Bug Hunting Session
Bug 66382 - FILEOPEN: MS .xlsx Fails to import properly. chart not displayed (6/6)
Summary: FILEOPEN: MS .xlsx Fails to import properly. chart not displayed (6/6)
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 19:07 UTC by Luke
Modified: 2013-07-02 18:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
MS .xlsx file imports incorrectly (468.90 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-29 19:13 UTC, Luke
Details
Comparison of xlsx in Excel vs Calc 7 (354.40 KB, image/png)
2013-06-29 19:18 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2013-06-29 19:07:41 UTC
This bug was tested LibreOffice v4.1 RC1 running in windows 7 and XP. It appears that LibreOffice loses formatting when importing MS xlsx files. I have attached an example.

Steps to reproduce the bug:
1. Open attached Demo-2012SummerOlympics.xlsx document in calc
2. Open attached Demo-2012SummerOlympics.xlsx document in Excel2010/Office 365
3. Compare the documents. 

Note item #7 in the screenshot that there is no sort options when you click on a column. If LO is missing this capability, please change to feature request.
Comment 1 Luke 2013-06-29 19:13:13 UTC
Created attachment 81712 [details]
MS .xlsx file imports incorrectly
Comment 2 Luke 2013-06-29 19:18:10 UTC
Created attachment 81719 [details]
Comparison of xlsx in Excel vs Calc 7
Comment 3 Jacques Guilleron 2013-07-01 13:27:53 UTC
Hello Luke,

I don't reproduce with LO 4.2.0.0.alpha0+
Build ID: ce0383d2950d3b0da2c457c8a406c1229de53571 & Windows 7 Home Premium.
This goal is achieved by previously using Document Converter Wizard.

Can you try it?

Thank you,

Jacques
Comment 4 Luke 2013-07-01 22:53:30 UTC
Jacques, Sorry I was not clear in my description. In Excel on row 4 of the Data worksheet, there is a drop down menu to filter and sort. LO does not give you these option. SHould this be reopened as a feature request?
Comment 5 Jacques Guilleron 2013-07-02 13:36:05 UTC
Hi Luke,

Perhaps it's me who was not very clear. Those options are filters (Data > Filter > AutoFilter in LO), but using Table function in Excel, they are automatically added to columns headings, so we don't see always the backward cooking.
The good news is that you can recover those filters by using File > Wizards > Document Converter. This is another way to open MS files. Uncheck Template, give it path for Excel source file, path for save .ods.

Have a nice day,

Jacques
Comment 6 Luke 2013-07-02 17:39:17 UTC
Yes, using the Wizards > Document Converter instead of File > Open results in the file being properly imported. I was unaware that there was a difference. Shouldn't both methods produce the same results? Is this a bug or by design?
Comment 7 Jacques Guilleron 2013-07-02 18:38:48 UTC
Hi Luke,

I don't know. Just keep in mind this can differ.

Regards,

Jacques