Bug Hunting Session
Bug 66387 - Editing: Hyperlinks do not work within a document
Summary: Editing: Hyperlinks do not work within a document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 21:21 UTC by proshka
Modified: 2013-10-16 17:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test.doc file (works fine for me) (10.50 KB, application/xml)
2013-07-03 10:26 UTC, retired
Details
Test.doc with TOC entry (10.50 KB, application/msword)
2013-07-03 15:49 UTC, proshka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description proshka 2013-06-29 21:21:31 UTC
When inserting a hyperlink to a position such a heading within a document it works while the document is open. After closing the document the target is replaced by a toc entry which does not point to anything in the document, rendering the hyperlink useless.
Comment 1 proshka 2013-07-02 20:45:37 UTC
.doc documents are affected by the bug.
Comment 2 retired 2013-07-03 10:26:33 UTC
Created attachment 81949 [details]
test.doc file (works fine for me)
Comment 3 retired 2013-07-03 10:28:40 UTC
Could not reproduce this on OS X 10.8.4 with LO 4.1.0.1.

Neither with Ubuntu 13.04.

Attaching my test.doc.

Proshka: Could you please attach your test document? After that set the bug to UNCONFIRMED.
Comment 4 proshka 2013-07-03 15:49:03 UTC
Created attachment 81963 [details]
Test.doc with TOC entry
Comment 5 Thomas Arnhold 2013-10-16 17:40:19 UTC
NOT reproducible on Windows 7 with

Version: 4.1.2.3
Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38

I followed your steps, but I don't get any broken links or toc entries. So closing this as WORKSFORME. If it still doesn't work for you please reopen the bug and give a detailed step by step description how your bug is reproducible.