Bug 66422 - UI: Allow to add a "X" grid button for charts
Summary: UI: Allow to add a "X" grid button for charts
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Tomaz Vajngerl
QA Contact:
URL:
Whiteboard: target:4.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-30 23:30 UTC by Francisco
Modified: 2013-07-09 15:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of deactivated "X" grid button added through editing configuration file (22.39 KB, image/png)
2013-06-30 23:33 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2013-06-30 23:30:20 UTC
In bug 64884 I stated incorrectly that there wasn't any possibility of adding X grids to a chart, after exiting the Chart wizard. I also tried to add a "X" grid button into the chart toolbar. I couldn't find a button for that, not even inside "Customize toolbar" dialog.

Steps:
1) create a chart
2) Try to add a "X" grid button with "Customize toolbar" option through right click

Actual:
1) It is not possible to add such button.

Expected:
1) The "X" grid button should be an available button in chart toolbar, as for "Y" grid

Additional information:
Also I tried to edit the file 

$HOME/.config/libreoffice/3/user/config/soffice.cfg/modules/schart/toolbar/toolbar.xml

there's a line: 

 <toolbar:toolbaritem xlink:href=".uno:ToggleGridHorizontal"/>

Wich, clearly indicates the button for "Y" gridlines. I added the following line 

 <toolbar:toolbaritem xlink:href=".uno:ToggleGridVertical"/>

below the first one. After starting Calc and inserting a chart, the new button appear, and it even has an icon... but saddly, it is disabled and  so it doesn't work

---
User bfoman showed that it was possible to add "X" grids after exiting the chart wizard through "Insert->grids" in menubar. But since he couln't find a wat to add a "X" grid button, he suggested to create a new bug report.
Comment 1 Francisco 2013-06-30 23:33:48 UTC
Created attachment 81769 [details]
screenshot of deactivated "X" grid button added through editing configuration file

This is how the chart toolbar looks after editing the file 

$HOME/.config/libreoffice/3/user/config/soffice.cfg/modules/schart/toolbar/toolbar.xml

and adding the line <toolbar:toolbaritem xlink:href=".uno:ToggleGridVertical"/>

That button seems to have even an icon, but it doesn't work.
Comment 2 Tomaz Vajngerl 2013-07-01 17:09:04 UTC
It should be fairly easy to add such a button. I am currently working around this code so I will take this bug.
Comment 3 Commit Notification 2013-07-04 18:31:18 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b5d481e2b96e2124021e6f80d2543a5904dad026

fdo#66422 Vertical grid toolbar button - choice major/minor/off



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Francisco 2013-07-08 17:12:11 UTC
The button now works in LibO Chart. 

The only thing I'm missing is how to add it the the chart toolbar through the Toolbar customization UI: I haven't been able to find it, but added editing file 

libreoffice/3/user/config/soffice.cfg/modules/schart/toolbar/toolbar.xml

in my profile.
Comment 5 Tomaz Vajngerl 2013-07-08 21:36:39 UTC
(In reply to comment #4)
> The button now works in LibO Chart. 
> 
> The only thing I'm missing is how to add it the the chart toolbar through
> the Toolbar customization UI: I haven't been able to find it, but added
> editing file 
> 
> libreoffice/3/user/config/soffice.cfg/modules/schart/toolbar/toolbar.xml
> 
> in my profile.

This toolbar button is now enabled and visible by default - previously the button was half done and could not work even if you forced it on the toolbar. Can you try it out with clean configuration folder - maybe your modification was the cause why it was not working for you. I tried it out on a daily build and both grid buttons appeared for me and worked.
Comment 6 Francisco 2013-07-09 03:17:10 UTC
(In reply to comment #5)
> This toolbar button is now enabled and visible by default - previously the
> button was half done and could not work even if you forced it on the
> toolbar. Can you try it out with clean configuration folder - maybe your
> modification was the cause why it was not working for you. I tried it out on
> a daily build and both grid buttons appeared for me and worked.

Hi Tomaz!

Yes, both buttons were working. What I couldn't do was add it in my libreofficedev profile (which was created by libo 4.1). I deleted that folder and the X grid button just appeared when I entered in the edit chart mode.

I think the bug is solved. Should it be marked, or wait until libO 4.2?

But there's still something else missing, that is, that I can't create a new custom toolbar (if I want, for any reason) with many buttons, including those buttons... or even any other char edit button. I haven't find the way. Any button for editing charts isn't reachable through customize toolbar UI. That was what I was referring when I said I didn't find the button.
Comment 7 Tomaz Vajngerl 2013-07-09 12:51:37 UTC
(In reply to comment #6)
> Hi Tomaz!
> 
> Yes, both buttons were working. What I couldn't do was add it in my
> libreofficedev profile (which was created by libo 4.1). I deleted that
> folder and the X grid button just appeared when I entered in the edit chart
> mode.
> 
> I think the bug is solved. Should it be marked, or wait until libO 4.2?
No need to wait - I have set it to resolved/fixed.

> But there's still something else missing, that is, that I can't create a new
> custom toolbar (if I want, for any reason) with many buttons, including
> those buttons... or even any other char edit button. I haven't find the way.
> Any button for editing charts isn't reachable through customize toolbar UI.
> That was what I was referring when I said I didn't find the button.
Ahh.. I understand now - this is indeed a problem. I think it is the best to make a new bug report about this.

Regards, Tomaž
Comment 8 Francisco 2013-07-09 15:39:09 UTC
(In reply to comment #7)
> Ahh.. I understand now - this is indeed a problem. I think it is the best to
> make a new bug report about this.
> 
> Regards, Tomaž

Ok, I think I will. But I've been seeing around charts for a while, and it seems to be that they need a lot work. So, I've been trying to review all the things I think are missing or not working properly (like this bug). I mean, all bugs should be filled separately, but I think that many of them are linked, and if solved separately, it will be more difficult.