Bug 66435 - Layoutmanager should prevent one tab alone in a row
Summary: Layoutmanager should prevent one tab alone in a row
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:4.2.0
Keywords: difficultyBeginner, easyHack, skillCpp
Depends on:
Blocks:
 
Reported: 2013-07-01 03:11 UTC by Dan Dascalescu
Modified: 2015-12-15 16:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Dascalescu 2013-07-01 03:11:05 UTC
In Writer, the Background tab (?) of the Paragraph dialog behaves unlike the other tabs in the window.

Screencast at http://screencast.com/t/xY7yxoUD
Comment 1 Zoltan Laszlo 2013-07-05 13:08:02 UTC
Confirmed in LibreOffice 4.1.0.1 on Win7 x64.
As far as functionality concerned behavior is normal but yes, it looks odd. Regrouping tabs in two rows in a way that the Background tab is not the only one in its row should fix the odd look.
Comment 2 Björn Michaelsen 2013-07-06 15:08:10 UTC
So the "odd" behaviour is that the second row of tabs actually has only one entry, which leads to behaviour which is not intuitive. A possible solution would be to either ensure that each row has at least two entries, or even better, distribute them ~evenly.

@Caolan: Easy Hack maybe, with a few code pointers?
Comment 3 Björn Michaelsen 2013-07-06 15:55:36 UTC
code pointers:

Rectangle TabControl::ImplGetTabRect( sal_uInt16 nItemPos, long nWidth, long nHeight )

in

vcl/source/control/tabctrl.cxx seems to be a good starting point:
http://opengrok.libreoffice.org/xref/core/vcl/source/control/tabctrl.cxx#344
Comment 4 Commit Notification 2013-08-26 20:19:54 UTC
Stefano Facchini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fa9a2aaa2246e6eb0665d36aa7c6c75fd31c4e3e

fdo#66435: distribute tabs more evenly across rows



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-08-26 20:20:13 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b224582aa3e7f0971035603515cf9c0e54ef299d

Related: fdo#66435 enhance decker-wrap using Minimum raggedness algo



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2013-08-27 08:52:40 UTC
all done now
Comment 7 Robinson Tryon (qubit) 2015-12-15 16:50:08 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner SkillCpp )
[NinjaEdit]