Bug Hunting Session
Bug 66438 - FORMATTING: Bad rendering letter spacing under Core Text
Summary: FORMATTING: Bad rendering letter spacing under Core Text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2013-07-01 04:58 UTC by deepjungle.maca
Modified: 2014-03-26 13:08 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Bad letter spacing (24.23 KB, image/png)
2013-07-01 05:00 UTC, deepjungle.maca
Details
Test case (15.75 KB, application/vnd.oasis.opendocument.text)
2013-07-01 05:03 UTC, deepjungle.maca
Details
Screenshot from 4.1 branch (27.94 KB, image/png)
2013-07-01 15:30 UTC, Khaled Hosny
Details
Side-to-side comparison print preview (AOO-LO) (147.82 KB, image/png)
2013-07-04 10:31 UTC, Emir Sarı (away)
Details
Ideal kerning example (Pages) (103.94 KB, image/png)
2013-07-04 10:35 UTC, Emir Sarı (away)
Details
LO 4.3.0.0a0+ 2014-03-26 looks good (183.41 KB, image/png)
2014-03-26 12:47 UTC, retired
Details
screenshot-master 26.03.13 (289.09 KB, image/png)
2014-03-26 13:08 UTC, Emir Sarı (away)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deepjungle.maca 2013-07-01 04:58:15 UTC
This is bug related to #66385

https://bugs.freedesktop.org/show_bug.cgi?id=66385
Comment 1 deepjungle.maca 2013-07-01 05:00:44 UTC
Created attachment 81776 [details]
Bad letter spacing
Comment 2 deepjungle.maca 2013-07-01 05:03:33 UTC
Created attachment 81777 [details]
Test case
Comment 3 Emir Sarı (away) 2013-07-01 11:33:23 UTC
Reproducible under 4.01.1 OS X 10.7.5
Comment 4 Khaled Hosny 2013-07-01 15:30:32 UTC
Created attachment 81817 [details]
Screenshot from 4.1 branch

I’m not sure which what you consider bad, please elaborate. Here is the rendering here.
Comment 5 deepjungle.maca 2013-07-01 16:31:19 UTC
Take a look at the words Fakulta or Thesis for instance on the screenshot. The space between first letter and the second one is wider than it would be.

This doesn't happen under the same Windows version of LibreOffice. The letter-spacing there is exactly same as in OpenOffice 4.0 on Mac as being on the screenshot.

I tried it on different machine with Mac OS X Lion 10.7.5. And the same problem.

It seems this issue is related to using Palatino Linotype font (Truetype variant, version 5.00 in my case).
Comment 6 Khaled Hosny 2013-07-01 17:38:59 UTC
The gap does not look as big on my machine (with a, so called, retina display), nevertheless there is an unnecessary gap but that is a side effect of using fake smallcaps which prevents the proper kerning between the F and A, but that is no Mac nor Core Text specific; I can see it on Linux as well.
Comment 7 deepjungle.maca 2013-07-03 10:49:25 UTC
I see the problem on retina displays won't be so significant thanks to so high DPI there. I don't know how to work Core Text exactly but I believe it behaves some different way in retina and in non-retina resolution.
Comment 8 Emir Sarı (away) 2013-07-04 10:31:18 UTC
Created attachment 82016 [details]
Side-to-side comparison print preview (AOO-LO)

This is a side-to side comparison with AOO. From a typographic point of view LOO kerning is definitely broken, small letters should always be rendered closer to capital letters.
Comment 9 Emir Sarı (away) 2013-07-04 10:35:12 UTC
Created attachment 82017 [details]
Ideal kerning example (Pages)

This is an example of the same file rendered by Pages (.doc). 

This is how it should look like. Both AOO and LO are inferior compared to Pages.
Comment 10 Khaled Hosny 2013-07-04 10:42:35 UTC
On my machine it looks exactly like your AOO screenshot (see attachment 81817 [details]), so either it was already fixed in RC2 or for some reason it is not happening to me.
Comment 11 Emir Sarı (away) 2013-07-04 10:47:11 UTC
By the way, I am always testing on master build. :)
Comment 12 Khaled Hosny 2013-07-04 10:53:46 UTC
No idea then, different OS may be, different hinting application, bad karma :), someone else who can reproduce this will have to debug it.
Comment 13 Emir Sarı (away) 2013-07-04 11:11:09 UTC
Joren, Alex,

Can you reproduce this?

Thanks in advance.
Comment 14 Alex Thurgood 2013-07-08 14:04:51 UTC
Confirming on master build :

Version: 4.2.0.0.alpha0+
Build ID: 0581c61c8b61041692befac101466190767e6597


with Mac OSX 10.8.4 on a Macbook Pro

Also tested on :

- NeoOffice 3.3 patch 5 : kerning problem
- LO 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539) : no problem
- LO 3.6.6.2 (Build ID: f969faf) : no problem
- LibreOffice 3.5.7.2 Version ID : 3215f89-f603614-ab984f2-7348103-1225a5b : no problem
- LibreOffice 3.3.4 OOO330m19 (Build:401) tag libreoffice-3.3.4.1 : no problem


Marking as regression.

Alex
Comment 15 Alex Thurgood 2013-07-08 14:15:51 UTC
Further testing :

OOo 3.4.1 : no problem
OOo 330m20 : no problem
Lotus Symphony 3.0.1 : no problem
TextEdit Version 1.8 (301) : kerning problem visible


Alex
Comment 16 Khaled Hosny 2013-07-08 22:40:32 UTC
AFAIK, latest versions of NeoOffice use Core Text, so if it, LibreOffice 4.1 and TextEdit show the same problem, then it is more likely to be a Core Text issue and I don’t think there is much we can do about it.
Comment 17 deepjungle.maca 2013-07-19 07:49:55 UTC
Any news about this bug?

BTW: In Pages (from Apple iWork) I don't have this problem.
Comment 18 deepjungle.maca 2013-08-24 22:53:05 UTC
Hello,
can this _critical_ bug be fixed soon? This bug affects also PDF export and printing on Mac. For me it means I can't use LO at all. I can't switch back to LO 4.0.x because it has tons different bugs fixed in 4.1 or 4.2 version.

Thanks a lot for your help guys.
Comment 19 deepjungle.maca 2013-10-23 09:57:19 UTC
I just upgraded to OS X Mavericks and it seems the problem is not appeared in this version of OS X :( I guess, the problem is under Core Text on Mountain Lion and former.

My current version of LO is 4.1.2.3.
Comment 20 Joel Madero 2014-03-25 23:47:40 UTC
I am downgrading this to normal - I cannot test as I don't have OSX but I can say this is not a critical bug.

Normal: Can prevent high quality work - that's as high as is appropriate

Joren: Can you test this at all against a daily?
Comment 21 retired 2014-03-26 12:46:56 UTC
WORKSFORME

Version: 4.3.0.0.alpha0+
Build ID: 003a27a14d5cf65fe0b528b6d6015e37a64dbb8e
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-03-26_02:39:10

Screenshot attached. Re-open if I missed something, but looks good to my eyes.
Comment 22 retired 2014-03-26 12:47:39 UTC
Created attachment 96410 [details]
LO 4.3.0.0a0+ 2014-03-26 looks good
Comment 23 Emir Sarı (away) 2014-03-26 13:08:13 UTC
Created attachment 96412 [details]
screenshot-master 26.03.13

I can still reproduce the issue under Lion, very weird.