Bug Hunting Session
Bug 66439 - FILEOPEN: writer crash during opening document
Summary: FILEOPEN: writer crash during opening document
Status: RESOLVED DUPLICATE of bug 64279
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-01 07:54 UTC by ondra.koncek
Modified: 2013-07-01 13:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
I attached document which I am not able to open after upgrade to libreoffice 4.0.4 (932.95 KB, application/vnd.oasis.opendocument.text)
2013-07-01 07:54 UTC, ondra.koncek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ondra.koncek 2013-07-01 07:54:31 UTC
Created attachment 81779 [details]
I attached document which I am not able to open after upgrade to libreoffice 4.0.4

Problem description: 
I have a problem with opening of the attached document written in Libre Office 4.0.3.3.

After crash ubuntu generates this bug report.






              
Operating System: Ubuntu
Version: 4.0.4.2 release
Last worked in: 4.0.3.3 release
Comment 1 Jorendc 2013-07-01 08:43:05 UTC
Hi,

Thanks for reporting!
I can reproduce a crash using Mac OSX 10.8.4 with LibreOffice 4.0.4.2.

I can NOT reproduce a crash using LibreOffice 4.1.0.1 RC1 and Version: 4.2.0.0.alpha0+ Build ID: 9ab800829b8a0e44824dc11276b54b1870bc5b2b

I don't have LibreOffice 4.0.3.3 around to test. But a in-branch regression looks quite bad to me :s. Also with our own ODF format.

@Bug reporter: Although you probably don't have a special build, is it possible to provide a backtrace and attach the log to this bug report? (See https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux). Thanks in advance


@Julien: you mind trying to get a backtrace too?

@Joel: any thoughts about this bug :s? Fixed in 4.1 and + versions, broken 4.0.3 (not tested) vs 4.0.4.

Kind regards,
Joren
Comment 2 Julien Nabet 2013-07-01 08:47:06 UTC
Joren: no problem but I'll be able to test after my day time job.
Comment 3 Michael Stahl (CIB) 2013-07-01 13:01:14 UTC
another duplicate

*** This bug has been marked as a duplicate of bug 64279 ***