Download it now!
Bug 66455 - Chart looses properties when it is copied/pasted to other spreadsheet
Summary: Chart looses properties when it is copied/pasted to other spreadsheet
Status: RESOLVED DUPLICATE of bug 62057
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-01 13:07 UTC by Clemens Eisserer
Modified: 2015-02-19 03:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
source document with intact chart (165.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-01 13:07 UTC, Clemens Eisserer
Details
destination spreadsheet with broken chart (12.58 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-01 13:08 UTC, Clemens Eisserer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2013-07-01 13:07:08 UTC
When copying (Ctrl+C) the chart from the attached source.ods-document and pasting (Ctrl+V) it into a fresh spreadsheet, it ends up like the chart in the also attached destination.ods spreadsheet.
Comment 1 Clemens Eisserer 2013-07-01 13:07:43 UTC
Created attachment 81798 [details]
source document with intact chart
Comment 2 Clemens Eisserer 2013-07-01 13:08:07 UTC
Created attachment 81799 [details]
destination spreadsheet with broken chart
Comment 3 Clemens Eisserer 2013-07-01 13:14:03 UTC
just noticed - copy&paste works in the same spreadsheet- it is only broken when pasting into a different spreadsheet.
Comment 4 retired 2013-07-03 11:34:34 UTC
This is flakey behavior. I can confirm that copy pasting works fine in the source.ods.

When pasting into destination or creating a new LO Spreadsheet and pasting the graph is displayed differently.

Not sure why that is, but since I can confirm the behavior: Setting to NEW.
Comment 5 David Tardon 2013-09-16 07:33:13 UTC

*** This bug has been marked as a duplicate of bug 62057 ***
Comment 6 Commit Notification 2015-02-19 03:19:19 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=52f4d152af4a0cad31ca6da43ae9e8fc55688aab

there is no x error bar for bar charts, related fdo#66455

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.