Bug Hunting Session
Bug 66464 - Queries based on linked tables not editable
Summary: Queries based on linked tables not editable
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:4.2.0 target:4.1.0.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-01 15:35 UTC by tim
Modified: 2013-07-10 15:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample linked table query. (4.05 KB, application/vnd.oasis.opendocument.base)
2013-07-01 15:35 UTC, tim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2013-07-01 15:35:53 UTC
Created attachment 81818 [details]
Sample linked table query.

In the example (to be attached), running Query1 on all 3.n versions of LO I have used produces a result set where the text fields can be edited.  This is true of this example using the embedded database, and of my main system using MySQl (Native and JDBC).

On LO 4,1,0.1 RC the data cannot be edited.  

For me this a blocker and I'll have to give up on using 4.1 (I couldn't use 4.0 due to other faults).  I had previously migrated to 4.1 since most problems were manageable.
Comment 1 Robert Großkopf 2013-07-01 20:12:04 UTC
I can confirm this bug. A query could be edited in nearly all LO-Versions, when there are the Primary-Keys of all tables included. Works with LO 3.5.7.2, LO 3.6.6.2, LO 4.0.3.3. Doesn't work with LO 3.3.4 and - new - with LO 4.1.0.1rc.
I have tested it with openSUSE 12.3 64bit rpm.
Comment 2 Commit Notification 2013-07-01 23:08:55 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=369e2d3e007fd9177c3500813feee22fc3a8a823

fdo#66464 initialise static join info at construct time



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2013-07-02 07:56:33 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a571129c94318ce5667f89cb6489561b8c161ee2&h=libreoffice-4-1

fdo#66464 initialise static join info at construct time


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 tim 2013-07-10 09:50:38 UTC
Confirm fixed on my 32-bit linux mint debian system.

Thanks.
Comment 5 tim 2013-07-10 09:51:06 UTC
Should have said - in 4.1.0.2 (RC2)
Comment 6 Lionel Elie Mamane 2013-07-10 15:02:50 UTC
Setting to VERIFIED (FIXED) as per Tim's comment.