Bug Hunting Session
Bug 66467 - Inserting URL via "Insert - Link to External Data..." leads to a crash
Summary: Inserting URL via "Insert - Link to External Data..." leads to a crash
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-01 16:43 UTC by Thomas Hackert
Modified: 2013-07-04 08:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
zipped backtrace, as original is 24K in size (3.10 KB, application/zip)
2013-07-01 16:44 UTC, Thomas Hackert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2013-07-01 16:43:53 UTC
Hello @ll,
I hope, I have chosen the right severity and all ... ;) If not, feel free to change it ... ;)

Steps to reproduce:
1. Open a new Calc speadsheet
2. Open "Insert - Link to External Data..."
3. Insert https://www.asnbank.nl/asnappl/scripts/koersen/koersen.asp into "URL of external data source"
4. Wait a bit
5. Press enter

LO crashes ... :( I will attach a gdbtrace log file afterwards.
Sorry for the inconvenience
Thomas.
Comment 1 Thomas Hackert 2013-07-01 16:44:33 UTC
Created attachment 81824 [details]
zipped backtrace, as original is 24K in size
Comment 2 Thomas van der Meulen 2013-07-01 16:51:33 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4.
Comment 3 Thomas van der Meulen 2013-07-01 17:48:00 UTC
Set to works for me because we have tested it out with the latest master and it was fixed. this bug is also discussed on IRC. 


tip: lets test this bug again wen rc2 comes out just to make sure
Comment 4 Thomas van der Meulen 2013-07-04 08:05:30 UTC
I can verify that it is fixed in LibreOffice 4.0.1.2.0 Build ID: 103a942746cfe346e87daab62acbd4268c38097 on mac osx 10.8.3.