Bug Hunting Session
Bug 66468 - Selecting new Personas Crashes LibreOffice
Summary: Selecting new Personas Crashes LibreOffice
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-01 19:44 UTC by Peter Maunder
Modified: 2013-07-05 08:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Maunder 2013-07-01 19:44:03 UTC
Applies to Ubuntu 12.04 desktop and Linux-Mint Mate 13. Using .config/libreoffice/4 file created by LibO 4.0.4.2 and with a working Personas.

Personalisation can switch to and from Plain view / Own theme.
Pasting new theme address like https://addons.mozilla.org/en-US/firefox/addon/10900/ causes Libreoffice 4.1.0.1 to crash. 

Duplicate of 66009 https  causes crash or 63498 Personas doesn't work anymore? 

Manual copying new Personas offline  called header.png, footer.png to .config/libreoffice/4/gallery/personas  works fine.
Comment 1 Julien Nabet 2013-07-02 19:50:27 UTC
Peter: https://addons.mozilla.org/en-US/firefox/addon/10900/ in Firefox returns this link:
https://addons.mozilla.org/en-US/firefox/addon/personas-plus/

Could you check url?
Comment 2 retired 2013-07-03 10:35:54 UTC
This is NOTABUG.

The URL is invalid. Following the Themes link provided in the according LO dialogue I can select any Firefox Persona just fine and use it on Ubuntu 13.04.

Peter: Could you please try again using the LO own dialogue instead of the config file. Also please try with a valid URL.
Comment 3 Peter Maunder 2013-07-05 08:23:40 UTC
James,

I deleted the ./config/libreoffice/4 file and went through the same procedure with 4.0.4.2 and 4.1.0.1 systems, deleting the file between each test.

On my system 4.0.4.2 allowed me to copy across the Personas from Firefox to provide my own theme as before.

4.1.0.1 crashed the LibreOffice system.

In both cases I did not create a /Gallery/Personas folder as I understand now that that was my misunderstanding of how the system worked.

However I have now recreated the /Gallery/Personas folder  in the /4 folder to allow me to use my own Personas and give a consistent look over Firefox/Thunderbird/LibreOffice 4.0.4.2 and 4.1.0.1.

I will recreate the test with 4.1.0.2 when that is available.