Bug Hunting Session
Bug 66538 - Other: Printer Setting dialog has incorrect layout in Japanese UI
Summary: Other: Printer Setting dialog has incorrect layout in Japanese UI
Status: RESOLVED DUPLICATE of bug 66502
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-03 07:20 UTC by Naruhiko Ogasawara
Modified: 2013-07-03 13:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The Printer Settings dialog with a problem (in Japanese; 4.1 RC1) (25.71 KB, image/png)
2013-07-03 07:20 UTC, Naruhiko Ogasawara
Details
The Printer Setting dialog without a problem (in Japanese, 4.0) (35.15 KB, image/png)
2013-07-03 07:22 UTC, Naruhiko Ogasawara
Details
Printer settings dialog after fix 66502 (26.89 KB, image/png)
2013-07-03 13:01 UTC, ikuya
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Naruhiko Ogasawara 2013-07-03 07:20:42 UTC
Created attachment 81938 [details]
The Printer Settings dialog with a problem (in Japanese; 4.1 RC1)

Problem description: 

Steps to reproduce:
1. Select Japanese as a User Interface language
2. Open menu "ファイル(File)" -> "プリンターの設定(Printer Settings)..."

Current behavior:

The button "オプション(Option)" covers another button "OK."
See attached file Printer-Setting-LibO-4.1-RC1-JA.png 


Expected behavior:

Each buttons put on separately, not covered each other.

NOTE: 4.0 series is OK.
      With 4.1 RC1, English and Simplified Chinese UI are OK.
Operating System: All
Version: 4.1.0.1 rc
Last worked in: 4.0.4.2 release
Comment 1 Naruhiko Ogasawara 2013-07-03 07:22:51 UTC
Created attachment 81939 [details]
The Printer Setting dialog without a problem (in Japanese, 4.0)
Comment 2 Naruhiko Ogasawara 2013-07-03 07:25:55 UTC
This bug is similar as another layout issue (fdo#66502), but little different (e.g. it doesn't cause with Simplified Chinese UI), so I filed it separately.
Comment 3 Jorendc 2013-07-03 08:05:16 UTC
Thanks for reporting. I can indeed reproduce this behavior, but I think this is fixed thanks to caolan's fix for bug 66502 (as far I can see the fix is in a shared code which 'all' dialogs use, not dialog-specific code).

@Caolan: am I right :)?

Kind regards,
Joren
Comment 4 ikuya 2013-07-03 13:01:56 UTC
Created attachment 81958 [details]
Printer settings dialog after fix 66502

It seems to fix this issue by bug 66502.
Comment 5 Jorendc 2013-07-03 13:14:10 UTC
(In reply to comment #4)
> Created attachment 81958 [details]
> Printer settings dialog after fix 66502
> 
> It seems to fix this issue by bug 66502.

Thanks for testing!
Lets mark it as dupe of 66502 then (same root cause).

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 66502 ***