Bug 66572 - Images Do Not Scale Properly
Summary: Images Do Not Scale Properly
Status: RESOLVED DUPLICATE of bug 65870
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-04 03:43 UTC by Sharky
Modified: 2013-07-09 09:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample image for scaling failure (44.92 KB, application/vnd.oasis.opendocument.presentation)
2013-07-04 05:15 UTC, Sharky
Details
Screenshot of the sample in LibreOffice 3.6.6.2 (113.25 KB, image/png)
2013-07-04 12:37 UTC, Kevin Suo
Details
Scaled image in 3.6.6.2 (137.39 KB, image/png)
2013-07-04 12:43 UTC, Kevin Suo
Details
worksforme (142.91 KB, image/png)
2013-07-04 14:03 UTC, retired
Details
Screenshot of Image Height Scaling Problem (465.51 KB, image/png)
2013-07-05 16:58 UTC, Sharky
Details
More thorough presentation slide of scalling failure (64.43 KB, application/vnd.oasis.opendocument.presentation)
2013-07-05 16:59 UTC, Sharky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sharky 2013-07-04 03:43:23 UTC
Even with keep ratio checked, picture does not scale properly for height, resulting in a stretched out appearance.
Comment 1 ign_christian 2013-07-04 03:58:29 UTC
Please supply sample file (along with screenshot of what is expected/unexpected if possible) & steps to reproduce that problem. Otherwise no one could confirm your report.

Then please mark this bug UNCONFIRMED
Comment 2 Sharky 2013-07-04 05:15:07 UTC
Created attachment 82004 [details]
Sample image for scaling failure
Comment 3 Kevin Suo 2013-07-04 12:37:14 UTC
Created attachment 82022 [details]
Screenshot of the sample in LibreOffice 3.6.6.2

I am not sure what you are expecting.
This is the screenshot of your sample file in LibreOffice 3.6.6.2. I don't think the image is wrongly scaled.
Comment 4 Kevin Suo 2013-07-04 12:43:10 UTC
Created attachment 82023 [details]
Scaled image in 3.6.6.2

This is a scaled image of your sample file, with keep-ratio option on.
This shows correct scaling I believe.
Comment 5 retired 2013-07-04 14:02:55 UTC
Tested with LO 4.1.0.2, OS X 10.8.4.

Looks good to my eyes.

Adjusting Importance to medium and normal and setting to WORKSFORME.

Sharky, could you post a screenshot of the issue happening and explain what is wrong? If you still see this feel free to re-open.
Comment 6 retired 2013-07-04 14:03:24 UTC
Created attachment 82025 [details]
worksforme
Comment 7 Sharky 2013-07-05 04:11:50 UTC
No one tested this with 4.1.0.1?
Comment 8 Sharky 2013-07-05 04:13:21 UTC
I can add a screenshot later when I get some time, but hopefully this just doesn't occur in 4.1.0.2 or something.
Comment 9 Sharky 2013-07-05 16:58:06 UTC
Created attachment 82085 [details]
Screenshot of Image Height Scaling Problem
Comment 10 Sharky 2013-07-05 16:59:00 UTC
Created attachment 82086 [details]
More thorough presentation slide of scalling failure
Comment 11 Sharky 2013-07-06 02:27:51 UTC
When I switch back to the current version of Writer (4.0.4.2) this scaling problem also goes away. I.e, it only seems to show up in the latest prerelease.
Comment 12 ign_christian 2013-07-06 12:02:26 UTC
Hi Sharky, James has said on comment 5 that it's ok with 4.1.0.2. Have you tested with that release?

You can only reopened this bug if you reproduce the problem with that release or later.

So we mark that NEEDINFO until you confirm
Comment 13 Sharky 2013-07-07 03:18:32 UTC
Unfortunately no, the latest prerelease I see is 4.1.0.1.

http://www.libreoffice.org/download/pre-releases/

It looks like all the cool kids have 4.1.0.2 or something. It's not something I seem to be able to find (nightly builds?)
Comment 14 ign_christian 2013-07-08 01:30:24 UTC
It's available now, or you could use this link instead:
http://dev-builds.libreoffice.org/pre-releases/
Comment 15 David Tardon 2013-07-09 09:40:55 UTC

*** This bug has been marked as a duplicate of bug 65870 ***