Bug 66622 - PDF export: pictures disappeared
Summary: PDF export: pictures disappeared
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Fargus
URL:
Whiteboard: target:4.2.0 target:4.1.0.2 target:4.0.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-05 14:53 UTC by Fargus
Modified: 2013-10-09 21:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
file with pictures (104.53 KB, application/vnd.oasis.opendocument.text)
2013-07-05 14:53 UTC, Fargus
Details
pdf file made in 4.0.4.2 version from .odt (208.04 KB, application/pdf)
2013-07-05 14:54 UTC, Fargus
Details
use this file to make pdf (8.33 KB, application/vnd.oasis.opendocument.text)
2013-07-29 20:48 UTC, Fargus
Details
you will receive this pdf file with infinity characters instead of dots (7.95 KB, application/pdf)
2013-07-29 20:49 UTC, Fargus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fargus 2013-07-05 14:53:41 UTC
Created attachment 82078 [details]
file with pictures

See the attached files.
During export to pdf pictures a not seen (they disapered).
Also may be problems to see pictures in .odt file in windows versions prior to 4.0.0.
Comment 1 Fargus 2013-07-05 14:54:24 UTC
Created attachment 82079 [details]
pdf file made in 4.0.4.2 version from .odt
Comment 2 Thomas van der Meulen 2013-07-05 16:11:10 UTC
Thank you for your bug report, I CANNOT reproduce this bug running LibreOffice ersion: 4.1.0.2.0
Build ID: 103a942746cfe346e87daab62acbd4268c38097on Mac osx 10.8.4. 

But I can reproduce this bug in LibreOffice 4.0.4.2 so it is fixed in 4.1 branch.

Set to worksforme.
Comment 3 Cor Nouws 2013-07-11 08:15:17 UTC
@thomas:
when it is fixed in 4.1 branch but not in 4.0.4, then the bug should be evaluated for fixing in 4.0.5/4.0.6 etc. 
I set it to regression too.
Should it be a MAB, what do you think?

Cheers,
Cor
Comment 4 Michael Stahl (CIB) 2013-07-12 22:24:54 UTC
this was fixed in 4.0.5 by commit 3553fa71b695c6c354872a77747ac4eb4bbff364
Comment 5 Cor Nouws 2013-07-13 06:06:36 UTC
(In reply to comment #4)
> this was fixed in 4.0.5 by commit 3553fa71b695c6c354872a77747ac4eb4bbff364

thanks :)
Comment 6 Fargus 2013-07-29 20:48:50 UTC
Created attachment 83241 [details]
use this file to make pdf

Linux x86_64 version: 4.1.0.4 + Russian language and Russian help
ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 7 Fargus 2013-07-29 20:49:59 UTC
Created attachment 83242 [details]
you will receive this pdf file with infinity characters instead of dots

Linux x86_64 version: 4.1.0.4 + Russian language and Russian help
ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 8 Thomas van der Meulen 2013-07-30 06:38:25 UTC
I CANNOT reproduce this bug running LibreOffice Version: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
os: mac osx 10.8.4
Comment 9 Fargus 2013-09-06 20:16:17 UTC
You are creating a new file instead of opening attched .odt and to make pdf from it.
If you will edit an attached file and select dot-marks in list you will receive correct pdf, but it is impossible to edit more then 100 places in document.

May be the problem is in imported data from MSWord. But why it is shown normally in the Writer and export is incorrect.
Comment 10 Michael Stahl (CIB) 2013-10-09 21:56:58 UTC
apparently comment #6 is a problem that is totally unrelated to the
description of this bug. please file a separate bug.
Comment 11 Michael Stahl (CIB) 2013-10-09 21:57:27 UTC
Comment on attachment 83241 [details]
use this file to make pdf

attachment unrelated to this bug
Comment 12 Michael Stahl (CIB) 2013-10-09 21:57:35 UTC
Comment on attachment 83242 [details]
you will receive this pdf file with infinity characters instead of dots

attachment unrelated to this bug