Download it now!
Bug 66645 - XHTML export: bad alignment/spacing of mathematical expressions
Summary: XHTML export: bad alignment/spacing of mathematical expressions
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.0
Keywords:
Depends on:
Blocks: HTML-Export
  Show dependency treegraph
 
Reported: 2013-07-06 13:58 UTC by Frédéric Wang
Modified: 2018-06-27 02:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
testcase (110.50 KB, application/vnd.oasis.opendocument.text)
2013-07-06 13:58 UTC, Frédéric Wang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Wang 2013-07-06 13:58:33 UTC
Created attachment 82122 [details]
testcase

draw:frame with MathML expressions contain margin-left, margin-right and vertical-align styles that make the alignment and spacing of mathematical formulas incorrect. Try to export the testcase to XHTML.
Comment 1 Frédéric Wang 2013-07-06 14:06:28 UTC
I've submitted a patch for review:

https://gerrit.libreoffice.org/4751

This should fix the bad vertical alignment of formulas. A space before/after the <math> element is now added which may be less artificial than margin properties (issues remain when an inline formula is followed by e.g. a comma or period).
Comment 2 Commit Notification 2013-07-09 09:11:53 UTC
Frederic Wang committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb2edd686c8b8ba4318e957f7cf23060ffd3e2c3

  fdo#66645 XHTML export: ignore incorrect style on math objects



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 retired 2013-07-09 10:36:09 UTC
Already fixed?

Setting to NEW with compliments from jorendc :)
Comment 4 Xisco Faulí 2016-10-23 12:44:23 UTC
Hello Frederic,
Is this bug already fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 5 QA Administrators 2018-06-27 02:47:31 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug