Bug 66736 - SLIDESHOW: Slide show hyperlink needs presentee's screen focus
Summary: SLIDESHOW: Slide show hyperlink needs presentee's screen focus
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA repro:6.0+
Keywords:
Depends on:
Blocks: Slide-Page-Pane Slide-Show Hyperlink
  Show dependency treegraph
 
Reported: 2013-07-09 13:22 UTC by andybstaples
Modified: 2019-06-20 02:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Files required for example. Place batch file in root C drive click the link in presentation (72.06 KB, application/zip)
2014-07-21 18:18 UTC, andybstaples
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andybstaples 2013-07-09 13:22:07 UTC
Problem description: Viewing a slide show on two screens. The presenter clicks on a hyperlink to a batchfile on the presenter's screen. Nothing happens until the mouse is moved to the presentee's screen

Steps to reproduce:
1. Open a presentation that has a hyperlink to a batch file in it
2. Run the slide show (F5)
3. In the presenter's window, go to the slide with the hyperlink on it
4. Click the link.

Current behavior: 
The batch file is not run until the presenter moves the mouse into the presentee's window (the main slide show window).

Expected behavior:
The batch file should run immediately from where ever the link is clicked.

Sub-issue:
Mouse icon does not change to a hand when hovering over hypertext on presenter's window. 

              
Operating System: Windows 7
Version: 4.0.4.2 release
Comment 1 ign_christian 2014-07-02 14:06:11 UTC
Hello.. Does it solved in LO 4.2.5.2 or 4.3.0.1? 

If no please change status back to UNCONFIRMED & give more details about last situation, otherwise RESOLVED WORKSFORME
Comment 2 andybstaples 2014-07-02 15:58:02 UTC
The issue persists in version 4.3.0.1:

There isn't more I can add, my original report says it all I think.

1. Requirement: Impress on a computer with two monitors
2. Open a presentation that has a link (I have a link to a batch file) on some page
3. Run the presentation (F5)
4. On the Presenter's screen, the "control screen", click the link
5. You'll notice the action does not get generated until the mouse is scrolled to the other monitor, the Presentation screen.

Further details found in original report.
Comment 3 beimaginativeegroup 2014-07-18 18:14:57 UTC
Can you add a sample file?
Comment 4 andybstaples 2014-07-21 18:18:21 UTC
Created attachment 103207 [details]
Files required for example. Place batch file in root C drive click the link in presentation
Comment 5 andybstaples 2014-07-21 18:20:57 UTC
So, place the batch file in your root C drive (I'm presuming Windows). Open the presentation with LibreOffice. Enter presentation mode (press F5). Click the link from the presenter's screen... the link won't fire (calculator won't start) until the mouse is moved to the Presentation screen (the audience's screen)
Comment 6 retired 2014-07-27 12:15:40 UTC
Thanks Andy, a test file is most helpful (as always).

OS X 10.9.4, LO 4.3.0.3 I can confirm that when F5 showing the test file presentation in a two monitor setup, the link does nothing when clicked on the presenters screen.

On OS X I then get a nice error message that no default browser would be defined (which is not true, chromium is the default browser here) as soon as I move the mouse over to the second screen showing the presentation.

So OS: all, state: NEW. Imo rather serious issue so setting to major, since for me it causes LO to hang or at least do nothing when clicking that link.
Comment 7 QA Administrators 2015-09-04 02:49:50 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2016-09-20 10:29:53 UTC Comment hidden (obsolete)
Comment 9 Timur 2017-09-08 12:56:51 UTC
Since integration in 3.3. Repro in 6.0+. Trivial.
Comment 10 QA Administrators 2019-06-20 02:49:29 UTC
Dear andybstaples,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug