Bug Hunting Session
Bug 66750 - Identify regression hotspots
Summary: Identify regression hotspots
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: http://dev-builds.libreoffice.org/lco...
Whiteboard:
Keywords: difficultyBeginner, easyHack, skillScript
Depends on:
Blocks: 70448
  Show dependency treegraph
 
Reported: 2013-07-09 21:28 UTC by Björn Michaelsen
Modified: 2016-02-18 16:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2013-07-09 21:28:56 UTC
We now have a few years and releases of LibreOffice behind us, thus our bugzilla data should be in an acceptable state to maybe gain some insight in the areas where we are most likely to regress.

This EasyHack suggests to:
- query and collect bugs marked as regressions on bugzilla
- then find the corresponding commits on git
- count by how many regression-fix-commits each directory was touched.

This might allow us to focus our attention on the critical areas for writing unit tests and get our coverage up in that area first:

see also:

 http://nabble.documentfoundation.org/build-with-code-coverage-td4064424.html
 http://dev-builds.libreoffice.org/lcov_reports/master~2013-07-08_14.53.51/
Comment 1 John Smith 2013-07-23 15:33:54 UTC
I renamed that 2nd link mentioned, so that the git commit SHA1 is part of the name (so you can tell on what revision the report was run). So the 2nd link mentioned above is no longer valid. Ooops.

Look here instead: http://dev-builds.libreoffice.org/lcov_reports/master~2013-07-08_14.53.51_commit-3a393557152ec61ebfe75580db0a2e321febfda3/
Comment 2 Björn Michaelsen 2013-10-04 18:46:18 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 3 Björn Michaelsen 2013-10-14 10:06:56 UTC
done with http://cgit.freedesktop.org/libreoffice/contrib/dev-tools/commit/?id=fc7dcf4ebef84c66f59f7188d02c8706a0993b51

script is at:

http://cgit.freedesktop.org/libreoffice/contrib/dev-tools/diff/scripts/regression-hotspots.py?id=fc7dcf4ebef84c66f59f7188d02c8706a0993b51

it currently takes ~200 minutes to run completely.

One note -- it is still buggy in that git log --stat prints incomplete filepaths a la ..../foo/baz.cxx if the filename is too long, but it already gives a good hint on the hotspots.
Comment 4 Stephan Bergmann 2013-10-14 11:45:59 UTC
(In reply to comment #3)
> it currently takes ~200 minutes to run completely.

Could you make available the output (or the top N lines of output), so one gets an idea what that looks like in under 200 minutes?
Comment 6 Robinson Tryon (qubit) 2015-12-16 00:01:21 UTC
Migrating Whiteboard tags to Keywords: (EasyHack SkillScript DifficultyBeginner)
[NinjaEdit]
Comment 7 Robinson Tryon (qubit) 2016-02-18 16:37:06 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]