Bug Hunting Session
Bug 66756 - FORMATTING: Bullets and numbering -- set incremental indent for all levels
Summary: FORMATTING: Bullets and numbering -- set incremental indent for all levels
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: https://msdnshared.blob.core.windows....
Whiteboard:
Keywords:
Depends on:
Blocks: Bullet-Numbering-Dialog Writer-Enhancements
  Show dependency treegraph
 
Reported: 2013-07-10 08:07 UTC by p199999991
Modified: 2019-09-07 03:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p199999991 2013-07-10 08:07:14 UTC
It would be good to have a way to specify the indent of the first level, and an indent increment for each level relative to the previous, like Word 2010.
Comment 1 Thomas Lendo 2019-06-08 14:08:56 UTC
Adding needsUXEval to discuss that.

For me, this is a request I thought about my very first use of numbering in Writer! What's possible should be (re-)arranged automatically to ease the user's life. Maybe a checkbox is sufficient to toggle if it's relative or manual changed.
Comment 2 Heiko Tietze 2019-07-22 13:46:33 UTC
Don't see much advantage here. If we introduce relative values we need an option to switch back as users are familiar with absolute values and wouldn't accept a hard cut. And I don't see the behavior in MSO: bullet position is 0.63cm by default for the first level and when I tab to second it's 1.9cm (context menu > adjust list indents). So WFM from my side.
Comment 3 Heiko Tietze 2019-07-25 12:23:13 UTC
No further input, so closing as WFM.
Comment 4 p199999991 2019-08-09 14:36:11 UTC
Sorry for the lack of response. In MSO, if you create a new outline numbering, you can specify to automatically set indents for all levels using an increment value. That is what I am talking about.
Comment 5 Heiko Tietze 2019-08-12 08:21:28 UTC
We do not copycat MSO. And the benefit over absolute values is totally unclear to me. Of course, you don't need to specify every level in detail but you loose the ability to do so. The UI would need more changes: the mentioned checkbox is a global option while everything today belongs to a certain level. 
So I'm still against this change.

(I don't close reopened tickets)
Comment 6 Xisco Faulí 2019-08-12 11:12:33 UTC
(In reply to Heiko Tietze from comment #5)
> We do not copycat MSO. And the benefit over absolute values is totally
> unclear to me. Of course, you don't need to specify every level in detail
> but you loose the ability to do so. The UI would need more changes: the
> mentioned checkbox is a global option while everything today belongs to a
> certain level. 
> So I'm still against this change.
> 
> (I don't close reopened tickets)

+1.
Closing as RESOLVED WORKSFORME
Comment 7 p199999991 2019-08-30 15:49:39 UTC
I think I am being misunderstood. I don't mean that you force the indents to become relative to the previous level. I mean that there should be a way to automatically set incrementally indented lists (i.e. help the user to set the increasing indents). I added URLs to this bug to illustrate how Microsoft Word allows this. Maybe those were overlooked.
Comment 8 Heiko Tietze 2019-09-03 07:39:48 UTC
(In reply to p199999991 from comment #7)
> I mean that there should be a way to automatically set incrementally 
> indented lists

Sure, you want to set level 1 at 1cm and all consecutive at plus 0.5cm. But read my comment #2, it complicates things and we better provide more list styles. I could imagine extensions that you just have to install. So still a WFM.
Comment 9 Dieter Praas 2019-09-04 14:50:46 UTC
I don't understand, why this report is set to UNCONFIRMED, after it was set to REOPENED, because status was NEW before it was closed

=> NEW
Comment 10 bradly 2019-09-07 03:18:52 UTC Comment hidden (spam)