Bug 66782 - FILEOPEN Office XML row ids are not imported
Summary: FILEOPEN Office XML row ids are not imported
Status: RESOLVED DUPLICATE of bug 62990
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-10 15:40 UTC by miguel gutierrez
Modified: 2014-10-15 15:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
PDT Plame-generated XML (61.13 KB, text/xml)
2013-07-10 15:40 UTC, miguel gutierrez
Details
how it looks in Excel 2010 (191.88 KB, application/pdf)
2014-03-31 15:26 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description miguel gutierrez 2013-07-10 15:40:27 UTC
Created attachment 82283 [details]
PDT Plame-generated XML

Cuando abro un archivo XML considera la ubicación de las filas por encima del resto, quedando oculto el contenido de la siguiente fila.

adjunto el archivo XML, fila 7, 8, 9, solo debería ser fila 7, 8 y 9 corresponden a otros datos, sucede lo mismo con la fila 20, 21 y 22
Gracias
Operating System: Windows 8
Version: 4.1.0.0.beta2
Comment 1 m.a.riosv 2013-07-10 22:43:35 UTC
Hola tocayo,

este sistema de comunicar los errores en el programa es utilizado en inglés. Por favor si te es posible haz el comentario en inglés, sino hazlo saber e intentaremos traducirlo.
Las celdas 7-8-9 están unidas por eso solo se ve el texto de la 7.
Menú/Formato/Unir celdas.

This system is used in English, please do the comment in English, if you can't let us know and we try to translate.
Cells 7-8-9 are merged, this why only the text in 7 is being saw.
Menu/Format/Merge cells
Comment 2 Urmas 2013-07-11 02:34:30 UTC
Confirmed with master. The row indices specified in the file are ignored on import.
Comment 3 Xisco Faulí 2014-03-31 15:25:26 UTC
it's still reproducible with:

   - Libreoffice 4.1.5.3 Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24
   - Libreoffice 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
   - Libreoffice 4.3.0.0.alpha0 Build ID: b6a43bcbbf9e9a5655fd36fd4c8ef72d585f67b0

Row 14, 15, 29 and 30 are missed in Libreoffice.
Comment 4 Xisco Faulí 2014-03-31 15:26:30 UTC
Created attachment 96670 [details]
how it looks in Excel 2010
Comment 5 m.a.riosv 2014-03-31 21:33:08 UTC
Cells in Rows 7+8+9, 20+21+22 and 33+34+35 are merged.

Selecting the rows and breaking the merge of cells shows all data like in excel.
Comment 6 Urmas 2014-10-15 15:40:38 UTC

*** This bug has been marked as a duplicate of bug 62990 ***