Bug Hunting Session
Bug 66818 - Font kerning cannot be disabled (for OpenType fonts)
Summary: Font kerning cannot be disabled (for OpenType fonts)
Status: RESOLVED DUPLICATE of bug 105454
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: HarfBuzz
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2013-07-11 11:34 UTC by Jan_J
Modified: 2018-04-05 23:12 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A sample text with different font options and reference rendering shots (91.65 KB, application/vnd.oasis.opendocument.text)
2013-07-11 11:34 UTC, Jan_J
Details
Reference rendering done by OpenOffice.org 3.3.0: here OTF kerns are ignored (40.69 KB, image/png)
2013-07-11 12:40 UTC, Jan_J
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan_J 2013-07-11 11:34:57 UTC
Created attachment 82332 [details]
A sample text with different font options and reference rendering shots

Kerning cannot be disabled for OpenType fonts.
Checking <Format/Character/Position/[ ] Kerning> takes no effect. Kerning seems to be always enabled.
Comment 1 Cor Nouws 2013-07-11 12:16:32 UTC
Hi Jan,
Thanks for the report.
Looking at the screen prints, and how it shows in 3.6.6. I would say that kerning is always disabled. both for OpenType and TT ...
Can you check/confirm this pls?
regards,
Cor
Comment 2 Jan_J 2013-07-11 12:40:26 UTC
Created attachment 82337 [details]
Reference rendering done by OpenOffice.org 3.3.0: here OTF kerns are ignored

Hello Cor,
thanks for the response. 

I confirm both my screenshots. First of them has been made from LO 4.1 rc2. Here we see no differences between variants, while typical tight kern pairs like "Ty" and "Wa" are typesetted closely. Hence I guess the kerning to be enabled.

The second shot shows the rendering done by LO 4.0. There 1st variant is
tight, while the 2nd (with kerning disabled) seems rather loose.

In all previous versions of Writer I suspect OTF kerns to be ignored. This
has been confirmed also by Your test.

In the attachment to currnt post I submit a reference rendering made by Oracle
OOo 3.3.0. This completely ignores kerning, as discussed above.
Comment 3 Khaled Hosny 2013-07-12 01:52:40 UTC
Right, we currently always enable kerning and Ligatures on Linux and Mac (it have been always like that on Mac). The handling of OpenType features in the UI needs some thinking, what we have now is a relic of different era.
Comment 4 Jan_J 2013-07-12 07:18:26 UTC
Support for OpenType features in Writer under Linux is quite new. That is a complex task; it's nice to see a progress an much better to have restricted support for the most wanted functions (like default kerning or ligatures) than to use raw font glyphs, asit has been at previous versions.
Thank you; we will wait for further successes in development.
Comment 5 Cor Nouws 2013-07-12 19:32:31 UTC
Hi Jan,
Sorry for mixing kerning and non-kerning!

Jan, Kahled: thanks for the insightful and positive comments.

Maybe we should set the version to 3.3.0, since what we see has never been working before?
Comment 6 Volga 2016-02-10 17:32:42 UTC
I founs recent version of LO for Windows started supporting OT kerning, but without any mention. I don’t know how LO developers got it.
Comment 7 Volga 2016-03-10 19:31:28 UTC
LO 5.1.1 seems disabled OT kerning on Windows 10.
Comment 8 Khaled Hosny 2016-11-04 12:41:11 UTC
The kerning settings are still ignored, but one can disable kerning manually now by appending the feature to the font name in the same syntax that was supported for graphite fonts, e.g., Foo Sans:-kern.
Comment 9 Khaled Hosny 2017-03-28 18:49:38 UTC

*** This bug has been marked as a duplicate of bug 105454 ***