Bug 66832 - PERFORMANCE: Writer hangs for several seconds while opening a file, cause by large styles.xml
Summary: PERFORMANCE: Writer hangs for several seconds while opening a file, cause by ...
Status: RESOLVED DUPLICATE of bug 67303
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, regression
Depends on:
Blocks:
 
Reported: 2013-07-11 17:56 UTC by Ruslan Kabatsayev
Modified: 2015-12-15 11:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (22.13 KB, image/png)
2013-07-11 17:56 UTC, Ruslan Kabatsayev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Kabatsayev 2013-07-11 17:56:54 UTC
Created attachment 82343 [details]
Screenshot

See this file: https://bugs.freedesktop.org/attachment.cgi?id=81761 . Writer hangs for several seconds at stage shown in screenshot.
Comment 1 Cor Nouws 2013-07-11 18:49:06 UTC
Hi Russian,
Thanks for the report. Can confrim the behaviour.
Strange. Even if I set all to default, par style Standard and remove the content: the pause in loading remains.
So must be something in one of the xml files in the odt(zip)-container ?!

Do you know how this worked in older versions?

Best,
Cor
Comment 2 Ruslan Kabatsayev 2013-07-11 19:12:38 UTC
> So must be something in one of the xml files in the odt(zip)-container ?!
I guess this should be related to 1 Meg file styles.xml.
> Do you know how this worked in older versions?
It appears to load almost instantly (lag about 500ms) in 3.5.3rc2+, and starts to hang (lag about 2 seconds) in 3.6.5.0+.
Comment 3 Cor Nouws 2013-07-12 18:02:37 UTC
Thanks - according to your info I change the summary and version!

Do you know if this is a 'regular' file ?
Comment 4 Cor Nouws 2013-07-12 18:08:13 UTC
changing version 4.0.0alpha1 does not show the delay, 4.0.0beta1 does
Comment 5 Ruslan Kabatsayev 2013-07-12 18:44:49 UTC
(In reply to comment #3)
> Do you know if this is a 'regular' file ?
I'm not sure, I came across it while looking at another bug report which had this file attached.
Comment 6 Michael Stahl (CIB) 2013-07-27 15:45:06 UTC
just 735 styles, the other bugdoc was more impressive :)

*** This bug has been marked as a duplicate of bug 67303 ***
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:05:10 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]