Bug 66840 - UI Provide UI option to pull updated styles from mother template
Summary: UI Provide UI option to pull updated styles from mother template
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Templates Styles-Management
  Show dependency treegraph
 
Reported: 2013-07-12 03:19 UTC by severoraz
Modified: 2017-12-13 10:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description severoraz 2013-07-12 03:19:38 UTC
Although every time a document is opened libreoffice offers to update its styles according to the template the document is based on (if the template was updated, of course), it would come in handy to have an action in the interface which let you update the styles manually. Perhaps even notify the user when the mother template is updated and offer to update the local styles too.
              
Operating System: All
Version: 3.3 all versions
Comment 1 m.a.riosv 2013-07-12 22:19:53 UTC
Hi wolterh6, thanks for reporting.

The version reported is outdated and closed for maintaining.
Can  you try with a updated version?.

Here the release plan:
https://wiki.documentfoundation.org/ReleasePlan

The official page for download:
http://www.libreoffice.org/download/

All versions for download:
http://downloadarchive.documentfoundation.org/libreoffice/old/?C=N;O=D
Comment 2 severoraz 2013-07-12 22:45:15 UTC
Sorry I don't know if what I did was right or wrong, I read once that the bug should have as version the earliest manifesting the bug. I am using 4.0.4.2 though.
Comment 3 m.a.riosv 2013-07-13 01:13:13 UTC
Don't worry wolter, maybe you are right, but IMO select a previous version to the oldest in maintenance, does not help too much, one can always mention in the comment what is the oldest version with the issue.
Comment 4 severoraz 2013-07-13 04:05:18 UTC
Haha yes indeed; I will do that from now on.
Comment 5 Cor Nouws 2014-02-03 21:57:10 UTC
(In reply to comment #3)
> Don't worry wolter, maybe you are right, but IMO select a previous version
> to the oldest in maintenance, does not help too much, one can always mention
> in the comment what is the oldest version with the issue.

It's a policy mariosv to set the oldest know version in the field version .. ;)
Comment 6 m.a.riosv 2014-02-05 22:50:54 UTC
Hi Cor, sure you are right, but being this is a request for enhancement, maybe is needed to do a global change for all request for enhancement. IMHO with the exception of few request for reverting a feature change, all should have then the oldest version. :)