Bug Hunting Session
Bug 66900 - [SVG] The exported file in vector format differs from the original file (LO Impress)
Summary: [SVG] The exported file in vector format differs from the original file (LO I...
Status: RESOLVED DUPLICATE of bug 61314
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-14 14:23 UTC by Bastián Díaz
Modified: 2013-12-08 04:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample files that show the problem explained. (ZIP) (1.65 MB, application/zip)
2013-07-14 14:30 UTC, Bastián Díaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2013-07-14 14:23:07 UTC
Description of problem:
The results of the exported image vertorial format differs from the original document in LibreOffice Impress.

For example do not follow the patterns of font and background color. For background color, just follow the patterns defined in the master page, so for example if I set the color blue as a base and some slides have another color (such as red), everything is exported with blue background (this does not happen when exporting in PDF format). If not set background color (master page) or set individual colors per slide, the background is exported as a transparency.

Version-Release number of selected component (if applicable):
fedora 19
GNOME 3.8.3
LibreOffice 4.1.0.1 | 4.1.0.1-8.fc19 (default package in fedora)


How reproducible:
always

Steps to Reproduce:
1.create a presentation
2.include text and image (to differentiate background objects)
3.a) adding a single background color for the slide b) adding a background color for all dispositive c) add a background color for all slides (master page) and change color diaspositiva exported individually.
4.export to SVG format

Actual results:
a) The exported image in SVG format has the background transparency
b) and c) The image is exported in SVG format as background color of the master page

In all the above cases, there are differences in the presentation of the typeface.

Expected results:
The image exported to SVG format, is identical to that presented in slide format ODP in LO Impress.

Additional info:
See also:Bug 61314

Thanks
Comment 1 Bastián Díaz 2013-07-14 14:30:23 UTC
Created attachment 82409 [details]
Sample files that show the problem explained. (ZIP)

Attached images showing the problem. PDF files display the pattern (such as the original presentation looked), and I can not upload the file on ODP, because for some strange reason weighed over 30 megs (2 slides).
Comment 2 ign_christian 2013-07-15 02:30:36 UTC
I think I made mistake while commenting on https://bugs.freedesktop.org/show_bug.cgi?id=61314#c9

If you created this bug report against changing background color (same as Bug 61314), please forgive me. What I meant was new report against comment4 on that bug: https://bugs.freedesktop.org/show_bug.cgi?id=61314#c4

If yes, I'll create that new bug report for you to pay for my mistake I've made.
Comment 3 Bastián Díaz 2013-07-15 11:25:20 UTC
(In reply to comment #2)
> I think I made mistake while commenting on
> https://bugs.freedesktop.org/show_bug.cgi?id=61314#c9
> 
> If you created this bug report against changing background color (same as
> Bug 61314), please forgive me. What I meant was new report against comment4
> on that bug: https://bugs.freedesktop.org/show_bug.cgi?id=61314#c4
> 
> If yes, I'll create that new bug report for you to pay for my mistake I've
> made.


Are you developer?

I have reviewed the comment and I have been clear to ask if it was the problem or the other who had to report in another report.

We can only hope that a developer mark it as duplicate and are interested in the problem.
Comment 4 ign_christian 2013-07-15 12:17:12 UTC
> Are you developer?
Unfortunately no :(
Just want to triage & try to make problem reported clear enough for dev.
 
> I have reviewed the comment and I have been clear to ask if it was the
> problem or the other who had to report in another report.
So we still have to create bug report for regression problem of comment#4 on bug 61314, have we? If you agree, I'll make it.
Comment 5 ign_christian 2013-07-15 14:34:50 UTC
> So we still have to create bug report for regression problem of comment#4 on
> bug 61314, have we? If you agree, I'll make it.
I've just realized that you had created Bug 66901 for that. Sorry for my useless comments here.
Comment 6 Owen Genat (retired) 2013-12-07 02:35:57 UTC
Like ign_christian I cannot see any distinguishable difference between this bug and bug 61314. The use of "differs" in the summary is not descriptive enough. A bug report needs to explicitly describe one problem and this one is largely about the same background colour issue reported in bug 61314. It is possible the intention was to indicate the problem with font (from comment #0):

> For example do not follow the patterns of font and ...

... however the included files are not a good test for this problem. The example files provided also do not include an ODF to test. At this point I feel it would likely be easier to close this bug (as a DUPLICATE) and open a more specific bug report if required.
Comment 7 Bastián Díaz 2013-12-07 18:42:42 UTC
(In reply to comment #6)
> Like ign_christian I cannot see any distinguishable difference between this
> bug and bug 61314. The use of "differs" in the summary is not descriptive
> enough. A bug report needs to explicitly describe one problem and this one
> is largely about the same background colour issue reported in bug 61314. It
> is possible the intention was to indicate the problem with font (from
> comment #0):
> 
> > For example do not follow the patterns of font and ...
> 
> ... however the included files are not a good test for this problem. The
> example files provided also do not include an ODF to test. At this point I
> feel it would likely be easier to close this bug (as a DUPLICATE) and open a
> more specific bug report if required.

You are absolutely right. I do not remember what my reason to make a new bug report.
If you choose to, you can mark the bug as duplicate.

Thank you.
Comment 8 Owen Genat (retired) 2013-12-08 04:43:28 UTC
Thanks for confirming Bastián.

*** This bug has been marked as a duplicate of bug 61314 ***