Bug Hunting Session
Bug 66914 - EDITING Writer does not recognize fields as part of a sentence and applies autocorrection (capitalize first letter)
Summary: EDITING Writer does not recognize fields as part of a sentence and applies au...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 76139 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-15 05:56 UTC by János Néhrer
Modified: 2017-09-29 09:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test document. The isse can be seen on the third page, in the line with a field at the beginning. (118.40 KB, application/vnd.oasis.opendocument.text)
2013-07-15 05:56 UTC, János Néhrer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description János Néhrer 2013-07-15 05:56:10 UTC
Created attachment 82431 [details]
Test document. The isse can be seen on the third page, in the line with a field at the beginning.

Enviroment
LibreOffice 3.6-4
Operating system: Windows 7 x64 and OpenSUSE

Steps to reproduce
1. Choose 'Insert'-> 'Fields' (choose any field)
2. Press space after the field and start typing...

Results
The first written word after the field will be autocorrected to have a capital
letter at the beginning.

Expected results
LibreOffice should handle the field as part of the sentence, so the text after
it should start in lowercase by default.
Comment 1 János Néhrer 2013-07-15 05:56:56 UTC
The issue exists in 4.0.4 as well.
Comment 2 Cor Nouws 2013-07-15 08:37:53 UTC
Hi jános,

thanks for the report. I confirm the behaviour.

Is already present in 3.3.0, so set the version accordingly. 
And I add some words on Autocorrection to the summary

Cheers,
Cor
Comment 3 tommy27 2014-06-04 04:53:17 UTC
*** Bug 76139 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2015-06-08 14:42:43 UTC Comment hidden (obsolete)
Comment 5 Cor Nouws 2015-06-22 11:53:45 UTC
still happens in 4.4.4.2
Comment 6 QA Administrators 2016-09-20 10:11:22 UTC Comment hidden (obsolete)
Comment 7 János Néhrer 2016-09-21 03:11:45 UTC
Still reproducible.

Win 8.1 x86-64
Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
Comment 8 Xisco Faulí 2017-09-29 08:53:06 UTC Comment hidden (obsolete)
Comment 9 János Néhrer 2017-09-29 09:54:05 UTC
Could not reproduce on Version: 5.4.1.2 (x64)
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Windows 6.29; UI render: default; 
Locale: hu-HU (en_US); Calc: group