Bug 66936 - EDITING: animation of SVG not saved, sometimes crash
Summary: EDITING: animation of SVG not saved, sometimes crash
Status: RESOLVED DUPLICATE of bug 64512
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-15 16:58 UTC by public
Modified: 2013-07-16 01:29 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
SVG to reproduce the bug (5.63 KB, image/svg+xml)
2013-07-15 16:58 UTC, public
Details

Note You need to log in before you can comment on or make changes to this bug.
Description public 2013-07-15 16:58:06 UTC
Created attachment 82456 [details]
SVG to reproduce the bug

Problem description: 

Steps to reproduce:
1. Import SVG
2. Add any animation to it
3. Save and close document
4. Re-open document

Current behavior:
The SVG is not animated anymore. In the list of animations, there is only an entry "-1" but no other. 

Addtionally, I had several crashes when I tried to start the slide show (after AND before re-opening) but I cannot reproduce them anymore...

Expected behavior:
The SVG is still animated.


It works with every SVG I have seen but to be sure I attached one that produces the bug.
Operating System: Linux (Other)
Version: 4.0.3.3 release
Comment 1 public 2013-07-15 17:00:16 UTC
Forgotten to mention one more thing:

After converting the SVG to a Metafile, the problem does not occur anymore.
Comment 2 ign_christian 2013-07-16 01:29:39 UTC
It should have been fixed in master according to Bug 64512.

*** This bug has been marked as a duplicate of bug 64512 ***