Download it now!
Bug 66988 - Lost formating during document previewing and printing
Summary: Lost formating during document previewing and printing
Status: RESOLVED DUPLICATE of bug 68148
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.2 rc
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-07-17 06:46 UTC by Andrzej
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice -view but don't printing cell borders xls and xlsx (9.00 KB, application/vnd.ms-excel)
2013-07-17 06:46 UTC, Andrzej
Details
Printed by PDFcreator (2.17 KB, application/pdf)
2013-07-17 09:18 UTC, ign_christian
Details
LO dont print cell border-printscreen normal view (134.90 KB, image/png)
2013-07-18 19:34 UTC, Andrzej
Details
LO dont print cell border-export to pdf from AOO (37.28 KB, application/pdf)
2013-07-18 19:35 UTC, Andrzej
Details
LO dont print cell border-export to pdf from LO4_1_RC2 (286.75 KB, application/pdf)
2013-07-18 19:37 UTC, Andrzej
Details
LO dont print cell border-export to pdf from LO4_1_RC3 (286.85 KB, application/pdf)
2013-07-18 19:37 UTC, Andrzej
Details
LO dont print cell border (9.00 KB, application/vnd.ms-excel)
2013-07-18 19:39 UTC, Andrzej
Details
Line style with gaps (6.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-08-30 20:00 UTC, Mateusz
Details
LO dont see line style (104.52 KB, image/png)
2013-10-06 18:55 UTC, Andrzej
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrzej 2013-07-17 06:46:28 UTC
Created attachment 82528 [details]
LibreOffice -view but don't printing cell borders xls and xlsx

LibreOffice view cell borders but don't printing from file save as xls and xlsx.

Open attachment in LO, now view cell border is all right, but when you choose from menu page preview or printing file you don't see cell borders.

This file open in AOO work correct. All cell borders are viewing and printing.
Comment 1 ign_christian 2013-07-17 09:18:54 UTC
Created attachment 82535 [details]
Printed by PDFcreator

Hi.. I saw all borders printed using PDFcreator with LO 4.0.4.2 (Win7 32bit)

Have you tried resetting user profile?
Comment 2 ign_christian 2013-07-17 09:37:07 UTC
Perhaps same/related to Bug 46393
Comment 3 Andrzej 2013-07-17 13:34:35 UTC
(In reply to comment #2)
> Perhaps same/related to Bug 46393

OMG.
I know that work correct on all version LO, but don't work on LO 4.1 RC2! Are you understand?
Comment 4 Andrzej 2013-07-18 19:33:28 UTC
LO 4.1 RC3 still don't printing cell borders.
Look et new attachments.
Comment 5 Andrzej 2013-07-18 19:34:57 UTC
Created attachment 82628 [details]
LO dont print cell border-printscreen normal view
Comment 6 Andrzej 2013-07-18 19:35:44 UTC
Created attachment 82629 [details]
LO dont print cell border-export to pdf from AOO
Comment 7 Andrzej 2013-07-18 19:37:15 UTC
Created attachment 82630 [details]
LO dont print cell border-export to pdf from LO4_1_RC2
Comment 8 Andrzej 2013-07-18 19:37:39 UTC
Created attachment 82631 [details]
LO dont print cell border-export to pdf from LO4_1_RC3
Comment 9 Andrzej 2013-07-18 19:39:45 UTC
Created attachment 82632 [details]
LO dont print cell border
Comment 10 Andrzej 2013-07-24 10:38:42 UTC
LO 4.1 RC4 still don't printing cell borders. In AOO work correct.
Comment 11 Michael Meeks 2013-07-24 11:03:04 UTC
Markus - any ideas about this ? :-) IIRC you did a chunk of work to improve cell borders in the past.
Comment 12 Mateusz 2013-07-24 18:53:08 UTC
It perfectly works with LO 4.0.4.1 (Build ID: 7fdd5ee61c1c7379dd088f5d50265f0adbccf53)
Comment 13 Michael Meeks 2013-07-24 19:06:01 UTC
Mateusz any chance of a bibsect ? :-)
Comment 14 Mateusz 2013-07-24 19:59:47 UTC
Michael, I never do it before and at first I must read up on https://wiki.documentfoundation.org/QA/HowToBibisect

so stay tuned. I will try do something after coming back do home (30.07)
Comment 15 Jorendc 2013-07-26 20:16:12 UTC
Well, this bug is not bibisectable with the provided packages.

I can reproduce this behavior, tested with LibreOffice Version: 4.2.0.0.alpha0+
Build ID: 7fd81244c21ad54a8b9766902fd7c34e8055b165 (2013-07-24 08:04:44), but not reproducible with 'oldest' and 'latest' from bisect40 package, and the binrepo with latest commit included: b2d08d759ee755cb5722553e01fb6d007ac9ffbe (2013-05-29 13:39:56).
Comment 16 Mateusz 2013-08-30 20:00:30 UTC
Created attachment 84932 [details]
Line style with gaps

I found another "border issue" and I thought it's not depending from file format. 

Try apply line style with gaps and make print preview. While normal line style is displayed correctly, line stile with gaps has many glitches and there is displayed only bottom line of table.

Try samle.ods
Comment 17 Andrzej 2013-08-30 20:31:49 UTC
Thanks Mateusz
This is this about what exactly it walked me.
Comment 18 Andrzej 2013-10-06 18:55:02 UTC
Created attachment 87206 [details]
LO dont see line style

In LO 4.1.2 still I can't printing cell borders when set line style with gaps.
LO 4.1.2 very nice read and display my xls and xlsx files almost just like MSO, but can't printing when don't see line style or cell borders are set as line style with gaps.
Comment 19 Mateusz 2013-10-09 09:54:33 UTC
Hey

I checked daily master build and Calc still has this regression. It loses table formating (borders, but only with hashtags) and it's not related with file format (neither save as XLS(X) nor ODS is not solution).

If it's "critical bug", could someone pay more attention on this bugreport? Persoanally this issue doesn't affect me, but I got many reports from normal, bothered users. 

Version: 4.2.0.0.alpha0+
Build ID: d73acee01885fae5465fa9c7c1d88be683d60e98
TinderBox: Win-x86@39, Branch:master, Time: 2013-10-09_05:34:33
Comment 20 Joel Madero 2013-10-29 14:18:28 UTC
Bibisected notes: There is also substantial performance degradation on the bad biibsect ranges - specifically when I try to print there is a long delay before the dialog comes up & when I click on any tab or box (such as print to file) there is also a long delay. I would open a new bug but I am relatively positive they are the same bug coming through as the issue only appeared on bad commit ranges.


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
3791268ce3e6f9e570f02c09d586fd8e9f2485c3 is the first bad commit
commit 3791268ce3e6f9e570f02c09d586fd8e9f2485c3
Author: Jean-Baptiste Lallement <jean-baptiste.lallement@canonical.com>
Date:   Tue Jun 25 08:38:33 2013 +0000

    source-hash-51daa4de4fbb86903aeb9cdfefbb089e8d00c001
    
    commit 51daa4de4fbb86903aeb9cdfefbb089e8d00c001
    Author:     Jelle van der Waa <jelle@vdwaa.nl>
    AuthorDate: Sat Jun 22 12:52:31 2013 +0200
    Commit:     Michael Stahl <mstahl@redhat.com>
    CommitDate: Mon Jun 24 21:44:24 2013 +0000
    
        fdo#43460 sd,rsc,ucb,sdext: use isEmpty()
    
        Change-Id: I7a7a77c26b74078f7fc160fbaa1c8d4e912b844e
        Reviewed-on: https://gerrit.libreoffice.org/4442
        Reviewed-by: Michael Stahl <mstahl@redhat.com>
        Tested-by: Michael Stahl <mstahl@redhat.com>

:100644 100644 e0cc68ae32874b64ac7d808f00880e1a79e714dc df3b23445f820f871a2d81e85b1e77e498f3ad23 M	ccache.log
:100644 100644 37f2ae4d811759d268b9b1038112d19960894a41 dc625f5b9d41121b4fa888e776a25b5cdbf462a8 M	commitmsg
:100644 100644 7873383e78698b5969775797224dea2257429d1a b85c93b24f073f04203e6d8492b6ae63d3039c30 M	dev-install.log
:100644 100644 8c4471055dd337a79af1aea93ba257edc45bbae3 062a117b360ac5cff020aae921e81cb3ca6578d9 M	make.log
:040000 040000 1cf15df9ad150422e1e8c4c13350c7fd64c88fd1 dcff4929a651e1e77268fb14b8688ae249b041ed M	opt

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

# bad: [d31848bf3b700a22d127d7c775a0f910a7e133d0] source-hash-86cbe18a6143bf054c31f69dc97368dfdd3ad374
# good: [3e7462bd65e692bf0592d5b080b7716341b62a47] source-hash-1eddfce9894fd05315173744f495619189093dc7
git bisect start 'latest' 'oldest'
# good: [578fb08152ad11454e2f09ad6f8c8e527da817de] source-hash-4e3e171262aed0e52fa76158950d5be770249e80
git bisect good 578fb08152ad11454e2f09ad6f8c8e527da817de
# bad: [efb04c1c794ef7fc4cda1eb80880d333ca969a5e] source-hash-7908692490120350f2ad45241f7b19ba52dc0489
git bisect bad efb04c1c794ef7fc4cda1eb80880d333ca969a5e
# good: [b46b5a58fcaec85eefb31b23afb0fc389a0c5334] source-hash-34c1b7bdd0bca4753f66a7d17ef46647a64a319e
git bisect good b46b5a58fcaec85eefb31b23afb0fc389a0c5334
# bad: [3791268ce3e6f9e570f02c09d586fd8e9f2485c3] source-hash-51daa4de4fbb86903aeb9cdfefbb089e8d00c001
git bisect bad 3791268ce3e6f9e570f02c09d586fd8e9f2485c3
# good: [e6232df2478b09d806e7b217c9dc0ac4ca83a935] source-hash-e08407052f556c981e533f532815125769212685
git bisect good e6232df2478b09d806e7b217c9dc0ac4ca83a935
# good: [ebdfc723e526d54263e8ae5597722bd980d141d4] source-hash-fd7861397bb4e8dc5ad694a7f677e10fd271f0f6
git bisect good ebdfc723e526d54263e8ae5597722bd980d141d4
# good: [2a7f2585a479ce80cdde9dc99934c72f3a355f30] source-hash-ebc635b95cc6d8c5853c443fee9fe76a0c89c121
git bisect good 2a7f2585a479ce80cdde9dc99934c72f3a355f30
# good: [159a7f006fe0759d61076916d2ddc1bec2e0fa83] source-hash-bddf3bba1fa13b57a69f2bd5f7c7f96bb945066d
git bisect good 159a7f006fe0759d61076916d2ddc1bec2e0fa83
# good: [a5620bdfe00015bdba86ee895e26fb4a13721dfe] source-hash-97f71c5f8be85f47d7978259a2d82708412043fd
git bisect good a5620bdfe00015bdba86ee895e26fb4a13721dfe
# first bad commit: [3791268ce3e6f9e570f02c09d586fd8e9f2485c3] source-hash-51daa4de4fbb86903aeb9cdfefbb089e8d00c001
Comment 21 Andras Timar 2013-11-19 20:54:11 UTC
1680a8cd4f4393ec15c4f85cb63b6654117d56d1 is the first bad commit
commit 1680a8cd4f4393ec15c4f85cb63b6654117d56d1
Author: Noel Power <noel.power@suse.com>
Date:   Mon Jun 24 21:04:51 2013 +0100

    fix hair & fine cell border export ( followon fix fdo#56960 )
    
    1) align excel binary and oox import filter border thickness values
    2) use new fine-dash border style
    3) detect & determine hair vrs fine borderline on export
    
    Change-Id: Ieb024bc6f4bfc87c525082c7b9a1f3c444f5c5ca

The commit solves an interop problem. The real problem is, that in print preview the dashed lines are too thin -> invisible. Even when I printed it with my HP Laserjet 1010, a few lines were invisible, most of them were there, however.
Comment 22 Andras Timar 2013-11-24 22:06:39 UTC

*** This bug has been marked as a duplicate of bug 68148 ***
Comment 23 Robinson Tryon (qubit) 2015-12-15 11:03:24 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]