Bug Hunting Session
Bug 67031 - Debian menus package conflict with older version
Summary: Debian menus package conflict with older version
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: All Linux (All)
: medium major
Assignee: Petr Mladek
URL:
Whiteboard: target:4.2.0 target:4.1.0
Keywords:
: 61014 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-18 09:26 UTC by Petr Mladek
Modified: 2013-09-18 15:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Mladek 2013-07-18 09:26:32 UTC
All files and desktop menu entries have been versioned since LO 3.4 => there are not real conflicts between LO versions and distro specific packages.

Unfortunately, libreoffice4.1-debian-menus_4.1.0-3_all.deb has the following dependencies:

   Provides: libreoffice-desktop-integration, libreoffice-unbundled
   Conflicts: libreoffice-desktop-integration, libreoffice-debian-menus, libreoffice-bundled
   Replaces: libreoffice-desktop-integration, libreoffice-debian-menus

The result is that the package for LO 3.x and 4.x versions conflict with each other. They are there from historical versions where the package, files, and menu entries were not versioned. They are not needed these days and should get removed.

This bug get more important in LO 4.1 where we moved the debian-menus from the "desktop-integration" subdirectory and it is stalled together with other packages by default.
Comment 1 Commit Notification 2013-07-18 09:55:36 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9642c6e66dd04ff3d91499cc1184c80a5d6d1707

debian-menus packages should not conflict with older versions (fdo#67031)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Petr Mladek 2013-07-18 13:53:06 UTC
The fix is already in master for LO 4.2. Also it is in the review queue for 4.1.1, see https://gerrit.libreoffice.org/#/c/4965/

I have mentioned it at at 
https://wiki.documentfoundation.org/Releases/4.1.0/RC3#Installation
https://wiki.documentfoundation.org/ReleaseNotes/4.1#Most_Annoying_Bugs

So, I would consider it as fixed.
Comment 3 Jean-Baptiste Faure 2013-07-18 15:05:19 UTC
(In reply to comment #2)
> The fix is already in master for LO 4.2. Also it is in the review queue for
> 4.1.1, see https://gerrit.libreoffice.org/#/c/4965/
> 
> I have mentioned it at at 
> https://wiki.documentfoundation.org/Releases/4.1.0/RC3#Installation
> https://wiki.documentfoundation.org/ReleaseNotes/4.1#Most_Annoying_Bugs
> 
> So, I would consider it as fixed.

It is more problematic: if you install LO 4.1.0.3 on Ubuntu 12.04, your update manager will ask you to install the ubuntu version of LO (3.5.7-0ubuntu4). If you have configured your update manager to install the updates automatically, or if you are not carefull, your LO installation will be destroyed. The problem occurs even if you uninstall your old vanilla version before installing LO 4.1.0.3.
ATM the most secure way to test 4.1.0.3 on ubuntu is to not install the desktop-integration package and launch LO using the command line.

Best regards. JBF
Comment 4 Petr Mladek 2013-07-18 17:00:22 UTC
I think that the update manager prefers the native Ubuntu packages or so. But the root of the problems is still the same and it is the wrong (conflicting) package name. By other word, the fixed package name should fix the problems with the updater as well.

=> marking this bug as fixed again
Comment 5 Commit Notification 2013-07-19 07:55:19 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c500e745b38e1d0be2bd21210001eef631bcea9&h=libreoffice-4-1

debian-menus packages should not conflict with older versions (fdo#67031)


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-07-22 10:23:57 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f4e3a2e272e1ed269efe3ba11915378ffb41a77

avoid file conflict in debian-menus package (fdo#67031)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-07-22 10:53:28 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=754586bb7148ffd9f8e7fd34a6f1700b74e4286f&h=libreoffice-4-1-0

debian-menus packages should not conflict with older versions (fdo#67031)


It will be available already in LibreOffice 4.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-07-22 11:02:36 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a6ae1cc0a2c5fd9f9bc0a834038b73e79b78fc6d&h=libreoffice-4-1

avoid file conflict in debian-menus package (fdo#67031)


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-07-22 17:06:55 UTC
Petr Mladek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff2139ccf7dc950503d10f953f2afd4b3e93417d&h=libreoffice-4-1-0

avoid file conflict in debian-menus package (fdo#67031)


It will be available already in LibreOffice 4.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Petr Mladek 2013-09-18 15:48:24 UTC
*** Bug 61014 has been marked as a duplicate of this bug. ***