Bug 67060 - deb package tarball contains RPM-only 'install' script
Summary: deb package tarball contains RPM-only 'install' script
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: All Linux (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.0 target:4.1.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-19 00:52 UTC by Lionel Elie Mamane
Modified: 2013-11-20 15:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2013-07-19 00:52:27 UTC
The LibreOffice_4.1.0.3_Linux_x86-64_deb.tar.gz tarball contains file LibreOffice_4.1.0.3_Linux_x86-64_deb/install, which makes no sense since that script can deal only with rpm packages. (OTOH, it seems it can deal with RPM packages on a Debian system...)
Comment 1 Jean-Baptiste Faure 2013-08-15 17:00:37 UTC
If I remember well, it is not new, it was already the case in the old time of OOo.

Best regards. JBF
Comment 2 Jean-Baptiste Faure 2013-08-15 17:13:32 UTC
Well, in OOo 3.3.0 install archive there is a script named update which seems to be able to handle DEB packages.

In the install script there is the following help:

  echo "User Mode Installation script for developer and knowledgeable early access tester"
  echo
  echo "This installation method is not intended for use in a production environment!"
  echo "Using this script is unsupported and completely at your own risk"

Not sure if developers and testers need such a script.

Other problem: when I open the file, gedit says that the file contains invalid characters...

Best regards. JBF
Comment 3 Kevin Suo 2013-09-04 09:17:58 UTC
This "INSTALL" script is really misleading, esp for newbies. It should be removed, or be replaced with a deb script.

I don't find such "install" script in LibreOffice 4.0.5.2 deb package tarball.
Comment 4 Andras Timar 2013-11-20 13:54:12 UTC
(In reply to comment #2)
> Not sure if developers and testers need such a script.

Some people need it, that's why it was added, see commit 117b3242dbdcf5c9690921f2f4cf1495df10c11e


> 
> Other problem: when I open the file, gedit says that the file contains
> invalid characters...

Because it contains an embedded binary file.
Comment 5 Commit Notification 2013-11-20 13:58:47 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f995b395ea347469ca9c7681d2f01f63e966d96

fdo#67060 do not package RPM-only install script to DEB packs



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-11-20 15:12:13 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=776f48eb97a99e077824741ad300fed27e4edd14

Revert "fdo#67060 do not package RPM-only install script to DEB packs"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-11-20 15:52:59 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b533869803537ca8f95fb3d7543ccaf067fdbbe0&h=libreoffice-4-1

fdo#67060 do not package RPM-only install script to DEB packs


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.