Bug Hunting Session
Bug 67083 - EDITING: Page Numbering: number when using offset is at maximum the number of pages
Summary: EDITING: Page Numbering: number when using offset is at maximum the number of...
Status: RESOLVED DUPLICATE of bug 35694
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 61701 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-07-19 12:31 UTC by Matthew Carlin
Modified: 2015-01-21 10:21 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Carlin 2013-07-19 12:31:03 UTC
I cannot make page numbers start at a high number (I wanted 165). I can offset it up to 5, but anything above that and nothing happens at all—the OK button won't even press. 
Operating System: Mac OS X
Version: 4.0.4.2 release
Comment 1 retired 2013-07-19 18:13:33 UTC
Matthew: please provide a detailed stepbystep description on how to reproduce this problem.
Comment 2 Matthew Carlin 2013-07-19 18:23:16 UTC
I clicked on insert field, I think it has the option for other under which
you can select page number which give you a the option for "offset" which
would only accept 1-5. I wanted to put in 165.


On Fri, Jul 19, 2013 at 2:13 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=67083#c1> on bug
> 67083 <https://bugs.freedesktop.org/show_bug.cgi?id=67083> from James<spam35@gmx.net>
> *
>
> Matthew: please provide a detailed stepbystep description on how to reproduce
> this problem.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 retired 2013-07-21 11:22:23 UTC
Matthew, please use a browser to reply. Otherwise replies will show up with crazy formatting.

Tried reproducing with LO 4.1.0.3, OS X 10.8.4.


Steps to reproduce:

* Open LO writer
* move to bottom of page
* click into document so the blue footer option will show
* click the "+"
* then via menu "insert" > second entry from top then > page number http://cl.ly/image/1j1w3b133D28
* page number "1" shows as expected
* mark and then right click that grey box in which "1" appears and select "feldbefehl" (not sure of the english translation) http://cl.ly/image/331C3L441V2J
* enter a digit in the correction field http://cl.ly/image/2a260W0u2d0G

expected: page number 3 should show up

current: page number gets removed and nothing is showing.

This already seems like a bug, so setting to NEW. Unsure how to test this with bigger numbers. Maybe I did sth wrong, if so, please elaborate in detailed steps on how to reproduce.
Comment 4 Luuk 2013-07-21 18:26:57 UTC
After:
* Open LO writer
* move to bottom of page
* click into document so the blue footer option will show
* click the "+"

try to do this:
* Insert/Fields/Other  (CTRL+F2)
* Pick 'Set page variable', set 'selection' to 'on', and enter an offset, confirm with 'Insert'
* Pick 'Show page variable', click 'Insert' , and 'Close'

Now you should see a page number which is one higher than the given offset.

I don't know what should happen when you right-click on a page-number, and than pick 'Fields', but i does not seem to work for what you want it to do.
Comment 5 Cor Nouws 2013-07-21 19:34:41 UTC
The helps says
" Enter the offset value that you want to apply to a page number field, for example "+1". "

However in 4.1.0 rc3 the highest number shown is the number of pages.

E.g. field + offset +1 in a page header
one page
 > result on page one =  empty
two pages
 > result on page one = 1
 > result on page two =  empty

Testing on Linux.
LO 3.3.0 is working correct for me, so somewhere in between (to be tested) the regression started.
Comment 6 retired 2013-07-25 16:57:08 UTC
*** Bug 61701 has been marked as a duplicate of this bug. ***
Comment 7 Michael Stahl (CIB) 2013-07-29 12:30:50 UTC
Cor, i'm not seeing this working in LO 3.3.4 on Linux.

in fact it appears to be broken since the oldest version i've tried, OOo 3.0.1.

so it does not appear to be a regression.
Comment 8 Cor Nouws 2013-07-30 21:24:09 UTC
Hi Michael,

(In reply to comment #7)
> in fact it appears to be broken since the oldest version i've tried, OOo
> 3.0.1.
> 
> so it does not appear to be a regression.

Indeed. Testing again with a new file in 3.3.0, it does not work correctly.
(maybe I was confused by the many different versions/tests... dunno, Appologies!)
Comment 9 João Paulo 2013-09-06 23:45:18 UTC
Tested on Windows XP SP3 32 bits with LibreOffice 4.0.5:

The page number offset only works if the document actually has the resulting page number.
Comment 10 João Paulo 2013-09-06 23:48:41 UTC
i.e., if the document has 30 pages and the offset results in a page number from 1 to 30, it works. If the offset results in a page number from 0 to any negative integer, or from 31 and up, the page number field is empty.
Comment 11 João Paulo 2013-09-07 00:23:13 UTC
I can confirm this bug appears since "BrOffice/3.3$Win32 LibreOffice_project/330m19$Build-202", because of the "<meta:generator>" tag inside an old test document I created, but didn't filed the bug until today when I was going to do that and found this bug.



This bug is not only for the #page# field, but also for the #count# field:

On a document with 2 pages, on the 1st page the first paragraph is formatted to insert a page break before it, renumbering the page to 0; the #page# field will be null/empty (shouldn't be 0?) and the #count# field will be 3 (shouldn't it be 2, as there is only 2 pages?).

On the same document with 2 pages, on the 2nd page the first paragraph is formatted to insert a page break before it, renumbering the page to 1; the #page# field will be 1 (correct) and the #count# field will be 3 (again, shouldn't it be 2?)

On the same document with 2 pages, on the first paragraph on both pages, if it is formatted to insert a page break before it renumbering, for example, to 9, the #page# field will be 9 (correct), but the #count# field will still be 3!



My doubt is: Shouldn't the total pages field (#count# field) be the real pages on the document? One can say we can put any number we want, but if we are using offsets/renumberings to the #page# field, shouldn't the #count# reflect the offset/renumbering or, at least, have a choice to offset it?
Comment 12 Regina Henschel 2013-12-11 12:20:48 UTC
It is no bug, but the desired behavior as defined in the specification.

<quote>
19.845.2 <text:page-number>
The text:page-adjust attribute specifies an adjustment of the value of a page number field, in order to display of page numbers of following or preceding pages. The specified value is added to the current page number. If a page with the resulting page number does not exist, no number is displayed.
</quote>

http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.html#__RefHeading__1419094_253892949

I suggest, resolve to "NOTABUG".
Comment 13 Matthew Carlin 2013-12-11 20:55:04 UTC
I'm not a programmer. I can't follow all this. But the last commenter does not explain how this is not a bug. I cannot renumber pages the way I can in any other word processor. How is that intentional? I go where I should be able to, I put in the offset, and it doesn't work. That's what I call a bug.
Comment 14 Regina Henschel 2013-12-11 21:23:22 UTC
You should ask on the user mailing list or in the forum how to get a new page number in LibreOffice. Here only a short description:
Go to the page where you want to start the new numbering. Set the cursor top left in the text area. Right-click and choose item "paragraph...". On dialog page "Text Flow" in section "Breaks" check "Insert" and "With Page Style". Then enter the new number in field "Page number".
Comment 15 Matthew Francis 2015-01-21 10:21:59 UTC

*** This bug has been marked as a duplicate of bug 35694 ***