Download it now!
Bug 67093 - FILEOPEN: Heading style replaced by Title style with FR (and other) UI
Summary: FILEOPEN: Heading style replaced by Title style with FR (and other) UI
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.1.2 target:4.0.6
Keywords: regression
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-07-19 15:08 UTC by Laurent BP
Modified: 2013-09-02 21:15 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file to open (135.46 KB, application/vnd.oasis.opendocument.text)
2013-07-19 15:08 UTC, Laurent BP
Details
Screenshot of opening file with UI langage as EN (69.58 KB, image/png)
2013-07-19 15:11 UTC, Laurent BP
Details
Screenshot of opening file with UI langage as FR (66.36 KB, image/png)
2013-07-19 15:13 UTC, Laurent BP
Details
Screenshot of opening file with UI langage as DE (71.19 KB, image/png)
2013-07-19 15:14 UTC, Laurent BP
Details
scrsht Italian 4.0.2.2 (128.74 KB, image/png)
2013-07-20 11:20 UTC, Valter Mura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2013-07-19 15:08:46 UTC
Created attachment 82695 [details]
Test file to open

Problem description: 

Steps to reproduce:
1. set UI language to EN and restart
2. open attached file
Current behavior:
First line look like it should: a green text left align
3. set UI language to FR and restart
4. open attached file

Current behavior:
Text is centered and black because style "Heading" ("Titre") has been changed to "Title" style ("Titre principal").

Expected behavior:
No change of "Heading" style.

See attached screenshot according to UI language of the same file, open with LibO 4.1.0.RC3
File is correctly opened in LibO 4.0.4.2

              
Operating System: Windows 7
Version: 4.1.0.1 rc
Last worked in: 4.0.4.2 release
Comment 1 Laurent BP 2013-07-19 15:11:33 UTC
Created attachment 82696 [details]
Screenshot of opening file with UI langage as EN

Check Styles list: "Heading 1" inherit from "Heading", and there is a different style "Title"
Comment 2 Laurent BP 2013-07-19 15:13:28 UTC
Created attachment 82697 [details]
Screenshot of opening file with UI langage as FR

Formating is wrong because style "Titre" ("Heading") has been changed to "Titre principal" ("Title") which has disappear from the styles list
Comment 3 Laurent BP 2013-07-19 15:14:41 UTC
Created attachment 82698 [details]
Screenshot of opening file with UI langage as DE

Same behavior as with UI language set as EN
Comment 4 Laurent BP 2013-07-19 15:25:15 UTC
Bug is confirmed with French and Occitan UI.
Bug is NOT confirmed with English, German and Farsi UI.
Comment 5 Jean-Baptiste Faure 2013-07-19 15:39:50 UTC
Reproducible with Version: 4.1.1.0.0+ (Build ID: 94dd6a449fe3c17f97264dd01bf263eb268ac19) under Ubuntu 12.04 x86-64
The bug is also present in the master (Version: 4.2.0.0.alpha0+ Build ID: 4843d5e8865d2f63f408f464e28be9440cb1ecc2)

Best regards. JBF
Comment 6 Laurent BP 2013-07-19 15:52:31 UTC
Bug NOT present with LibO 4.1.0.0beta1
Bug IS present with LibO 4.1.0.0beta2

Bug NOT present with UI in Afrikaans, Albanian, Esperanto

Bug IS present with UI in Portuguese

Bug is DIFFERENT with UI in Italian: "Heading" is changed to default style.
Comment 7 Laurent BP 2013-07-19 16:36:12 UTC
Bug is DIFFERENT with UI in Spanish (same as Italian)

Bug IS present with UI in Chinese, Russian, Breton

Bug is NOT present with UI in Arabic, Hebrew, Finnish, Kurdish, Turkish
Comment 8 Pierre C 2013-07-19 21:34:44 UTC
I can confirm this very annoying bug with 4.1.0.3 French ; seven 64 bits
Comment 9 Jean-Baptiste Faure 2013-07-20 03:52:11 UTC
Possible data loss because styles structure is modified. If you save your file with LO 4.1.0.3 and open it back with LO 4.0.4 your file has the modified / corrupted styles structure.
Many users affected.
Set to blocker according to https://wiki.documentfoundation.org/Release_Criteria#Blocker_Bug_Definition

Best regards. JBF
Comment 10 Norbert Thiebaud 2013-07-20 07:57:33 UTC
+ are we _sure that the problem is bisected between beta1 and beta2 as indicated by comment #6 ?
If that is confirmed then the bug is, or is triggered by something somewhere between
923e81c6b5a9f7eddf7138cffc44d802a883c72d and b07a9b535987a7d1a5e91a4937d0ed0572eb1053

+ From the description and the local dependency, I would emit this hypothesis, that is true for French, and could be confirmed with the other locale that have the bug:
"The bug is present whenever the name of the style in the local is a leading sub-string of the name of the style in the other locale."
iow here 'Titre' is sub-string of 'Titre Principal' =? bug
but in English 'Heading' is not a leading sub-string of 'Title'

+ With that in mind could there be other style issue, when they involve localized name that have the same property ? or is it really just Heading/Title
Comment 11 Valter Mura 2013-07-20 11:18:15 UTC
Supposing it is only a 4.1.0 beta problem, I attach a screenshot from my KDE system (Kubuntu 13.04) with Libo 4.0.2.2, Italian, the heading style is same as English and German
Comment 12 Valter Mura 2013-07-20 11:20:50 UTC
Created attachment 82725 [details]
scrsht Italian 4.0.2.2
Comment 13 Arnaud Versini 2013-07-20 13:06:35 UTC
Replacing in traduction "Titre" by "Titre principal seems to remove the issue for the french UI.
Comment 14 Niklas Johansson 2013-07-20 19:41:15 UTC
Can confirm the effect on Swedish version as well. Works well in LibreOffice 3.6 beta 4.0 beta but not in LibreOffice 4.1 rc3. As a sidenote the same issue is present in OpenOffice.org 3.3. Though there was a translation problem in that version were the Styles Title and Heading was both translated into Rubrik so there might be some issues because of that.

Sorry if my comment are mute I haven't had any time to read the last comments in this thread. Sorry got to go!
Comment 15 Adolfo Jayme 2013-07-20 22:18:59 UTC
This may be related to bug 61339 and bug 63141.
Comment 16 Laurent BP 2013-07-20 22:29:00 UTC
(In reply to comment #10)
> + are we _sure that the problem is bisected between beta1 and beta2 as
> indicated by comment #6 ?
I can confirm both on Win7 and Linux x64 (openSuse)that:
- bug is NOT present in beta1
- bug IS present in beta2
Comment 17 Laurent BP 2013-07-21 23:06:43 UTC
New tests:

Bug appeared between 4.1.0.0beta1 and beta2 for FR, IT and PT UI languages

Problem seems different with ES UI language, as bug was ALREADY in 4.0.4.2 and 3.6.7.1
Comment 18 Mikeyy - L10n HR 2013-07-22 20:17:14 UTC
Bug affects hr (croatian) locale also. Win7 64bit, LO 4.1.0.3
Comment 19 Cheng-Chia Tseng 2013-07-23 15:31:26 UTC
Bug affects Chinese (Taiwan) locale, confirmed with 4.1.0.1.
Comment 20 Thorsten Behrens (CIB) 2013-07-24 08:56:11 UTC
Fixes are in for 4.1.0 rc4, available for testing here:

 http://www.libreoffice.org/download/pre-releases/
Comment 21 sophie 2013-07-24 09:01:23 UTC
I just check the test document and it's fixed for the FR version. My version: Version: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Thanks! Sophie
Comment 22 Mikeyy - L10n HR 2013-07-24 09:36:10 UTC
Nothing changed for croatian, still bugged.
You just applied new FR translation or fixed something in a code since I don't see any patches.
Comment 23 Laurent BP 2013-07-24 09:56:03 UTC
Hi,

Version 4.1.0.4: 89ea49ddacd9aa532507cbf852f2bb22b1ace28 on Win7
Bug is corrected for FR UI :)

However, there is still a bug (at least) for Italian (IT) and Spanish (ES) UI. All styles, which should inherit from "Heading", inherit from "Header" in ES and IT l10n.

For instance, when comparing flat XML (fodt) saved with EN UI or ES UI (with LibO 4.1.0.4) from the same file, you can find many differences such as:
***** Test4.0en.fodt
  </style:style>
  <style:style style:name="Title" style:family="paragraph" style:parent-style-name="Heading" style:next-style-name="Subtitle" style:class="chapter">
   <style:paragraph-properties fo:margin-top="3.81cm" fo:margin-bottom="0.33cm" style:contextual-spacing="false" fo:line-height
***** TEST4.0ES.FODT
  </style:style>
  <style:style style:name="Title" style:family="paragraph" style:parent-style-name="Header" style:next-style-name="Subtitle" style:class="chapter">
   <style:paragraph-properties fo:margin-top="3.81cm" fo:margin-bottom="0.33cm" style:contextual-spacing="false" fo:line-height
*****

Bug is already present with LibO 3.6.6 (but not in LibO 3.6.0.0beta1) for ES, but it appeared between beta1 and beta2 of LibO 4.1.0 for IT.
Comment 24 Laurent BP 2013-07-24 10:07:07 UTC
LibO 4.1.0.4. 
- Bug corrected with PT, Breton, RU, CN
- bug NOT corrected with Occitan, Croatian
Comment 25 Laurent BP 2013-07-24 15:20:33 UTC
Suspected source of bugs
For ES (Spanish)
Heading and Header have the same translation "Encabezado"
/translations/source/es/sw/source/ui/utlui.po
   2717 "STR_POOLCOLL_HEADER\n"
   2718 "string.text"
   2719 msgid "Header"
   2720 msgstr "Encabezado"
and
   2277 "STR_POOLCOLL_HEADLINE_BASE\n"
   2278 "string.text"
   2279 msgid "Heading"
   2280 msgstr "Encabezado"

For IT (Italian)
Heading and Header have the same translation "Intestazione"
/translations/source/it/sw/source/ui/utlui.po
   2717 "STR_POOLCOLL_HEADER\n"
   2718 "string.text"
   2719 msgid "Header"
   2720 msgstr "Intestazione"
and
   2277 "STR_POOLCOLL_HEADLINE_BASE\n"
   2278 "string.text"
   2279 msgid "Heading"
   2280 msgstr "Intestazione"

For OC (Occitan)
Heading and Title have the same translation "T��tol"
/translations/source/oc/sw/source/ui/utlui.po
   2277 "STR_POOLCOLL_HEADLINE_BASE\n"
   2278 "string.text"
   2279 msgid "Heading"
   2280 msgstr "T��tol"
and
   3141 "STR_POOLCOLL_DOC_TITEL\n"
   3142 "string.text"
   3143 msgid "Title"
   3144 msgstr "T��tol"

For HR (Croatian)
Heading and Title have the same translation "Naslov"
/translations/source/hr/sw/source/ui/utlui.po
   3141 "STR_POOLCOLL_DOC_TITEL\n"
   3142 "string.text"
   3143 msgid "Title"
   3144 msgstr "Naslov"
and
   2277 "STR_POOLCOLL_HEADLINE_BASE\n"
   2278 "string.text"
   2279 msgid "Heading"
   2280 msgstr "Naslov"

For AM (Amharic)
Heading and Title have the same translation

For BN and BN-IN (Bengali)
Heading and Title have the same translation

For BO (Tibetan)
Heading and Title have the same translation

For BS (Bosnian)
Heading and Title have the same translation "Naslov"
/translations/source/bs/sw/source/ui/utlui.po
   3141 "STR_POOLCOLL_DOC_TITEL\n"
   3142 "string.text"
   3143 msgid "Title"
   3144 msgstr "Naslov"
and
   2277 "STR_POOLCOLL_HEADLINE_BASE\n"
   2278 "string.text"
   2279 msgid "Heading"
   2280 msgstr "Naslov"

For EL (Greek)
Heading and Header have the same translation

Tested from AF to EU l10n
Comment 26 Cheng-Chia Tseng 2013-07-24 16:07:23 UTC
Tested with 4.1.0.4, Chinese (Traditional) is showed as fixed now. (a green text left align).
Comment 27 Michael Meeks 2013-07-24 20:03:54 UTC
So - to confirm - this is still busted for major languages in RC4 ? and we badly need an automated test / translation / lint tool to ensure this never happens again ?
Comment 28 Laurent BP 2013-07-24 22:42:18 UTC
Next tests from GA to SW-TZ

For HI (Hindi)
Heading and Title have the same translation

For ID (Indonesian)
Heading and Title have the same translation "Judul"
/translations/source/id/sw/source/ui/utlui.po
   2277 "STR_POOLCOLL_HEADLINE_BASE\n"
   2278 "string.text"
   2279 msgid "Heading"
   2280 msgstr "Judul"
and
   3141 "STR_POOLCOLL_DOC_TITEL\n"
   3142 "string.text"
   3143 msgid "Title"
   3144 msgstr "Judul"

For KA (Georgian)
Heading and Header have the same translation

For KO (Korean)
Heading and Title have the same translation

For KOK (Konkani)
Heading and Title have the same translation

For MAI (Maithili)
Heading and Title have the same translation

For MK (Macedonian)
Heading and Header have the same translation

For ML (Malayalam)
Heading and Header have the same translation

For MN (Mongolian)
Heading and Header or Title have the same translation (?)

For MNI (Manipuri)
Heading and Title have the same translation

For MY (Burmese)
Heading and Header or Title have the same translation (?)

For NE (Nepali)
Heading and Title have the same translation

For NN (Norvegian Nynorsk)
Heading and Title have the same translation "Overskrift"
/translations/source/nn/sw/source/ui/utlui.po
   3141 "STR_POOLCOLL_DOC_TITEL\n"
   3142 "string.text"
   3143 msgid "Title"
   3144 msgstr "Overskrift"
and
   2277 "STR_POOLCOLL_HEADLINE_BASE\n"
   2278 "string.text"
   2279 msgid "Heading"
   2280 msgstr "Overskrift"

For NSO (Northern Sotho)
! Heading and Subtitle have the same translation "Sehlogwana"
/translations/source/nso/sw/source/ui/utlui.po
   2277 "STR_POOLCOLL_HEADLINE_BASE\n"
   2278 "string.text"
   2279 msgid "Heading"
   2280 msgstr "Sehlogwana"
and
   3149 "STR_POOLCOLL_DOC_SUBTITEL\n"
   3150 "string.text"
   3151 msgid "Subtitle"
   3152 msgstr "Sehlogwana"

For OM (Oromo)
Heading and Title have the same translation "Mataduree"
/translations/source/om/sw/source/ui/utlui.po
   3143 "STR_POOLCOLL_DOC_TITEL\n"
   3144 "string.text"
   3145 msgid "Title"
   3146 msgstr "Mataduree"
and
   2276 "STR_POOLCOLL_HEADLINE_BASE\n"
   2277 "string.text"
   2278 msgid "Heading"
   2279 msgstr "Mataduree"

For OR (Oriya)
Heading and Title have the same translation

For SA-IN (Sanskrit)
Heading and Title have the same translation

For SID (Sidama)
Heading and Title have the same translation "Umo"
/translations/source/sid/sw/source/ui/utlui.po
   3158 "STR_POOLCOLL_DOC_TITEL\n"
   3159 "string.text"
   3160 msgid "Title"
   3161 msgstr "Umo"
and
   2285 "STR_POOLCOLL_HEADLINE_BASE\n"
   2286 "string.text"
   2287 msgid "Heading"
   2288 msgstr "Umo"
Comment 29 Laurent BP 2013-07-25 07:39:13 UTC
Next tests from TA to ZU

For TG (Tajik)
Heading and Title have the same translation

For UG (Uygur)
Heading and Title have the same translation

For UZ (Uzbek)
! Heading and Caption have the same translation "Sarlavha"
/translations/source/uz/sw/source/ui/utlui.po
   2276 "STR_POOLCOLL_HEADLINE_BASE\n"
   2277 "string.text"
   2278 msgid "Heading"
   2279 msgstr "Sarlavha"
and
   2804 "STR_POOLCOLL_LABEL\n"
   2805 "string.text"
   2806 msgid "Caption"
   2807 msgstr "Sarlavha"

To summarize all my tests with LibO 4.1.0.4:
# L10N with same translation of style name "Heading" with another style (Header, Title, Caption, Subtitle...)
- am, bn, bo, bs, el, es, hi, hr, id, it, ka, ko, kok, mai, mk, ml, mn, mni, my, ne, nn, nso, oc, om, or, sa-IN, sid, tg, ug, uz
# L10N without problem detected
- af, ar, as, ast, be, bg, br, brx, ca, cs, cy, da, de, dgo, dz, en-GB, en-ZA, eo, et, eu, fa, fi, fr, ga, gd, gl, gu, he, hu, is, ja, kk, km, kn, ks, ku, lb, lo, lt, lv, mr, nb, nl, nr, pa-IN, pl, pt, pt-BR, ro, ru, rw, sat, sd, sh, si, sk, sl, sq, sr, ss, st, sv, sw-TZ, ta, te, th, tn, tr, ts, tt, uk, ve, vi, xh, zh-CN, zh-TW, zu

However, some other duplication of style names may exist or will appear. As mentioned by Mickael Meeks on comment27
https://www.libreoffice.org/bugzilla/show_bug.cgi?id=67093#c27
an automated test should be performed.

Another problem will appear when this bug will be fixed for document saved with a wrong style hierarchy and open in a correct one.
Comment 30 Arnaud Versini 2013-07-25 07:45:48 UTC
For your information the italian bug already occures :
https://issues.apache.org/ooo/show_bug.cgi?id=115232
Comment 31 Arnaud Versini 2013-07-25 08:15:07 UTC
Normally resolved for italians in 4.1.1
Comment 32 Andras Timar 2013-09-02 21:15:19 UTC
Fixed by 83cf8a270e2e6b2dabecb9eee97faa879542787c (libreoffice-4-0) and by ff3cff1f9e31f89c0648340f952dcb52a0403aaa (libreoffice-4-1). The new pocheck tool can delete wrong translations.

Before commiting updated translations to git, run this:
make cmd cmd=solver/*/bin/pocheck