Download it now!
Bug 67113 - UI: the AutoText icon on the Insert toolbar has no more arrow to choose AutoText
Summary: UI: the AutoText icon on the Insert toolbar has no more arrow to choose AutoText
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0 target:4.1.1
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-20 09:30 UTC by pierre-yves samyn
Modified: 2013-09-06 08:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2013-07-20 09:30:37 UTC
Hello

In previous releases, the AutoText icon on the Insert bar had an arrow to choose AutoText.

This possibility has disappeared. This is a regression.


Regards
Pierre-Yves
Comment 1 Regina Henschel 2013-07-22 00:01:03 UTC
It was OK in Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)

It is broken in Version: 4.1.0.0.beta2 Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6
Comment 2 Commit Notification 2013-07-25 11:27:46 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a645a14cf46a1160c426052823772ad117f0bd8b

Related: fdo#67113 restore some code, it has side effects



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Ivan Timofeev (retired) 2013-07-25 11:40:27 UTC
Caolan, reverting your commit 0741054cb9f58fe6e021fe04fb477f0e56366d9e "glossary/autotext isn't a toggleable dialog" helps here.

This toolbutton registers as
  SwTbxAutoTextCtrl::RegisterControl(FN_GLOSSARY_DLG, pMod );

SwTbxAutoTextCtrl defined as
  SFX_IMPL_TOOLBOX_CONTROL( SwTbxAutoTextCtrl, SfxBoolItem );

i.e. with *SfxBoolItem*, but FN_GLOSSARY_DLG is
  SfxVoidItem EditGlossary FN_GLOSSARY_DLG

i.e. *SfxVoidItem*

so the following condition in SfxToolBoxControl::CreateControl is false (line 339):
  (rFactories[nFactory]->nTypeId == aSlotType)
therefore it fails to create SwTbxAutoTextCtrl and returns NULL.

So... I wonder if changing FN_GLOSSARY_DLG to SfxBoolItem is a right fix here?
Comment 4 Caolán McNamara 2013-07-25 13:34:35 UTC
Bah, what I *wanted* to happen is that insert->autotext doesn't show a toggle checkbox but I was unaware of the toolbox stuff
Comment 5 Commit Notification 2013-07-25 14:01:50 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb98778dbf761a0c88c96117add00a66e5cc6c95

Resolves: fdo#67113 split insert autotext and field controls



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2013-07-25 14:05:00 UTC
can you double check this all works ok now in master and if so I'll propose for 4-1
Comment 7 Ivan Timofeev (retired) 2013-07-25 14:59:19 UTC
It works for me in master, thanks :)
Comment 8 Commit Notification 2013-07-25 17:41:19 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab79f3def7ce98d27e096e6b40203787dde2f3fb&h=libreoffice-4-1

Related: fdo#67113 restore some code, it has side effects


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-07-25 17:41:39 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cf908fbf1119446000fe75c57f15d08046b8091d&h=libreoffice-4-1

Resolves: fdo#67113 split insert autotext and field controls


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 pierre-yves samyn 2013-09-06 08:05:58 UTC
Hello

WORKSFORME with Version: 4.1.2.1
Build ID: bf15ac65c2167fb1ef3daf3710609d4a4c369a9

Thank you :)
And sorry for the delay to test...

Regards
Pierre-Yves