Download it now!
Bug 67148 - Wiki help includes several unlocalizable strings
Summary: Wiki help includes several unlocalizable strings
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-21 21:49 UTC by Martin Srebotnjak
Modified: 2018-04-19 13:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2013-07-21 21:49:00 UTC
Wiki help uses several non-localizable strings in its rendering of online help on the wiki, i.e.  "In the Writer", "In the Calc". These make it look as if localizers did not localize help fully.

Example:
https://help.libreoffice.org/Common/Switching_Between_Insert_Mode_and_Overwrite_Mode/sv
https://help.libreoffice.org/Common/Switching_Between_Insert_Mode_and_Overwrite_Mode/ru
https://help.libreoffice.org/Common/Switching_Between_Insert_Mode_and_Overwrite_Mode/ast

So please add these special strings to the help po files so they can be localized.
Comment 1 Adolfo Jayme 2013-07-24 11:47:31 UTC
The problem is quite visible in Wikihelp, marking this bug as NEW.
Comment 2 Valter Mura 2013-07-24 19:28:32 UTC
Confirmed for Italian
Comment 3 QA Administrators 2015-04-01 14:42:56 UTC Comment hidden (obsolete)
Comment 4 Martin Srebotnjak 2015-04-01 14:58:02 UTC
Can still confirm, this bug is still present.
Since this bug is still present it just shows that totally moving Help writing/editing & translation to wiki is really not feasible if already fully making it localizable on wiki is a problem that persists so long that the bugbot asks for a bug update...
Comment 5 Adolfo Jayme 2015-11-23 23:59:11 UTC
@Dennis: I think this is also material for Infrastructure, I’ll let you decide… I think this is solvable by creating a template in the Help wiki and adding translations to it with a #switch, but us translators cannot register on that wiki.
Comment 6 Dennis Roczek 2015-11-28 22:27:51 UTC
yeah, I will take this. :-)

You can see that the untranslatedstring is in a template https://help.libreoffice.org/WikiAction/edit/Common/Switching_Between_Insert_Mode_and_Overwrite_Mode/sv --> https://help.libreoffice.org/Template:WhenInWriter

The code is in http://opengrok.libreoffice.org/xref/help/to-wiki/wikiconv2.py#928
so we should add here the language code ({{WhenIn%s --> e.g. {{WhenIn%s/sv)

This is rather easy to fix. The only question is how to upload / update the code so that Pootle asks for text for a translation for WhenIn%s/sv
Comment 7 Dennis Roczek 2016-02-13 12:34:29 UTC
@Cloph how can we localize the WhenInWriter (etc) templates? Any idea how to get them in Pootle?
Comment 8 Olivier Hallot 2018-04-19 13:41:48 UTC
Closing this bug since we are phasing out wikihelp since 6.0.

Page is now:

https://help.libreoffice.org/6.1/sv/text/shared/guide/textmode_change.html