Bug 67152 - Symbol catalog: no way to change font en-masse
Summary: Symbol catalog: no way to change font en-masse
Status: RESOLVED DUPLICATE of bug 101174
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-22 04:13 UTC by john
Modified: 2017-05-08 23:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2013-07-22 04:13:13 UTC
As noted in bug #48965, there is a problem with missing font metrics in the OpenSymbol font, at least that which is distributed with Ubuntu 12.04.

It should be possible to change the font of all greek letters to a different font, preferably as a document-level preference, but as a system-level one alternatively.

As well as because of font problems, it is also desirable to allow this so that users can produce higher-quality documents with fonts of their choice. But such documents should contain the required font information embedded within them, and not separately in the machine-specific libreoffice registry.

It looks like one way to do this would be via registry hacking, eg editing 'registrymodifications.xcu', but there should be a better way, really.
Comment 1 Cor Nouws 2013-07-22 13:07:12 UTC
Hi John,
Thanks for reporting this!

I hardly ever work with Math, but I must understand from your report that there are no (character) syles involved that you can use?

Regards,
Cor
Comment 2 Cor Nouws 2013-07-22 13:07:48 UTC
Hi John,
Thanks for reporting this!

I hardly ever work with Math, but I must understand from your report that there are no (character) styles involved that you can use?

Regards,
Cor
Comment 3 john 2013-07-24 05:38:54 UTC
Hi Cor,

No, the formula/math editor in LibreOffice I guess has its roots in intended compability with MS Equation Editor (and whatever the 'full version' of that was called). That system was totally divorced from the Styles system of the word processor, and it continues to be that way all the way to the present.

There are character styles, but they're defined inside the Formula component, and it's nothing like the styles feature in the rest of the Writer. And I'm not sure where the default/preferred styles are stored. I think they're stored somewhere that's system-specific rather than document specific. And it's worse! If you change the default in Writer, then insert a formula in Presentation, you get a tiny text formula. The default sizes should depend on the insertion context, but they don't, or didn't last time I checked.

So, character styles do exist, but the Symbol Catalog ignores them completely. If you insert a symbol from the Catalog, its font and style are defined by the symbol catalog alone, and don't change to reflect chosen character styles.

I found that the information in the Symbol Catalog is stored in the LibreOffice registry. My local machine has ~/.config/libreoffice/4/user/registrymodifications.xcu which contains for example

<item oor:path="/org.openoffice.Office.Math/FontFormatList/org.openoffice.Office.Math:FontFormat['Id1']"><prop oor:name="Name" oor:op="fuse"><value>OpenSymbol</value></prop></item>

and I suspect that simply changing that might solve my problem. But it's a bad solution... what happens to my other documents, if I only want to change the symbol font for a particular document? And how do I force LibreOffice to re-render all of my equations with the modified symbols?

Thanks for your comment, hope we can find some help from someone.

Cheers
JP
Comment 4 Cor Nouws 2013-07-30 20:53:48 UTC
Thanks for further description.
I set this to enhancement.

Maybe the summary line could be more clear?

ALso: would be useful to trigger some attention (users list?) from people working a loth with Math, so that they can jump in and help with precisely defining needs and such?
Comment 5 e_psi 2014-04-14 19:27:22 UTC
Dump the obsolete catalog, use Unicode and add Greek to Format>Font…
Comment 6 john 2017-01-11 02:30:39 UTC
Please revise this bug to be at least minor if not major. The current hard-wired OpenSymbol font lacks metric information. It is critical that users be able to change the font used for greek symbols etc in the symbol catalog. If you can tell me a work-around that allows me to do this, then fixing the symbol catalog can be considered an 'enhancement'.

But at the moment, it is not possible to produce good clear equations!
Comment 7 john 2017-01-11 02:32:56 UTC
Please refer to bug 104749 for a description of the un-workaround-able problem with the OpenSymbol font that necessitates either (1) changing the font permanently or (2) allowing the user to change the font.
Comment 8 V Stuart Foote 2017-05-08 14:04:30 UTC
Not as clean as the more involved bug 101174 which requires a major refactoring, but it is already trivial to do this and also adjust the Greek symbols catalog.

Tools -> Options -> Fonts: checkbox "Apply replacement table" to activate replacement table.  In the "Font" drop list select "Open Symbol" and in the "Replace with" select "Cambria Math" (or Asana, or STYX as installed).

Green check button to add to listing. And if the "Always" is checked, the substituted font is saved to profile, but also will be exported (e.g. subset into PDF).

Otherwise just "Screen only" affecting the GUI.

OK to apply and exit.

The Greek "Symbols" dialog and the rest of the GUI will refresh with the substitution font.
Comment 9 john 2017-05-08 23:34:33 UTC
(In reply to V Stuart Foote from comment #8)
> Not as clean as the more involved bug 101174 which requires a major
> refactoring, but it is already trivial to do this and also adjust the Greek
> symbols catalog.
> 
> Tools -> Options -> Fonts: checkbox "Apply replacement table" to activate
> replacement table.  In the "Font" drop list select "Open Symbol" and in the
> "Replace with" select "Cambria Math" (or Asana, or STYX as installed).
> 
> Green check button to add to listing. And if the "Always" is checked, the
> substituted font is saved to profile, but also will be exported (e.g. subset
> into PDF).
> 
> Otherwise just "Screen only" affecting the GUI.
> 
> OK to apply and exit.
> 
> The Greek "Symbols" dialog and the rest of the GUI will refresh with the
> substitution font.

This solution sounds interesting, but it it's still a workaround. It would lead to some issues when collaboratively editing a document -- one would have to explain this required configuration change, which would have the side-effect of changing other documents that colleagues might be working on.

Also, my preferred font for Math is Liberation Serif, but it is missing some symbols such as %varphi, so would prefer to still be able to acess OpenSymbol (but indeed, I could use STYX etc instead)
Comment 10 john 2017-05-08 23:35:47 UTC
Hence I am arguing that this is not fixed, as this setting does not persist with the document when it is sent to others.
Comment 11 V Stuart Foote 2017-05-08 23:50:04 UTC
The premise that there is no way to change the font en-masse is simply not true as demonstrated.  Beyond the font substitution that works correctly there is no development effort to be applied here.

Otherwise the refactoring needed to replace the existing hardcoding of OpenSans as  FONTNAME_MATH, FNTNAME_MATH, and FNT_MATH is reasonably well understood with several options of how to implement. 

Will go ahead and dupe this to the actual refactoring that would see this corrected in the general case

*** This bug has been marked as a duplicate of bug 101174 ***