Bug 67223 - UI: problem changing font with drop down from Formatting toolbar, if target area is not already all one font: selection in dropdown jumps up when using the mouse
Summary: UI: problem changing font with drop down from Formatting toolbar, if target a...
Status: RESOLVED DUPLICATE of bug 63273
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-23 16:12 UTC by Tim Deaton
Modified: 2013-08-29 22:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Illustration of font-changing problem (19.58 KB, application/vnd.oasis.opendocument.text)
2013-07-23 20:05 UTC, Tim Deaton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Deaton 2013-07-23 16:12:51 UTC
I use Writer weekly to make notes for a Bible study class.  In doing so, I copy Bible passages from my Bible Study software into Writer.  I want to keep most of the passages' formatting, but I do change the font using the dropdown list in the Formatting toolbar.  However, I have discovered that I cannot do that if I have selected text that has existing formatting including more than one font.  When I try, the dropdown list will jump back to the top of its list within a second or less after I start trying to move to the font I want.

The default style for my study notes uses Lucida Console 8.
The default font from the Bible Study software is Georgia 11.
I'm changing the Bible passage font to Times New Roman 10.

If I'm trying to change one contiguous passage that's all one font, I have no problem.  But If I'm trying to change multiple passages that have space between them, then the existing font for the passage is Georgia, while the existing font for that space would be Lucida.  THAT's when I have the problem.
Comment 1 Cor Nouws 2013-07-23 19:34:05 UTC
Hi Tim,

Works fine for me. In any case, if I understood your problem well.

Could you pls attach a sample file, with such passages that need to be selected together and then one wants to change the font of all selected text at once?
Comment 2 Tim Deaton 2013-07-23 20:02:38 UTC
Thank you, Cor.

I just created a new file, with a little bit of notes followed by two Bible passages copied from my e-Sword Bible Study software.  The passages are Ecclesiastes 1:1-4 and 1:5-8, with one blank line separating them.  If I select only one of the passages (with no surrounding lines), it works fine.  If I select both (and thus have that blank line between them), using the dropdown box in the formatting toolbar, it fails like I described.  If I use the "Format" menu and choose "Character..", it works. 

The file I'm uploading is "Test 1 - Eccl 1.odt".
Comment 3 Tim Deaton 2013-07-23 20:05:33 UTC
Created attachment 82873 [details]
Illustration of font-changing problem
Comment 4 Cor Nouws 2013-07-23 20:58:50 UTC
Thanks Tim.

Interesting problem that I can confirm. I tested in 4.1.0 rc3

One still can use the list by typing the first letter of the font name.
Or by using Pg-Down. 

But still, it should be easily possible by using the mouse too ;)
Now, as long as I point to the slider, I can go down and the focus of the list stays where I go. But as soon as I move the mouse to the list, the focus goes up.

Any idea if it worked better in previous versions?

(Would not be surprised if the preview of the fonts in the list has to do with this).
Comment 5 Cor Nouws 2013-07-23 20:59:40 UTC
Tested on Linux 32 bits
Comment 6 Tim Deaton 2013-07-23 21:11:49 UTC
I didn't try the PgDn key, but I DID try typing the first letter or first few letters.  Ass soon as I stip typing, or even before I stop, it shoots back up to the top.
Comment 7 Tim Deaton 2013-07-23 21:13:01 UTC
I had not run into it before, but then I'm normally only trying to change one contiguous section.
Comment 8 Cor Nouws 2013-07-30 21:05:50 UTC
This worked fine in 3.6 (am not able to do more precise testing, appols)
So it is a regression.

Caolán (or the appropriate collegue):
 - use attachment 82873 [details] 
 - select all text on page 1
 - open the font drop down list with the mouse and drag it below
 (- maybe move the mous pointer a bit on the fonts list)
 > list jumps back up
Comment 9 Michael Stahl (CIB) 2013-08-29 11:51:08 UTC
it is already fixed on master and libreoffice-4-1 by:

commit e2484e3998f2c5036fb8e3584d4b1c72db19bfd3
Author:     Miklos Vajna <vmiklos@suse.cz>
AuthorDate: Tue Jul 16 18:26:18 2013 +0200

    fdo#63273 sw: let word count not update stat. fields

    Updating fields would generate loads of selection change events and it's
    not what we asked for.

*** This bug has been marked as a duplicate of bug 63273 ***
Comment 10 Tim Deaton 2013-08-29 14:30:48 UTC
I'm confused by Michael Stahl's post today (I don't understand how this problem is a duplicate of bug 63273), but the problem I reported does seem to be fixed in version 4.0.5.2.

Thank you.
Comment 11 Miklos Vajna 2013-08-29 14:47:02 UTC
The root cause of the two problems were the same.
Comment 12 Tim Deaton 2013-08-29 22:15:48 UTC
Thank you.