Bug 67258 - languagepack install fails when spotlight is disabled
Summary: languagepack install fails when spotlight is disabled
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.0 target:4.1.1 target:4.0.5
Keywords:
Depends on:
Blocks: 33682
  Show dependency treegraph
 
Reported: 2013-07-24 14:18 UTC by Christian Lohmaier
Modified: 2013-09-26 17:33 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lohmaier 2013-07-24 14:18:38 UTC
From bug 33682
#####################
Comment 10 cfr 2011-04-08 17:02:05 UTC
I am also on PPC and having trouble installing language packs. I specifically tried to install the language packs for British English and Welsh/Cymraeg. Once installed, LibreOffice correctly picks up Welsh as the appropriate default for the user interface but the .app provided for installation does not work for either pack. In both cases, I moved the .tar.bz2 file to LibreOffice.app/ and just used bunzip2 and gnutar -xf to install the files manually. This seems to work fine but is probably not a method accessible to most users. (And if this is the best method, it would obviously be easier to just download the .tar.bz2 archive rather than having to disentangle the .app.)

Hardware is PPC 7450, 1.5GHz with OS X 10.4.11.

Errors from console.log:

/Users/<me>/Documents/src/libreoffice/cy/LibreOffice 3.3 Language Pack.app/Contents/osx_install.applescript:1885:2067: execution error: Failed to create query for 'kMDItemContentType == 'com.apple.application-bundle' && kMDItemDisplayName == 'LibreOffice*' && kMDItemDisplayName != 'LibreOffice 3.3 Language Pack.app''. (1)

/Users/<me>/Documents/src/libreoffice/gb/LibreOffice 3.3 Language Pack.app/Contents/osx_install.applescript:1885:2067: execution error: Failed to create query for 'kMDItemContentType == 'com.apple.application-bundle' && kMDItemDisplayName == 'LibreOffice*' && kMDItemDisplayName != 'LibreOffice 3.3 Language Pack.app''. (1)

I have dictionaries installed as part of the main application install for various languages, including UK English, Spanish, French etc. Basically dict-en, dict-es and dict-fr appear to be installed by default. There's no dictionary for Welsh either by default or in the language pack but this might just be a lack of support for Welsh. The user interface is only partially translated in any case.

The .app does start the installation process. I get the initial dialogue with the choice to "Abort" or "Install". (None of this is translated for the Welsh pack - interface is identical to UK English.) However, on clicking on "Install", the application simply disappears without trace. So I assume that the issue is with the applescript?
###########################
Comment 11 cfr 2011-04-08 17:34:24 UTC
OK. You should probably ignore my report. The installation applications fail in my case because I've disabled Spotlight. It would be nice if it would just ask me where LibreOffice is installed but disabling Spotlight is presumably considered a non-approved customisation so I must take responsibility for the consequences!
Comment 1 Commit Notification 2013-07-24 20:21:37 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bd242a8768b8e2f457af581c782ef8a9f2ba0be7

fdo#67258 catch error when calling mdfind



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2013-07-26 07:00:06 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=80328f390eceb32e1530ca182e6b135c3a0b0264&h=libreoffice-4-1

fdo#67258 catch error when calling mdfind


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2013-07-26 07:00:24 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02d706a3ce8a97ebe234acd3565817abb144a294&h=libreoffice-4-0

fdo#67258 catch error when calling mdfind


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 retired 2013-09-26 17:33:16 UTC
I guess FIXED is the correct status for this?