Download it now!
Bug 67260 - Can't send new document to master document if the UI is not in English
Summary: Can't send new document to master document if the UI is not in English
Status: RESOLVED DUPLICATE of bug 113876
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Master-Doc
  Show dependency treegraph
 
Reported: 2013-07-24 15:23 UTC by Krunoslav Šebetić
Modified: 2018-07-13 14:59 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Krunoslav Šebetić 2013-07-24 15:23:53 UTC
If English "version" of LO is opened, there is now problem doing File - Send - Create Master Document, file saves as should. But, when LO is set to Croatian UI it is not possible to do that. Error is displayed: The document can't be saved (in Croatian, not English as I put it here since we have translation to 100%.)
Comment 1 Krunoslav Šebetić 2013-07-24 15:30:03 UTC
Problem exists only if you have new (unsaved) document opend.
Comment 2 Thomas Hackert 2013-07-24 15:46:13 UTC
Hello Krunoslav, *,
I can confirm it with LO Version: 4.1.0.4 Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28 and installed Germanophone lang- as well as helppack under Debian Testing AMD64 ... :( When I use the Germanophone UI, create a Writer document with only "Test" in it, and send this via "File - Send - Create Master Document", I get the message "Das Dokument konnte nicht erzeugt werden." (roughly translated: The document could not be created.") ... :(
HTH
Thomas.
Comment 3 sophie 2013-07-25 16:37:04 UTC
I can't reproduce with FR UI, all is ok. My version Version: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28 Sophie
Comment 4 Urmas 2013-07-25 17:00:24 UTC
I have the same error with English UI too.
Comment 5 sophie 2013-07-25 17:03:14 UTC
(In reply to comment #4)
> I have the same error with English UI too.
Can you paste your system/ version/ Build ID please? Sophie
Comment 6 Urmas 2013-07-25 21:05:17 UTC
2cce78137bbf9810421b9fdedd45127b019b1188
Win 7 x64
Comment 7 Krunoslav Šebetić 2013-08-19 19:10:46 UTC Comment hidden (obsolete)
Comment 8 Krunoslav Šebetić 2013-08-19 19:12:33 UTC Comment hidden (obsolete)
Comment 9 Mirosław Zalewski 2013-10-23 15:03:29 UTC
Hi

Krunoslav, Thomas, Urmas: could one of you provide example document or detailed steps to reproduce, starting from fresh user profile?
When you do, please change status of this report back to NEW. Until then, let's leave it as NEEDINFO.
Sophie could not reproduce this issue, I have failed either. Since we don't have consensus here, I think it's better to remove NEW status from report.


I have noticed that File -> Send -> Create new master doc will fail if opened file does not have Heading 1 style definition. You can create that definition by either:
a) applying Heading 1 style to any paragraph
b) changing Heading 1 properties (change interline or whatever)

Be aware, that style definition might be inherited from template used to create document.

So, this will result in error message:
1. Open LO with new, never used before, profile directory (use -env:UserInstallation=file:// command line switch)
2. Create new Writer document
3. File -> Send -> Create new master doc
4. After specifying filename, LO will show error

It doesn't matter whether you save document or not before step 3. Apparently, language and locale settings don't matter either.
But if you apply Heading 1 to any paragraph, or change heading 1 properties, before step 3, then LO will successfully create new master document.

I think that you might have run into issue mentioned above and mistakenly thought that UI language plays a role here. Which would be understandable, as many master document quirks are not documented.
Comment 10 Jean-Baptiste Faure 2013-11-29 22:23:51 UTC
Reproducible for me with Version 4.2.0.0.beta1
Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7
with a clean new user profile.

UI in French -> KO
UI in English -> OK

Steps to reproduce:
1/ open a new text document with the UI in French
2/ type TEX+F3 (autotext)
3/ Menu Fichier > Envoyer > Créer un document maître
4/ type the name of the new file
==> Error message: Impossible de créer le document

UI in English:
2/ type DT+F3 (autotext Dummy Text)
3/ Menu File > Send > Create a Master Document
4/ Type the name of the new file
==> The file is created

Set status back to NEW

Best regards. JBF
Comment 11 QA Administrators 2015-04-19 03:23:42 UTC Comment hidden (obsolete)
Comment 12 Jean-Baptiste Faure 2015-04-20 04:41:57 UTC
Still reproducible with LibreOffice 4.4.4.0.0+ built at home under Ubuntu 14.10 x86-64 and French UI.

Best regards. JBF
Comment 13 Kruno 2016-04-09 08:33:15 UTC
Still present :D

Inačica: 5.1.2.2
ID Inačice: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU niti: 2; OS inačica: Linux 3.16; Ui crtač: zadano; 
Jezik: hr-HR (en_US.UTF-8)

Linux jessie 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt25-1 (2016-03-06) i686 GNU/Linux
Comment 14 Kruno 2016-08-23 11:52:02 UTC
Present in 5.3 alpha (and translating user interface is a hard work).
Comment 15 Xisco Faulí 2017-06-12 11:36:03 UTC
Changing version back to the earliest affected version.
Comment 16 Buovjaga 2018-07-13 14:59:47 UTC

*** This bug has been marked as a duplicate of bug 113876 ***