Download it now!
Bug 67307 - Y error bars settings not loaded properly
Summary: Y error bars settings not loaded properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-25 15:00 UTC by faber
Modified: 2016-05-08 07:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File with 'cell range' y errors in a chart (14.10 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-09-10 04:59 UTC, faber
Details
Y error bars line style changed to "NONE (431.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-03-10 19:01 UTC, oara27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description faber 2013-07-25 15:00:04 UTC
I have a series of graphs that use Y error bars which are fed from cell values, for positive and negative range separately.

When I load a ODS file containing such Y error bars, the settings are modified to "Same value for both" and both cell ranges are set to the same value (the cells for the positive range).

Once manually corrected, the settings stay put as long as the document is opened.

In the stored file the attributes seem to be set correctly:

<style:chart-properties [..] chart:error-category="cell-range" chart:error-upper-range="Zugfestigkeit.B30:Zugfestigkeit.M30" chart:error-lower-range="Zugfestigkeit.B29:Zugfestigkeit.M29" [..]

So this error seems to occur when loading a file containing such Y error bars.
Comment 1 ign_christian 2013-07-26 03:20:34 UTC
Perhaps related to Bug 60083
Comment 2 faber 2013-07-26 05:16:02 UTC
Yes, the whole error bar topic seems to have a funny smell. Sorry for my wrong title, btw.: s/sav/load

I have also noticed that sometimes the error bars disappear completely while working in the sheet, but I was not able to create a reproducible sequence of steps (yet).
Comment 3 Jean-Baptiste Faure 2013-09-07 10:56:40 UTC
Updated summary due to comment #2.

Please, could you attach an example file ?
Did you experienced the same problem with LO 4.0.x or is it new in 4.1.0 ?

Best regards. JBF
Comment 4 faber 2013-09-10 04:58:57 UTC
It occured in all 4.x versions I have tested so far (currently 4.1.1.2). 

The attached file is a very basic chart with y error bars. In the Object 1/content.xml we can see:

chart:error-upper-range="Sheet1.B4:Sheet1.K4" 
chart:error-lower-range="Sheet1.B5:Sheet1.K5"

But when loaded, we can see that "Same value for both" is checked and only the positive range is displayed in both text fields.
Comment 5 faber 2013-09-10 04:59:59 UTC
Created attachment 85529 [details]
File with 'cell range' y errors in a chart

Stored with different ranges for positive and negative values.
Comment 6 Jean-Baptiste Faure 2013-09-11 04:59:28 UTC
I reproduce the problem with the attachment with both LO 4.0.5 and LO 4.1.x. If I modify the Y error bars to have positive and negative range separately and save the modified file with LO 4.0.5, then it opens fine and the change is preserved.
Looking at the Object 1/content.xml, one can see that data for error bars are not stored in the same way. If I read correctly, there is 2 boolean values chart:error-upper-indicator and chart:error-lower-indicator that are not in the bugdoc.

Hi Markus, please, could you have a look? I am not sure, but this behavior seems to be linked in some way to your improvements on error bars.
Comment 7 Jean-Baptiste Faure 2013-11-09 18:55:37 UTC
Forgot to set the status to NEW.
I still reproduce the problem with LO 4.1.4.0.0+ under Ubuntu 13.10 x86-64


Best regards. JBF
Comment 8 oara27 2015-03-10 19:01:55 UTC
Created attachment 114025 [details]
Y error bars line style changed to "NONE
Comment 9 oara27 2015-03-10 19:02:33 UTC
When I open in LibreOffice 4.* a Calc file created with OpenOffice (any version, up to 4.1.1,) all the Y error bars line style properties are changed to "NONE". This seems related to the bug reported on this thread. 

I am attaching a file so the issue can be reproduced. The file has data and two charts, one is editable, the other is a metafile showing how the first chart is supposed to look. Hopefully the posting will be useful, although since this problem has been round for almost two years, it doesn't look like anyone is working on it.

By the way, when I prepared the file for posting, I copied one sheet from the original spreadsheet to a new file. However, only two of the four charts in the original sheet made it to the copy. I realize that this is a different bug, that perhaps should be reported elsewhere, but user time is limited. 

As I pointed out in the related OpenOffice bug tracking system, it makes no sense for two outfits to be competing for users of the same buggy application. Apache and the Document Foundation ought to merge and serve jointly the free software community they claim to support.

Thank you,

O. Rondon
Comment 10 oara27 2015-03-10 19:03:34 UTC
Comment on attachment 114025 [details]
Y error bars line style changed to "NONE

When I open in LibreOffice 4.* a Calc file created with OpenOffice (any version, up to 4.1.1,) all the Y error bars line style properties are changed to "NONE". This seems related to the bug reported on this thread. 

I am attaching a file so the issue can be reproduced. The file has data and two charts, one is editable, the other is a metafile showing how the first chart is supposed to look. Hopefully the posting will be useful, although since this problem has been round for almost two years, it doesn't look like anyone is working on it.

By the way, when I prepared the file for posting, I copied one sheet from the original spreadsheet to a new file. However, only two of the four charts in the original sheet made it to the copy. I realize that this is a different bug, that perhaps should be reported elsewhere, but user time is limited. 

As I pointed out in the related OpenOffice bug tracking system, it makes no sense for two outfits to be competing for users of the same buggy application. Apache and the Document Foundation ought to merge and serve jointly the free software community they claim to support.

Thank you,

O. Rondon
Comment 11 tommy27 2016-04-16 07:26:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 12 Jean-Baptiste Faure 2016-05-08 07:17:08 UTC
Saving corrected file (Y error bars set to positive and negative range separately) with LO 5.1 seems to preserve this settings when reopening the file with LO 5.1 or the master.

So closing as WorksForMe. Please feel free to reopen if you disagree.

Nothing to say about comment #9 and comment #10, unless please open a separated bug report.

Best regards. JBF