Download it now!
Bug 60083 - ]FILEOPEN] spreadsheet doesn't show error bars
Summary: ]FILEOPEN] spreadsheet doesn't show error bars
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA bibisected40 target:4.1.0 target:...
Keywords: regression
: 56730 60767 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-30 17:55 UTC by KELLER
Modified: 2013-06-26 18:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with the problem (366.25 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-01-30 17:55 UTC, KELLER
Details
Work on LibreOffice 3.5.7 (175.85 KB, image/png)
2013-01-30 22:23 UTC, vulcain
Details
Problem with LibreOffice 3.6.2.2 (171.82 KB, image/png)
2013-01-30 22:24 UTC, vulcain
Details
bibisect40 log (2.85 KB, text/plain)
2013-01-30 22:41 UTC, Jorendc
Details
Disappearing Y error bars (33.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-09 08:02 UTC, andis.lazdins
Details
test docs for error bar import (47.62 KB, application/x-gzip)
2013-02-26 21:46 UTC, Markus Mohrhard
Details
test ods file with bar graph and y-error bars created using cell range (12.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-03-04 00:22 UTC, John Kuang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KELLER 2013-01-30 17:55:58 UTC
Created attachment 73941 [details]
Document with the problem

Problem description: 

Les barres d'erreur s'affichent avec la version 3.5.7.2 mais plus avec la version 3.6.4.3.
Si je modifie le fichier avec la version 3.6.4.3, j'arrive à afficher les barres d'erreurs correctement mais chaque fois que je l'ouvre de nouveau, les barres d'erreurs ont de nouveau disparu?

Steps to reproduce:

Ouvrir le fichier ci-joint


Current behavior: 

Expected behavior: 

              
Operating System: Windows 7
Version: 3.6.4.3 release
Comment 1 vulcain 2013-01-30 22:20:58 UTC
French translation (as i can ;-) ):

Problem description: 
We have bar of error's varriation in LibreOffice 3.5.7 but no in LibreOffice 3.6.4.3

If i change the file, i could try to see this bar of error's variation, but i lost this bars the next i open the file.

Operating System: Windows 7
Version: 3.6.4.3 release
Comment 2 vulcain 2013-01-30 22:23:27 UTC
Created attachment 73962 [details]
Work on LibreOffice 3.5.7

I reproduce on Ubuntu:
Ubuntu 12.04.1 LibreOffice 3.5.7: it's work
Ubuntu 12.10 LibreOffice 3.6.2.2: don't work

Expected: work as well in LibreOffice 3.5.7

See screenshot
Comment 3 vulcain 2013-01-30 22:24:20 UTC
Created attachment 73963 [details]
Problem with LibreOffice 3.6.2.2
Comment 4 Jorendc 2013-01-30 22:41:25 UTC
Thanks for the translation :-). Now I see the problem.

> I reproduce on Ubuntu:
> Ubuntu 12.04.1 LibreOffice 3.5.7: it's work
> Ubuntu 12.10 LibreOffice 3.6.2.2: don't work
You may set it to NEW as well then ;-). Because you can reproduce using 3.6.2.2 I set the bug version to 3.6.2.2 (oldest version we can reproduce this bug).

I can confirm the error bars aren't shown in LibreOffice 4.0.0.2 rc2 using Linux Mint 14 x64. I did a bibisect on this one.
Comment 5 Jorendc 2013-01-30 22:41:43 UTC
Created attachment 73964 [details]
bibisect40 log
Comment 6 Markus Mohrhard 2013-01-31 15:45:18 UTC
I believe I'm the one needing to look into it as it looks like it slipped through my review when I pushed the error bar imrovements.
Comment 7 andis.lazdins 2013-02-09 08:02:42 UTC
Created attachment 74475 [details]
Disappearing Y error bars

Hello!

I'm not sure it is the same problem, but looks very similar. Chart in attached file contains Y error bars, which disappear, when I try to copy/paste chart to any other document or the same file in libreoffice 4.0.0.3.  When I open this file in 3.6.5 and try to copy/paste it to other libreoffice file, Y error bars survive. There was another problem in previous libreoffice versions, that Y error bars disappeared, when I tried to edit pasted chart, but not anymore in 3.6.5. So the problem is luckily solved in this release.

What is the most strange, Y error bars disappear in 4.0.0.3 also when I paste chart as GDI metafile, so the only option to get chart to another document in 4.0.0.3 is to use screen copy.
Comment 8 Jorendc 2013-02-17 15:14:25 UTC
*** Bug 60767 has been marked as a duplicate of this bug. ***
Comment 9 Markus Mohrhard 2013-02-26 01:38:20 UTC
Ok it is a bit nasty.

The code for the x-error-bar import has several flaws which have been added to the y-error-bar import as well.

First we now ignore the default values written into the file which is responsible for some of the problems here. Secondly the non default values seem to be ignored as well but I have no idea yet why. I have already reverted the commit that introduced the regression as we need another way to implement x-error-bar import if we want to fix this.
Comment 10 Not Assigned 2013-02-26 06:44:21 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b63d1e56621d7a2369717d21d46cfee19be8e4bf

get at least the y-error-bar import working again, fdo#60083



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Markus Mohrhard 2013-02-26 06:53:37 UTC
So I got at least the y error bars back.

And just for the record: This error did not slip through my review as I did not review the commit that introduced this regression.
Comment 12 Not Assigned 2013-02-26 08:12:38 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91b67ad7180c9957a5e1ff41be5af83b0759655c

get the x-error-import working as well, fdo#60083



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Not Assigned 2013-02-26 09:10:19 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=01f8d0a1dffce854a66c0f957e81e6df6d361a86&h=libreoffice-4-0

get error bar import working again, fdo#60083


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Michael Meeks 2013-02-26 11:48:35 UTC
Comment #7 appears to work with a -4-0 with this included, but I still get no error bars from the #1 comment on either master or -4-0 as of now - which is odd :-)
Comment 15 Markus Mohrhard 2013-02-26 19:32:48 UTC
(In reply to comment #14)
> Comment #7 appears to work with a -4-0 with this included, but I still get
> no error bars from the #1 comment on either master or -4-0 as of now - which
> is odd :-)

Oh my hell, there are even more nasty cases in this horrible code. I have a fix for the positive part of the original document and somehow it does not work for the negative part.
Comment 16 Markus Mohrhard 2013-02-26 21:26:21 UTC
> Oh my hell, there are even more nasty cases in this horrible code. I have a
> fix for the positive part of the original document and somehow it does not
> work for the negative part.

I have a fix for it now too. I suspect there are a few more issues around error bar import so please test with 4.0.1 or 4.0.2 and put me into cc for all errors you see.
Comment 17 Not Assigned 2013-02-26 21:44:13 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c91b8d3251e3a8ad14e1b143af182c937bf6e5cb

one more fix for error bar import, fdo#60083



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Markus Mohrhard 2013-02-26 21:46:53 UTC
Created attachment 75603 [details]
test docs for error bar import

A set of test documents that show of the fixed problems.
Comment 19 Not Assigned 2013-02-27 10:32:14 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dd316847ce711333f4e30f52fd1d3a3795e57c93&h=libreoffice-4-0-1

get error bar import working again, fdo#60083


It will be available already in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Not Assigned 2013-02-27 10:38:31 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e220bc9850e5afd7d622c0adc6665af88dd25dcb&h=libreoffice-4-0

one more fix for error bar import, fdo#60083


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Not Assigned 2013-02-27 11:22:39 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=160c0f4c1fd381a91a7443088c7222ae4cc5b6a2&h=libreoffice-4-0-1

one more fix for error bar import, fdo#60083


It will be available already in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 John Kuang 2013-02-28 22:54:31 UTC
I think the error bars disappear after saving/reopen because the
Comment 23 John Kuang 2013-02-28 22:59:31 UTC
I think the error bars disappear after saving/reopen because it messes up the sheetname. After reopen, if you go to "Format Y Error Bars", you will see it changed from say "C5:C6" to "c5:sheet1.c6". If I change that to "sheet1.c5:sheet1.c6", then the error bars are retained after save/close/open.
Comment 24 Markus Mohrhard 2013-03-03 07:05:29 UTC
(In reply to comment #23)
> I think the error bars disappear after saving/reopen because it messes up
> the sheetname. After reopen, if you go to "Format Y Error Bars", you will
> see it changed from say "C5:C6" to "c5:sheet1.c6". If I change that to
> "sheet1.c5:sheet1.c6", then the error bars are retained after
> save/close/open.

Which version did you use for your tests? In my current master build I can open your file without problems.

And after having seen some similar errors recently, do you use a version where the default sheet name is not Sheet?
Comment 25 Not Assigned 2013-03-03 08:16:59 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bf0e0f88563377ee6f2db26970d3199c08acaa38

and one more fix for error bar import, related fdo#60083



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 John Kuang 2013-03-04 00:22:28 UTC
Created attachment 75876 [details]
test ods file with bar graph and y-error bars created using cell range
Comment 27 John Kuang 2013-03-04 00:23:51 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > I think the error bars disappear after saving/reopen because it messes up
> > the sheetname. After reopen, if you go to "Format Y Error Bars", you will
> > see it changed from say "C5:C6" to "c5:sheet1.c6". If I change that to
> > "sheet1.c5:sheet1.c6", then the error bars are retained after
> > save/close/open.
> 
> Which version did you use for your tests? In my current master build I can
> open your file without problems.
> 
> And after having seen some similar errors recently, do you use a version
> where the default sheet name is not Sheet?

I haven't uploaded any file here before. But I just did.

This was tested on 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985). I am attaching a simple chart with y-error bars using cell range. The y-error bars were created using Cell Range, and for parameter I manually typed in "D7:D8" since clicking on "select data range" doesn't do anything (Bug 60253). The bars became visible, and then I saved the ODS file. This file is what I have uploaded without any more modification.

Now, when I close and open this file again, the error bars are no longer visible. And under "Format y-error bars", in place of "D7:D8", it shows as "d7:sheet1.d8".

I will repeat this test with the latest daily and report back.
Comment 28 John Kuang 2013-03-04 00:28:05 UTC
(In reply to comment #27)

No change in 4.1.0.0.alpha0+ (Build ID: c1f8861c12e2f66592330a2926db840ede16ea8). Exactly as described in comment #27.
Comment 29 Markus Mohrhard 2013-03-04 07:40:30 UTC
Can you please open a new bug report for it. It is a different bug as it is an export and not an import bug. Thanks.
Comment 30 John Kuang 2013-03-04 08:05:44 UTC
(In reply to comment #29)
> Can you please open a new bug report for it. It is a different bug as it is
> an export and not an import bug. Thanks.

Opened Bug 61781 per your request.
Comment 31 Commit Notification 2013-03-04 12:01:24 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=53630966cca9f88cff01c6607abc7e6ed0cca877

another fix for error bar import, related fdo#60083



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2013-03-06 10:32:22 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=abcba0e9260aa3164b3c1a7e6ea741de5e1931b9&h=libreoffice-4-0

and one more fix for error bar import, related fdo#60083


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 Commit Notification 2013-03-06 10:38:48 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9a1860a28e2e183b67338a47f8cb37d4e896cc42&h=libreoffice-4-0

another fix for error bar import, related fdo#60083


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 John Kuang 2013-03-07 19:23:00 UTC
*** Bug 56730 has been marked as a duplicate of this bug. ***
Comment 35 Markus Mohrhard 2013-03-09 13:20:06 UTC
Looks like all parts are fixed now.
Comment 36 Björn Michaelsen 2013-06-26 18:19:02 UTC
The buggy pain of errorbars is already reproducable in 3.6.0 after scrolling once, thus setting version to 3.6.0 release -- _no_ minor release regression.