Download it now!
Bug 60253 - Unable to select data for error bars in calc
Summary: Unable to select data for error bars in calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Markus Mohrhard
URL:
Whiteboard: target:4.1.0 target:4.0.2
Keywords:
: 60484 61920 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-03 20:59 UTC by Mike Sobieraj
Modified: 2013-03-16 00:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Sobieraj 2013-02-03 20:59:25 UTC
when trying to add error bars from the sheet when clicking on the icon where one is normally able to then select the data from the sheet, one is not taken back to the spread sheet to select the range of cells by highlighting them.  It does work if you manually type the ranges in.  Also, when copying the chart into writer the error bars are lost
Comment 1 Joel Madero 2013-02-04 18:14:21 UTC
Adding Markus.

Markus - opinion?

@Reporter - the second issue is known and reported, I thought it was fixed by Kohei or Markus. Please try to keep bug reports separate as this is two bugs reported in one go :-D Thanks!
Comment 2 John Kuang 2013-02-06 20:13:13 UTC
I noticed this too in the RC3. Error bars doesn't seem to get much love on LibreOffice :(
Comment 3 John Kuang 2013-02-06 20:18:40 UTC
Joel, I think the bug that you said got fixed by Kohei is actually about the bars (Y-values) themselves disappearing in Bug 58562, not error bars. Mike is saying that the error bars disappear after copy/paste into writer, probably related to Bug 52159.
Comment 4 Joel Madero 2013-02-06 20:25:12 UTC
@John - thanks for the clarification and for confirming this one. Maybe Kohei needs to be involved with this. Is it a regression?
Comment 5 Markus Mohrhard 2013-02-06 20:49:13 UTC
This is another one for me. I'm already looking into another error bar regression.
Comment 6 Joel Madero 2013-02-06 21:25:43 UTC
Markus - do you want a bibisect of this one?
Comment 7 Markus Mohrhard 2013-02-07 16:53:42 UTC
(In reply to comment #6)
> Markus - do you want a bibisect of this one?

Just a quick check if that works in 3.6 would be the first step. If it works a bibisect would be nice.
Comment 8 John Kuang 2013-02-07 18:17:51 UTC
I submitted a new bug for the 2nd bug that Mike talked about.
https://bugs.freedesktop.org/show_bug.cgi?id=60435
Comment 9 Commit Notification 2013-03-04 12:57:28 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1f810b3adf030d4e20e71845bd6368b119a53bc7

we need to use GetParentDialog nowadays, fdo#60253



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-03-04 13:15:02 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=68bc2384a250d3b6cb3017ba91c0dac5e8b6707f&h=libreoffice-4-0

we need to use GetParentDialog nowadays, fdo#60253


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Markus Mohrhard 2013-03-10 01:21:03 UTC
*** Bug 61920 has been marked as a duplicate of this bug. ***
Comment 12 Markus Mohrhard 2013-03-16 00:08:34 UTC
*** Bug 60484 has been marked as a duplicate of this bug. ***