Download it now!
Bug 67369 - EDITING: "Select all" only selects table if that table is at top of document
Summary: EDITING: "Select all" only selects table if that table is at top of document
Status: RESOLVED DUPLICATE of bug 37606
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-26 19:54 UTC by crxssi
Modified: 2013-07-28 06:20 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description crxssi 2013-07-26 19:54:02 UTC
If a table is the first thing in a Writer document, you cannot use "file->select all" (or control-) to select the entire document, even if you are outside the table.

Steps to reproduce:

* Start a new Writer document
* Insert a table
* Go outside the table at the end of the document and type some stuff
* Leave the cursor in the text outside the table
* Use File->Select All or press control-A to attempt to select everything
* Notice that only the table is selected.  If you try Control-A again, there is no change.

Work-around:

* In the above example, insert a blank line before the table.
* NOW you can select the whole document by clicking outside the table and using File-Select All.

We encountered this bug in LO 4.1, and then discovered it is in LO 4.0, OO 3.4, and OO 3.2.1.  So it has probably been around a loooong time.
Comment 1 Cor Nouws 2013-07-26 21:59:32 UTC
(In reply to comment #0)

> We encountered this bug in LO 4.1, and then discovered it is in LO 4.0, OO
> 3.4, and OO 3.2.1.  So it has probably been around a loooong time.

Hi,

thanks for writing. Indeed it's very old behaviour, related to the way table-text object are handled in the document. Ah well. Not easy to change.

(Happily, when you work with styles properly, Ctrl-A is not needed that often ;) )

Regards,
Cor
Comment 2 Ivan Timofeev (retired) 2013-07-28 06:20:19 UTC

*** This bug has been marked as a duplicate of bug 37606 ***