Bug Hunting Session
Bug 67372 - control for setting UI font size, please add one
Summary: control for setting UI font size, please add one
Status: RESOLVED DUPLICATE of bug 101646
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: https://wiki.documentfoundation.org/D...
Whiteboard:
Keywords:
Depends on:
Blocks: Options-Dialog-View
  Show dependency treegraph
 
Reported: 2013-07-26 20:13 UTC by Yury
Modified: 2019-01-15 18:42 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yury 2013-07-26 20:13:48 UTC
Fonts have different internal size parameters, which results in drastically different screen sizes when selecting different fonts for UI (by means of Font substitution table).

Please add an appropriate control in the 'Fonts' dialog, on the lines of the 'source text font size' control.
Comment 1 Yury 2013-08-10 06:27:08 UTC
I mean there *ought* to be something like field for the point size of the (resulting) UI font.

Also, the obvious place for such field would be the 'LibO->View' dialog, but as the field for program source font size is already put into the 'LibO->Fonts' dialog, the UI font size field might as well be put there.
Comment 2 Thomas Lendo 2018-10-29 20:51:51 UTC
It seems nobody has confirmed the bug. So I set it back to UNCONFIRMED.

Also I add keyword needsUXEval to have more input if this is desired.
Comment 3 Cor Nouws 2018-11-07 16:56:31 UTC
Hi Yury,

Is your aim to influence the font size, or the UI size, or ..
Sorry that I don't understand that.
Cor
Comment 4 Yury 2018-11-07 17:14:38 UTC
Hi, 

I wanted UI font size to be configurable (maybe UI fontface too), but as the LO's UI font itself isn't influenced anymore by anything in the LO's settings, I think this issue could be closed now as irrelevant.
Comment 5 Thomas Lendo 2018-11-07 23:19:12 UTC
Closing as Resolved Worksforme according to comment 4 and the design meeting from today.
Comment 6 Stefano 2019-01-15 18:24:29 UTC
The issue seems to be still open and affecting users.
See discussion here:
https://ask.libreoffice.org/en/question/146190/increase-font-size-of-calc-formula-toolbar-in-libreoffice-version-6/
Comment 7 Stefano 2019-01-15 18:27:52 UTC
Also, there's a related bug report:
https://bugs.documentfoundation.org/show_bug.cgi?id=101646
Comment 8 V Stuart Foote 2019-01-15 18:42:20 UTC
Resolution of this depends on dev efforts against bug 101646 and dupes, rather than WF or WFM will dupe there.

*** This bug has been marked as a duplicate of bug 101646 ***