Bug Hunting Session
Bug 67373 - control for setting formula source font size, please add one
Summary: control for setting formula source font size, please add one
Status: RESOLVED DUPLICATE of bug 32419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-26 20:15 UTC by Yury
Modified: 2014-08-28 11:31 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yury 2013-07-26 20:15:21 UTC
Formula source font face and size seem to be controlled internally, which isn't always convenient.

Please add an appropriate control in the 'Fonts' dialog, on the lines of the 'source text font size' control.
Comment 1 Owen Genat (retired) 2013-12-09 02:36:17 UTC
This report is likely related to these enhancement requests:

- Bug 33827, Implement styles for formulae
- Bug 32419, get "Base size" for formulas from underlining paragraph

The first would probably solve the issue reported here, while the second is an alternate method of handling the problem. Component set to Formula Editor. Version set to Inherited From OOo as this functionality has never existed.
Comment 2 Yury 2013-12-09 09:53:04 UTC
Thank you :)

The #33827 would be an ideal solution, but obviously it is *not* going to be implemented, not even "any time soon".

The #32419 would be as good as what I propose. My proposal *might* be wee bit more logical w/r to the look-and-feel (font settings grouped with font settings).

I'm using the python variation of easyhack mentioned in #32419. Mind you, it stopped working at least in libreoffice 4.1 and libreofficedev 4.2. API changed or something. Can't find my comment and screenshot, though.
Comment 3 Owen Genat (retired) 2014-01-06 10:26:06 UTC
Setting version back from "Inherited From OOo" to what it was prior (for bugs marked enhancement), for QA tracking purposes. My mistake. Apologies.
Comment 4 Owen Genat (retired) 2014-08-28 11:31:17 UTC
(In reply to comment #2)
> The #32419 would be as good as what I propose. My proposal *might* be wee
> bit more logical w/r to the look-and-feel (font settings grouped with font
> settings).

*** This bug has been marked as a duplicate of bug 32419 ***