Download it now!
Bug 67386 - VIEWING: Dagger (x) was not displayed
Summary: VIEWING: Dagger (x) was not displayed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-27 06:24 UTC by Ruslan
Modified: 2014-07-20 12:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Dagger (x) was not displayed (112.14 KB, image/png)
2013-07-27 06:24 UTC, Ruslan
Details
Document with problems at pages 9-10 (737.50 KB, application/msword)
2013-08-29 13:07 UTC, Ruslan
Details
LO 4.1.1 on Win7 64bit - dagger broken (229.11 KB, image/png)
2013-08-29 14:33 UTC, Ruslan
Details
LibreOffice 4.1.1 on WinXP SP3 PRO RU x86 (106.98 KB, image/png)
2013-09-09 07:44 UTC, Ruslan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan 2013-07-27 06:24:13 UTC
Created attachment 83076 [details]
Dagger (x) was not displayed

Document was saved in MSO2003 to "DOC" format.
Font: Times New Roman, 14.
Dagger not displayed in strings like "436x170x277" (See attached screen shot)
Comment 1 tommy27 2013-08-29 12:58:11 UTC
it would be useful to have the .doc file not just a screenshot.
can you attach it as well?
Comment 2 Ruslan 2013-08-29 13:07:52 UTC
Created attachment 84838 [details]
Document with problems at pages 9-10

Document with problems at pages 9-10
Sorry, but it is cyrillic
Comment 3 tommy27 2013-08-29 13:29:05 UTC
I correctly see the "x" character in the test document using LibO 4.0.4 and 4.1.0 final releases under Win7 64bit. 

LibO 4.1.1 final is out. try upgrading and see if the issue is still there.
Comment 4 Ruslan 2013-08-29 14:33:26 UTC
Created attachment 84846 [details]
LO 4.1.1 on Win7 64bit - dagger broken

Office was upgraded but nothing changed
Comment 5 tommy27 2013-08-29 18:09:30 UTC
mhhhh.... strange...

try this test: download the portable version from this link
https://bugs.freedesktop.org/show_bug.cgi?id=67386
(you should see the 4.1.0 release in the list)

put it on a USB key and test your .doc file in another PC.

this test is to see if the issue depends on your computer or not.
as said before I do not see any bug on my PC.
Comment 6 tommy27 2013-08-29 18:10:07 UTC
sorry... the right link is:
http://sourceforge.net/projects/winpenpack/files/X-LibreOffice/releases/
Comment 7 Jean-Baptiste Faure 2013-09-07 19:55:55 UTC
(In reply to comment #3)
> I correctly see the "x" character in the test document using LibO 4.0.4 and
> 4.1.0 final releases under Win7 64bit.

Me too with LO 4.1.3.0+ (build at home) under Ubuntu 13.04 with locale FR.

> LibO 4.1.1 final is out. try upgrading and see if the issue is still there.

So set status to NEEDINFO.

Best regards. JBF
Comment 8 Ruslan 2013-09-09 07:44:27 UTC
Created attachment 85484 [details]
LibreOffice 4.1.1 on WinXP SP3 PRO RU x86

Reproduced on other PC with Windows XP, full installation of office.
Comment 9 Jean-Baptiste Faure 2013-12-13 16:54:17 UTC
Hi Ruslan,
in your file, the dagger (x) is in Symbol font, not in Times New Roman.
Are your sure that this font is correctly installed on your systems?

Please, do the following in LibreOffice:
1/ open the file
2/ select the first dagger in "436x170x277" page 10
3/ right click and choose Character in the context menu
4/ in the font tab, you should read "The same font will be used on both your printer and your screen" if the font is found and used by LibreOffice.

Best regards. JBF
Comment 10 Commit Notification 2014-01-11 21:18:13 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4e4abd7e06425a468107a3f1ad6808a246cf2078

Related: fdo#67386 RtfSdrExport: fix crash by respecting size of aVertices



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 tommy27 2014-01-11 23:20:09 UTC
@Miklos

is it really this patch related to the current issue report?
I suspect mistyping of the bug number in the committ message
Comment 12 Miklos Vajna 2014-01-12 17:10:04 UTC
It's related in that the if you opened the .doc attachment of this bugreport and saved it as RTF, then LibreOffice crashed, and the above commit fixes that. So no, not a typo.
Comment 13 tommy27 2014-01-13 09:56:01 UTC
ok. sorry sorry the noise
Comment 14 Jean-Baptiste Faure 2014-07-20 12:29:10 UTC
Still works as expected in versions 4.2 and next 4.3.
No answer since more than 6 months, so closing as WorksForMe.

Best regards. JBF