Download it now!
Bug 67441 - CONFIGURATION: *.desktop files installed from Debian packages are with wrong user:group and permissions (workaround available)
Summary: CONFIGURATION: *.desktop files installed from Debian packages are with wrong ...
Status: RESOLVED DUPLICATE of bug 67388
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-07-28 17:52 UTC by Grigory Rechistov
Modified: 2013-08-07 17:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grigory Rechistov 2013-07-28 17:52:22 UTC
Problem description: 

Just installed LO4.1 on Ubuntu 12.04 x86_64. Discovered that I cannot open files either by clicking on them or by using xdg-open command. The error is that the corresponding .desktop files are not executable and do not belong to root.

Steps to reproduce:
1. Install LO4.1 from the official site DEB 64 bit files
2. Try to open a document file (of any type: ODT, DOC, ODP etc) by clicking on it - a warning gets issued, then, if confirmed, some strange messaged about failed update. No document is opened. 

3. Use command line xdg-open to see the message:

ggg@scilla:~/Texts$ xdg-open TWAR05015_WinHEC05\ VTx.ppt 
kioclient(1120) KDesktopFile::isAuthorizedDesktopFile: Access to ' "/opt/libreoffice4.1/share/xdg/impress.desktop" ' denied, not owned by root, executable flag not set. 

kioclient(1120)/kio (KRun): Unable to open replacement file for "/opt/libreoffice4.1/share/xdg/impress.desktop" "Not enough rights to write to folder" 

Upon examination of /opt/libreoffice4.1/share/xdg/ it turned out that all files inside it are owned by user:group 500:500 (not root) and are not marked as executable. Marking them as such with `sudo chmod +x /opt/libreoffice4.1/share/xdg/*` fixes the issue.


Current behavior:
No document file can be opened by clicking on it because LO4/1 cannot be started. Opening from already running instance is possible.

Expected behavior:

Clicking on documents allows to open them.
              
Operating System: Ubuntu
Version: 4.1.0.4 release
Last worked in: 4.0.3.3 release
Comment 1 Joel Madero 2013-07-28 18:15:29 UTC
Did you completely purge LibreOffice before installing 4.1 from LibreOffice.org? Or did you install from PPA? 

Marking as NEEDINFO - I haven't seen this problem nor read about anyone else having the issue. Please completely purge everything related to LibreOffice then install from the PPA - we tend to suggest not installing from libreoffice.org if you have previously installed from your distros package manager because the TDF package can conflict with the packages from your distro.

If that doesn't solve your problem set the bug back to UNCONFIRMED and we'll test - but I run a Ubuntu based distro and haven't experienced it nor has several of the other QA members.

If it does resolve the problem please mark the bug as RESOLVED -> NOTABUG


Thanks!
Comment 2 Joel Madero 2013-07-28 18:16:29 UTC
Also by completely purge you need to get rid of the uno python package also - if you open synaptic and search for LibreOffice - almost everything that appears in the search needs to be purged prior to installing 4.1 - in the future we may warn users about installing from libreoffice.org and recommend to stick with your repos and official PPA to avoid these issues
Comment 3 Grigory Rechistov 2013-07-28 18:38:43 UTC
I did not use PPA, only the DEB-files I get from the official site. I also have nothing related to Libreoffice installed from official Ubuntu repos - I purged all stuff soon after the OS installation a couple of years ago.

Still, before installing 4.1 I did not uninstalled LO4.0 though - I thought this would be done automatically. Here's my events sequence:

0. Prerequisite: LO 4.0.3 is installed from the official website.
1. Download the 4.1 main installer and the Ru language pack from the official site.
2. Unpack stuff, cd DEBs/
3. dpkg -i *.debs # All packages from both main installer and language pack
4. Notice that LO4.0 data has not been removed as expected. When I did upgrades 4.0.x -> 4.0.y old packages got removed automatically, apparently this is not the case for 4.0.x -> 4.1.y upgrade.
5. Remove all LO4.0-related packages by hand.
6. Notice that .desktop files are with wrong permissions/owner:group

I don't feel like doing a complete LO4.1 reinstall as I have a workaround.

--
Maybe I should really switch to using PPA instead to save myself from a need to download/unpack/install every time a LO update is ready.
Comment 4 Owen Genat (retired) 2013-07-31 04:12:07 UTC
I am confirming this bug. I noticed this at the time of install, but thought nothing of it (i.e., that it was intentional) because under Crunchbang 11 / Openbox running TDF/LO v4.1.0.4 Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28 it all appears to work fine (I don't use desktop icons). Here is what ls reveals:

$ ls -l /opt/
total 4
drwxr-xr-x 8 500 500 4096 Jul 27 17:34 libreoffice4.1
$ ls -l /opt/libreoffice4.1/
total 1268
-rwxr-xr-x  1 500 500  63838 Jul 24 03:21 CREDITS.odt
drwxr-xr-x  2 500 500   4096 Jul 27 17:34 help
-rw-r--r--  1 500 500 436216 Jul 24 03:21 LICENSE
-rw-r--r--  1 500 500 603074 Jul 24 03:21 LICENSE.html
-rwxr-xr-x  1 500 500 141186 Jul 24 03:20 LICENSE.odt
-rwxr-xr-x  1 500 500   4907 Jul 24 03:21 NOTICE
drwxr-xr-x  9 500 500   4096 Jul 27 17:34 presets
drwxr-xr-x  9 500 500  16384 Jul 27 17:34 program
drwxr-xr-x  2 500 500   4096 Jul 27 17:34 readmes
drwxr-xr-x 23 500 500   4096 Jul 27 17:34 share
drwxr-xr-x  5 500 500   4096 Jul 27 17:34 ure
lrwxrwxrwx  1 500 500      3 Jul 24 03:20 ure-link -> ure
$ ls -l /opt/libreoffice4.1/share/xdg/
total 184
-rw-r--r-- 1 500 500 27010 Jul 24 03:21 base.desktop
-rw-r--r-- 1 500 500 21721 Jul 24 03:21 calc.desktop
-rw-r--r-- 1 500 500 20495 Jul 24 03:21 draw.desktop
-rw-r--r-- 1 500 500 23984 Jul 24 03:21 impress.desktop
-rw-r--r-- 1 500 500 19355 Jul 24 03:21 math.desktop
-rw-r--r-- 1 500 500  1078 Jul 24 03:21 qstart.desktop
-rw-r--r-- 1 500 500 23272 Jul 24 03:21 startcenter.desktop
-rw-r--r-- 1 500 500 26173 Jul 24 03:21 writer.desktop
-rw-r--r-- 1 500 500  5230 Jul 24 03:21 xsltfilter.desktop

There is no uid or gid of 500 defined on my system. I uninstalled the v4.0.4.2 debs using synaptic and manually installed v4.1.0.4 using dpkg. I use the LibreOffice_4.1.0_Linux_x86-64_deb.tar.gz download for the en_US locale.
Comment 5 Owen Genat (retired) 2013-08-03 12:34:16 UTC
Actually, this bug looks very much like a duplicate of the (now RESOLVED) bug 67388. Can this one be closed?
Comment 6 FBrown 2013-08-07 15:38:36 UTC
For KDE integration I think those desktop files also need to be made executable? Which that other bug does not seem to address as far as I can see?
Comment 7 Björn Michaelsen 2013-08-07 17:47:02 UTC
@Owen: Indeed, thanks.

*** This bug has been marked as a duplicate of bug 67388 ***