Download it now!
Bug 67450 - Very bad .docx document display
Summary: Very bad .docx document display
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: MultipleBugs
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-28 22:44 UTC by John
Modified: 2015-11-04 18:28 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
docx with bugs (1.62 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-07-29 10:28 UTC, John
Details
Document in LibreOffice Writer 4.1.0.4 (412.27 KB, image/png)
2013-07-29 14:17 UTC, BurnSpamAddress
Details
MS Word 2013 (205.09 KB, image/png)
2013-07-29 14:17 UTC, BurnSpamAddress
Details
LibreOffice 4.1 screenshot 1 (67.46 KB, image/png)
2013-07-31 23:58 UTC, John
Details
LO 4.1 screenshot 2 (80.77 KB, image/png)
2013-07-31 23:59 UTC, John
Details
LO 4.1 screenshot 3 (72.04 KB, image/png)
2013-07-31 23:59 UTC, John
Details
MS Word 2010 screenshot 1 (85.67 KB, image/png)
2013-08-01 00:00 UTC, John
Details
MS Word 2010 screenshot 2 (95.03 KB, image/png)
2013-08-01 00:00 UTC, John
Details
MS Word 2010 screenshot 3 (88.56 KB, image/png)
2013-08-01 00:01 UTC, John
Details
Large docx provided by the OP (user John) originally stored in UbuntuOne (3.86 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-22 16:13 UTC, Pedro
Details
Backtrace of crash on Windows (11.19 KB, text/plain)
2015-06-22 19:46 UTC, Buovjaga
Details
PDF showing what the document looks like under MS Office 2010 (1.67 MB, application/pdf)
2015-06-22 21:38 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John 2013-07-28 22:44:39 UTC
I will attach a document (created in MS Word) that Libreoffice cant display properly. I do it just to help developers fix it because contains a huge amount of bugs.

The document comes from a friends homework on "signal digital editing".
Comment 1 Cor Nouws 2013-07-29 08:38:47 UTC
Hi John,

Yes, please provide the sample document(s), but pls also give a clear description of what needs improvement. When possible, a screen shot of the situation in Word is great.
Thoses detailed reports have helped developers a lot over the past time to get where we are, and every extra step is good.
Regards,
Cor
Comment 2 John 2013-07-29 10:28:49 UTC
Created attachment 83193 [details]
docx with bugs

The file was too large and upload failed. I erased some content. I can not make the description more accurate because there isn't one bug on the docx but multiple. I provide the file to help you determine bugs.

Open it with MS Office 2010 and you can see the differences.
Comment 3 BurnSpamAddress 2013-07-29 14:17:31 UTC
Created attachment 83203 [details]
Document in LibreOffice Writer 4.1.0.4
Comment 4 BurnSpamAddress 2013-07-29 14:17:48 UTC
Created attachment 83204 [details]
MS Word 2013
Comment 5 BurnSpamAddress 2013-07-29 14:18:00 UTC
I am getting similar results on MS Word 2013 and LibreOffice 4.1.0.4 - see attached images. MS Word 2010 looks identical to 2013, so I didn't bother to attach that.

Something is seriously wrong with this document, and it's not obvious whether this is the fault of LibreOffice or something totally different.

Maybe a screenshot from your machine would help here?
Comment 6 John 2013-07-31 23:57:54 UTC
maybe the file is corrupt (cause i had to delete content in order to attach it). i will give you external link ( http://ubuntuone.com/3tq4ybEMtKvclYzWvO8wY4 ) so you can get it complete-untouched. i will attach here some screenshots too.
Comment 7 John 2013-07-31 23:58:36 UTC
Created attachment 83398 [details]
LibreOffice 4.1 screenshot 1
Comment 8 John 2013-07-31 23:59:09 UTC
Created attachment 83399 [details]
LO 4.1 screenshot 2
Comment 9 John 2013-07-31 23:59:35 UTC
Created attachment 83400 [details]
LO 4.1 screenshot 3
Comment 10 John 2013-08-01 00:00:01 UTC
Created attachment 83401 [details]
MS Word 2010 screenshot 1
Comment 11 John 2013-08-01 00:00:37 UTC
Created attachment 83402 [details]
MS Word 2010 screenshot 2
Comment 12 John 2013-08-01 00:01:07 UTC
Created attachment 83403 [details]
MS Word 2010 screenshot 3
Comment 13 Joel Madero 2013-08-01 18:25:51 UTC
Hi John - 

in the future when bug reporting please 

a) provide reproducible steps and any details about your system and LibreOffice version

b) a clear summary of the bug "very bad" doesn't give us much to work with ;)


Trying to reproduce now - thanks for the report
Comment 14 Joel Madero 2013-08-01 18:28:09 UTC
@John - can you attach the untouched one here also? Seems like Ubuntu one is down, we don't like relying on outside infra for attachments because of these kinds of issues.
Comment 15 John 2013-08-01 19:36:19 UTC
a)I wish i could but bugzilla doesnt allow files with such size to be uploaded. I will have to delete content again and i dont know how much that affect the document.

b)Sorry for the description.
Comment 16 Joel Madero 2013-08-01 19:42:36 UTC
No worries - thanks for the update

With it behaving weird on MSO 2013 also I have my doubts about the file. Going to request some input.
Comment 17 Pedro 2013-12-01 07:05:26 UTC
I can confirm that

1) The document linked from ubuntuone named "complicate docx.docx" is 4.045.510 bytes in size and is a good sample

1) The document attached as "docx with bugs" (file BUG.docx) is the result of saving the original file with some old version of LO (possibly 3.5.7) and is useless for testing

3) Document "complicate docx.docx" loads correctly under MS Office 2010 and even under MS Office 2003 (with file conversion)

4) Document "complicate docx.docx" formatting is broken under LibreOffice 4.1.4.1

5) "LO 4.1 screenshot 3" from the 4th page of the document is a good reference. The schemes on top should be in page 3 (shown in "MS Word 2010 screenshot 3")

6) In addition to all the changes in the position of elements, the screenshots from the Hellenic (aka Greek) LO also show that there is a problem in displaying some math elements E.g. the squares in the formulas in "LO 4.1 screenshot 3" should be an Epsilon or Sum symbol; the vertical curved brackets in "LO 4.1 screenshot 2" are missing (compare with "MS Word 2010 screenshot 2")

7) The missing math symbol problem does not occur in my PC using LO 4.1.4.1 en_US under Windows XP Pro x86 SP3

8) Loading "complicate docx.docx" in LO 3.5.7, 3.6.7 and 4.0.6.2 shows different problems. There were progresses and regressions...
Comment 18 Joel Madero 2013-12-01 07:31:50 UTC
It sounds like this is a lot of bugs in one document. If at all possible it would be nice to isolate the problems and report 1 bug report for 1 problem. 

Pedro - am I correct in this assumption? If so, might be best to close as INVALID and narrow down the issue(s) so that it's a functional bug report for our developers. If you think that this is impossible then that's fine, but it's much harder to find a developer to tackle a meta bug than individual bugs.


Thanks all
Comment 19 Robinson Tryon (qubit) 2014-02-03 18:23:05 UTC
(In reply to comment #18)
> It sounds like this is a lot of bugs in one document. If at all possible it
> would be nice to isolate the problems and report 1 bug report for 1 problem. 

Whiteboard: MultipleBugs

Joel -- I managed to download the entire document from UbuntuOne, so one of us can go through and try to generate some smaller test documents that exercise just a single bug each. I'll try to get to that soon, if you don't beat me to it :-)

For now, I'll leave this open as a reminder to split-up the test cases. Once each of those individual bugs is fixed, the entire document should render properly, and then we can close this bug as well.
Comment 20 Joel Madero 2015-05-02 15:44:16 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 21 Pedro 2015-06-22 16:13:25 UTC
Created attachment 116737 [details]
Large docx provided by the OP (user John) originally stored in UbuntuOne

I never received Comment #18 because I was not in CC
Comment 22 Buovjaga 2015-06-22 19:46:34 UTC
Created attachment 116741 [details]
Backtrace of crash on Windows

complicate_docx.docx crashes consistently on Windows, LibO 5.1.
Does not crash on Win LibO 4.4 or Linux LibO 5.1

On the ones that it opens, there are continuing flashes of graphics at the top left of the first page.

Win 7 Pro 64-bit, Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fi_FI

Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)

Ubuntu 15.04 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-06-20_00:06:19
Locale: en-US (en_US.UTF-8)
Comment 23 Pedro 2015-06-22 21:38:42 UTC
Created attachment 116743 [details]
PDF showing what the document looks like under MS Office 2010

This is a 115 page PDF document. Opening this file in LibreOffice (any version including 5.0.0.1) has so many differences that a PDF is the only way to actually see what the author expects the document to look like.
Comment 24 Pedro 2015-06-22 21:42:28 UTC
(In reply to Pedro from comment #23)
> Opening this file in LibreOffice (any
> version including 5.0.0.1) has so many differences that a PDF is the only
> way to actually see what the author expects the document to look like.

Just to make it clear: I meant opening the docx file in LibreOffice, not the PDF.
Comment 25 Timur 2015-11-04 18:28:39 UTC
Problems with rendering exist, BUT:
- it's highly unlikely that any bugs of type "multiple problems/bad rendering", will be fixed
- each issue (section break, paragraph break, text box, picture...) should be reported separately, after a search for already reported bugs
- if bugs don't exist, they should be reported separately, even if they happen with the same file

So, this shouldn't have been confirmed at all. I'll close this one as Invalid.
I kindly ask you to reduce the file to minimum test case for a specific problem (like saving a single page that shows a problem) - if needed multiple times, of course after a search.

Another problem is that LO master 2015-11-03 doesn't open the file (seh exception: access violation), but luckily LO 5.0.3.2 does, so it can be used.
I reported that as Bug 95579.