Bug 67453 - FILEOPEN: Loading some .odg files will crash LibreOffice 4.0.4.2
Summary: FILEOPEN: Loading some .odg files will crash LibreOffice 4.0.4.2
Status: RESOLVED DUPLICATE of bug 60075
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2013-07-29 03:44 UTC by Marc Pare
Modified: 2015-12-17 07:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File name says it all. -- Marc (1.32 MB, application/vnd.oasis.opendocument.graphics)
2013-07-29 03:44 UTC, Marc Pare
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Pare 2013-07-29 03:44:53 UTC
Created attachment 83160 [details]
File name says it all. -- Marc

Problem description: 

Steps to reproduce:
1. Load a particular .odg file with LibreOffice closed (double-click on file)
2. LibreOffice will try to load the file, but close instead of load it

3. Alternatively, start LibreOffice
4. Try to open .odg file
5. LibreOffice will not load file and remain on empty page

Expected behavior:

Should open file instead of crashing or remaining on a blank page. It crashes the 4.0.x branch BUT works fine on our new 4.1.x branch.

This topic was discussed on the user list, introduced by a user and I confirmed it was indeed crashing 4.0.4.2 . See [http://permalink.gmane.org/gmane.comp.documentfoundation.libreoffice.user/30003]

              
Operating System: All
Version: 4.0.4.2 release
Comment 1 Joel Madero 2013-07-29 04:48:51 UTC
No crash for me but it doesn't open with 4.0.4 opens fine with 4.1 

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

In general we'd like more info when someone is reporting someone else's bug - and we'd prefer the actual reporter to report so they can answer these types of questions directly - examples include:

How was the file made? LibreOffice (if so what version?), openoffice (if so what version?), some other software (if so what software, what version)

What OS is experiencing the crash? Like I said, for me no crash, just doesn't open, LibreOffice continues to work fine

Did it work on previous versions of 4, or any other version for that matter prior to 4.1 for reporter? 

Also it's good for users to get a bugzilla account and get comfortable with our system so that they can report future problems - else they start thinking they can just report on the ML and get action - which is not the case - QA rarely monitors the list and we don't want users getting false expectations
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

That being said because I can confirm it won't open on some versions of 4 I went ahead and bibisected - since it's been fixed someone will need to cherry pick the fix for 4.0 release



9a5620ca6473969359f262802c76daf35cbcbb5d is the first bad commit
commit 9a5620ca6473969359f262802c76daf35cbcbb5d
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue Dec 11 01:59:31 2012 +0000

    source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
    
    commit ae4e4a11d4300f7448cb6bd170fcb034542caddc
    Author:     Rene Engelhard <rene@debian.org>
    AuthorDate: Tue Nov 6 21:24:32 2012 +0100
    Commit:     Rene Engelhard <rene@debian.org>
    CommitDate: Tue Nov 6 21:24:32 2012 +0100
    
        typo...
    
        Change-Id: I2c7968194afbcf74967cd16c639dce7de858a513

:100644 100644 c09b92a8ddf24b8738a7cd3a695ae1e4482d354c 6b13afd13f023cedac65a896318de4aa55dead27 M	autogen.log
:100644 100644 bcee1e11bd693642ca5a6330175b58082e5dcdd0 54d2377f5b3afd6ed668b3e24cb877c289119ec5 M	ccache.log
:100644 100644 75677cef16786d2cc95c0d8f301482278ca055c3 d18a6ebcd3b8537c3dd3dbc16e862fb6370ecb8a M	commitmsg
:100644 100644 83b4ecc0ecb3e031c804d49f45f854e95d5cc961 d482c00e5fff6081c6b87b637fd9ffaf3e1e2c6c M	dev-install.log
:100644 100644 91437b9974ffada7e049273419bb8c66c91c0539 abf45ab9609c77a5ab952aa310eafe8c2ffaf85c M	make.log
:040000 040000 45c0bab8b669778ab523c8f65a25e8c9afde604a f4bfa15b2f72d3df5675b07bcf32254a819b9d19 M	opt



# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect good 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# good: [f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect good f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a
# good: [114fd3b76bcba890e6d702d00cef910f1493c262] source-hash-64ab96cd15e52da88781e720d6f031dbcd0ba902
git bisect good 114fd3b76bcba890e6d702d00cef910f1493c262
# bad: [47498a36f7af8f54e6e3dda89cd4708802a409e6] source-hash-19f4ebd8a54da0ae03b9cc8481613e5cd20ee1e7
git bisect bad 47498a36f7af8f54e6e3dda89cd4708802a409e6
# good: [f4e2d84db194943180f3e7ed4adce5f8e377d9bc] source-hash-806d18ae7b8c241fe90e49d3d370306769c50a10
git bisect good f4e2d84db194943180f3e7ed4adce5f8e377d9bc
# bad: [fb4214f9d134b556582a4a5280e5458de5f8eebd] source-hash-683758efb22d08a4cf211a6d985148f513da2a90
git bisect bad fb4214f9d134b556582a4a5280e5458de5f8eebd
# good: [e2e46267c18c2706de771a08472ebfce19f68520] source-hash-4316e643ef345b0f673b4a03a80a4b7cb3185588
git bisect good e2e46267c18c2706de771a08472ebfce19f68520
# bad: [9a5620ca6473969359f262802c76daf35cbcbb5d] source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
git bisect bad 9a5620ca6473969359f262802c76daf35cbcbb5d




Thanks Marc for reporting - wasn't trying to lecture you as I obviously know that you're a contributor to the project - just trying to make sure that QA gets what they need and that users learn how to do things the right way instead of bugs through ML - which I see occasionally but I tend not to do more than say "you should report this on FDO" and link to the how to report a bug wiki.
Comment 2 Joel Madero 2013-07-29 04:49:37 UTC
@Thorsten - can you use the bibisect to try to figure out what patch fixed it on 4.1 and see if we can backport it to the 4.0 branch?
Comment 3 Marc Pare 2013-07-29 06:35:56 UTC
The file was not sent in by the original reporter on the mailing list but another user sent me a file but did not want to be involved with the bug reporting. No idea why.

Marc
Comment 4 David Tardon 2013-07-29 08:35:56 UTC

*** This bug has been marked as a duplicate of bug 60075 ***
Comment 5 Robinson Tryon (qubit) 2015-12-17 07:16:56 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]