Download it now!
Bug 67463 - LibreOffice 4.0.4 always chooses paper from tray 1 and ignores settings
Summary: LibreOffice 4.0.4 always chooses paper from tray 1 and ignores settings
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-07-29 09:35 UTC by Björn Michaelsen
Modified: 2015-12-15 22:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2013-07-29 09:35:03 UTC
This seems to be a minor release regression in 4.0.4 vs. previous 4.0 versions:
"The pre-installed LibreOffice 3.6(?) of Ubuntu 12.04 has a bug and the paper tray selection does not work. It chooses always the paper from tray 1.

Therefore I installed LibreOffice 4.0 from ppa libreoffice-4-0. And this version worked correctly concerning the paper tray selection until now - the current version 4.0.4.2 AGAIN BROKE this feature - again everything is printed from tray 1!"

https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1196263

possibly related:
https://bugs.freedesktop.org/show_bug.cgi?id=61186
https://bugs.freedesktop.org/show_bug.cgi?id=43932
Comment 1 Winfried Donkers (retired) 2013-07-29 09:49:22 UTC
(In reply to comment #0)
@Björn: Shouldn't the version number of this bug be 4.0.4.2 release?

As I haven't ubuntu I can't confirm the bug itself.
Comment 2 Michael Meeks 2013-07-29 10:20:05 UTC
So - the claim is that the change is in the 4.0.3 to 4.0.4 range ?

git log --numstat libreoffice-4.0.3.3..libreoffice-4.0.4.2

167 commits to bisect I guess - but I'd check that 4.0.3 actually does work ;-) Only one commit actually looks even remotely related to printing:

commit 0b39358aaf723b26b5effb7245f38ad960cc609a
Author: Jan Holesovsky <kendy@suse.cz>
Date:   Wed Apr 24 16:15:19 2013 +0200

    fdo#59259: Suppress the expensive parts when we are only writing to metafile.

So I'm suspicious of the claimed range personally.
Comment 3 Cor Nouws 2013-07-29 10:40:05 UTC
don't forget to do a query on "paper" and "print" before starting ..
Comment 4 Björn Michaelsen 2013-07-29 11:40:19 UTC
@Winfried: Whops indeed -- fixed.

@Michael: No, so far the claim is that it worked with _some_ 4.0.x version, so the range is 4.0.0 to 4.0.4. I asked to clarify on the downstream bug.

Note that given how much we use an external print stack on this, before its confirmed hard that going back to 4.0.0 fixes this, its entirely possible that some other package update broke this. Still -- if it would be us, its a minor release regression.
Comment 5 Robinson Tryon (qubit) 2013-10-16 03:16:58 UTC
Changing 'regression' -> 'PossibleRegression' until we get independent confirmation.
Comment 6 retired 2013-12-21 21:27:04 UTC
Björn just a ping. Does this persist with 4.2.0.1?
Comment 7 retired 2013-12-29 01:40:32 UTC
Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 8 QA Administrators 2014-07-08 17:29:13 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 9 Björn Michaelsen 2014-07-12 19:53:22 UTC
Closing as WFM as per:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1196263/comments/15
Comment 10 Robinson Tryon (qubit) 2015-12-15 22:05:16 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]