Bug 67466 - Writer doesn't remember scale if you don't save the document
Summary: Writer doesn't remember scale if you don't save the document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Zoom-Issues
  Show dependency treegraph
 
Reported: 2013-07-29 10:05 UTC by moray33
Modified: 2017-07-26 14:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description moray33 2013-07-29 10:05:54 UTC
When I open a document, it's always showed with 100% scale. If I change the scale and close the document, the next time I open that document (or any) the scale is set to 100% again.
Comment 1 Jorendc 2013-08-06 19:46:22 UTC
I can not reproduce this behavior, tested using ODT and .docx file format with Windows 8 and LibreOffice Version: 4.1.0.4 Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

@bug reporter: what document format did you use? Can you reproduce this from scratch to, or did you only try with an existing document?

Kind regards,
Joren
Comment 2 Jorendc 2013-08-06 20:12:08 UTC
Ah dangit, tested this one wrong. LibreOffice just remember it, it doesn't store it in the file. Opening a new document result also in the zoom-scale I exit it the last time :).

PS ... not sure we can store it in the files. Our native/"own" file extension is ODT for text documents. Not sure there is such thing to store it.

@Michael: is this allowed in ODF/ODT :)? If not we can close this bug I guess.

Thanks in advance,
Joren
Comment 3 moray33 2013-08-06 20:24:38 UTC
If I change the scale but I don't do any change in the document and save it, it doesn't remember the new scale, it remembers the scale of the last time it was saved.
Comment 4 moray33 2013-08-07 09:51:23 UTC
Plus, I just found the cause of the 'original' problem I wanted to report.

In the office, I have 3 Windows PC with LibreOffice. One of them has one directory shared and we work there from all the PCs. In that directory, from a client PC LibreOffice doesn't remember the scale of .DOC files. With .ODT and .DOCX works 'well' (I have to save it to remember a new scale as I said in the previous message), but it always open .DOC with 100% scale.

It worked well in 4.0
Comment 5 Jorendc 2013-08-07 09:53:50 UTC
(In reply to comment #4)
> Plus, I just found the cause of the 'original' problem I wanted to report.

Please create another bug report for that.
Comment 6 moray33 2013-08-07 14:00:20 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Plus, I just found the cause of the 'original' problem I wanted to report.
> 
> Please create another bug report for that.

Ok, done: https://bugs.freedesktop.org/show_bug.cgi?id=67870
Comment 7 QA Administrators 2015-04-01 14:42:44 UTC Comment hidden (obsolete)
Comment 8 moray33 2015-04-01 21:07:16 UTC
Still present in LO 4.4.1.2
Comment 9 tommy27 2016-04-16 07:25:35 UTC Comment hidden (obsolete)
Comment 10 moray33 2016-04-16 14:02:01 UTC
Still present in LO 5.1.0
Comment 11 QA Administrators 2017-05-22 13:27:07 UTC Comment hidden (obsolete)
Comment 12 Timur 2017-06-30 15:48:25 UTC
This is not a proper bug report. On reading, I'm not clear what this bug is about. 
Report needs to be clear with all details, preferably in a single post, without a need for multiple explainations: 
REPRODUCED: _______
EXPECTED: _______

If it's like this:
REPRODUCED: Writer doesn't remember zoom-scale of a document if you don't save it
EXPECTED: LibreOffice remembers last zoom-scale of a document, regardless if it was saved

than I don't find this a justified request. It is not explained why and how LO would remember a zoom state of all the documents it ever opened. 
In my case, I want to have only what's saved.
To get that answer, I set back to Needinfo.
Comment 13 moray33 2017-07-06 12:00:57 UTC
The thing is sometimes you download or receive a document and you don't want to actually modify it but you want to see it in a different scale. When I reported this bug you couldn't change the scale and save the document, you had to change something in the document in order to save the changes. Now you can save the document whenever you want, so I think that will do.
Comment 14 Timur 2017-07-06 12:13:34 UTC
So I'll close as WorksForMe.