Download it now!
Bug 67470 - Element Dock: Subset icon missing in Set Operation section
Summary: Element Dock: Subset icon missing in Set Operation section
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium normal
Assignee: Jorendc
URL:
Whiteboard: target:4.1.1 target:4.2.0
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2013-07-29 11:27 UTC by grofaty
Modified: 2015-12-18 10:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
subset_missing_fromo_elements_dock_window (65.27 KB, image/png)
2013-07-29 11:27 UTC, grofaty
Details
subset_formula_4_1_1 (109.95 KB, image/png)
2013-09-16 11:57 UTC, grofaty
Details
set_operator_fixed_on_windows.png (53.07 KB, image/png)
2013-10-16 10:18 UTC, grofaty
Details

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2013-07-29 11:27:21 UTC
Created attachment 83196 [details]
subset_missing_fromo_elements_dock_window

In LibreOffice 4.1 there is new Elements Dock feature in Formula.

1. Make sure From View | Elements Dock is checked.
2. From drop-down list selection select Set Operations.
3. Now compare Elements Dock window with Elements window and you will see there is "supset" icon present in Elements window, but missing in Elements Dock window.

P.S. See attached print-screen for details.

Tested on: LibreOffice 4.1.0.4 on Ubuntu 12.04 using ppa:libreoffice/ppa
Comment 1 Jorendc 2013-08-02 20:47:07 UTC
I can confirm this. I'm having a look at it now. I think I found the missing code.

Thanks for reporting!
Joren
Comment 2 Jorendc 2013-08-02 21:16:45 UTC
https://gerrit.libreoffice.org/#/c/5261/ awaiting approval
Comment 3 Commit Notification 2013-08-02 21:26:41 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c549ac677ba6279387aca33c5117b8ee1461bd9e&h=libreoffice-4-1

fdo#67470 Element Dock: Subset icon missing in Set Operation section


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2013-08-02 21:26:59 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d82433b0051a93632d66fdd6ab1df10166879c6e

fdo#67470 Element Dock: Subset icon missing in Set Operation section



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 grofaty 2013-09-16 11:57:54 UTC
Created attachment 85904 [details]
subset_formula_4_1_1

I retested on LibreOffice 4.1.1.2 on Ubuntu 12.04 using ppa:libreoffice/ppa but this bug is still not fixed - the "subset" icon still does not appear in Element Dock dialog. See attachment.
Comment 6 grofaty 2013-09-16 11:59:33 UTC
I am REOPENING the bug.
Comment 7 Jorendc 2013-10-15 18:29:15 UTC
(In reply to comment #5)
> Created attachment 85904 [details]
> subset_formula_4_1_1
> 
> I retested on LibreOffice 4.1.1.2 on Ubuntu 12.04 using ppa:libreoffice/ppa
> but this bug is still not fixed - the "subset" icon still does not appear in
> Element Dock dialog. See attachment.

Is it possible to retest using a later version? Sadly I fail to reproduce this behavior :(, so I can't fix it if necessary.

Kind regards,
Joren
Comment 8 grofaty 2013-10-16 10:18:09 UTC
Created attachment 87725 [details]
set_operator_fixed_on_windows.png

I have retested on LibreOffice 4.1.2.3 on Windows XP and problem is fixed.

Can't test with the latest stable on Ubuntu 12.04, because PPA is currently not updated to the latest release. Currently it is still has 4.1.1.2.
Comment 9 Jorendc 2013-10-16 15:35:09 UTC
Thanks for your feedback.
Lets mark as RESOLVED FIXED again. Please feel free to retest on Ubuntu and comment again.

Kind regards,
Joren
Comment 10 Robinson Tryon (qubit) 2015-12-18 10:16:16 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval)
[NinjaEdit]