Bug 67487 - Please add non-blocking autosave
Summary: Please add non-blocking autosave
Status: RESOLVED DUPLICATE of bug 81627
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-29 15:43 UTC by S.
Modified: 2014-07-22 16:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. 2013-07-29 15:43:23 UTC
Hello,

Autosave on LibreOffice locks up the UI while it is running, even ignoring keystrokes. It is extremely annoying to be typing along at high speed without looking, only to realize that part of what you typed was ignored because autosave was running. On large documents, autosave often takes 5 to 10 seconds, during which nothing can be done. Or is this an anti-fatigue feature introduced to force the user to take a break from typing? ;-)

Thanks for looking into this.
Comment 1 Mike Kaganski 2013-08-04 10:50:07 UTC
This is a valid enhancement request. The interruption creates a very bad user experience. This enhancement would be very welcome.
Comment 2 Rafael Luik 2014-07-22 01:40:27 UTC
Haha "enhancement"?

If I type something or use a keyboard shortcut like Ctrl+D to fill some cells while AutoRecovery is autosaving the document, what I just typed is lost, DATA LOSS occurs. This is a bug, and I filed it as such: bug 81627.
Comment 3 V Stuart Foote 2014-07-22 16:28:49 UTC
Bug 81627 has more substantive discussion of this enhancement.

*** This bug has been marked as a duplicate of bug 81627 ***