Bug 67492 - No support for named range subaddressing
Summary: No support for named range subaddressing
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Name
  Show dependency treegraph
 
Reported: 2013-07-29 16:50 UTC by Tollef Fog Heen
Modified: 2020-09-01 18:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tollef Fog Heen 2013-07-29 16:50:52 UTC
In excel, you can use brackets with named ranges to do operations on them.   http://excelexperts.com/node/770 has some information on this.

It would be useful if LibreOffice had the same functionality.

If you need a sample spreadsheet, I can provide one, but it should be trivial to make one yourself.
Comment 1 Jean-Baptiste Faure 2013-12-13 17:40:02 UTC
What can be done this way that can't be done with matrix formula?

Best regards. JBF
Comment 2 Tollef Fog Heen 2013-12-13 18:53:32 UTC
Excel compatibility, since that's where I first ran into them.

In addition, I don't see how I can say "please give me the third column of the row named foo", but that might just be not understanding matrices properly.

(I don't know what the LO bug workflow is, so leaving as needinfo.)
Comment 3 QA Administrators 2014-07-08 17:29:24 UTC Comment hidden (obsolete)
Comment 4 Tollef Fog Heen 2014-07-08 19:11:23 UTC
Setting back to unconfirmed, since I believe I've provided the necessary information.
Comment 5 Joel Madero 2014-07-16 20:37:23 UTC
With the explanation it seems like a fine (althoug maybe difficult) enhancement request.

Marking as:
New
Enhancement
Low - probably not going to affect at on of users but for compatibility with MS Office seems appropriate to bump up from Lowest

@Tollef - a simple test document would indeed be nice to have. Always better to have a sample from the reporter than for many QA people to have to reproduce over and over again. Thanks!
Comment 6 Eike Rathke 2020-09-01 18:28:00 UTC
That feature is called Table Structured References and is implemented as of 5.0 to 5.1, see
https://wiki.documentfoundation.org/ReleaseNotes/5.0#Table_structured_references
https://wiki.documentfoundation.org/ReleaseNotes/5.1#Table_structured_references